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Chapter

INTRODUCTION

This Quick Start gives a brief overview of using the different components in MATFOR
version 4.0. Language considerations, the structure of programs, and the use of
advanced tools are all covered.

. PRODUCT DESCRIPTION

MATFOR is a set of numerical and visualization libraries developed to enhance
programming in C++ and Fortran environments. Especially designed for scientists
and engineers, MATFOR aims to accurately perform computation, dynamically
visualize data, and efficiently decrease process time. Its features include:

mfArray, a MATFOR defined data type that simplifies and facilitates
object-oriented programming in C++ and Fortran environments.

Numerical Library contains useful linear algebraic functions subject to assist
users with computational problem solving.

Visualization Library collects well-designed graphical procedures and controls
to support a variety of 2D and 3D visual functions.

Data Viewer, organized in spreadsheet format, is one convenient platform for
data management, filter, and analysis.

Graphics Viewer, besides its highly customized user interface, overthrows the
convention of post-processing as it instantly visualizes scientific and
engineering data.

mfPlayer animates simulation results by reading and displaying numerical data,
and further allows additional graphical manipulations.

Graphics Export converts dynamic presentation into standalone movie or
image files to enhance accessibility of simulation results.

GUI System facilitates application-building by allowing users to create an
interface of their preference.
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COMPILER REQUIREMENTS

MATFOR supports these compiler choices:

Platform and System Requirements

Platform Operating System C++ Compilers
+ Intel C/C++ 8.1/9.0/9.1
Intel Based . ¢ Visual C++ 6.0
32-bit systems | VINdoWs 98/NT/2000/Me/xP o Visual C++ NET 2003/2005
+ Borland C++ Builder 6.0
FedoraCore 1/2/3/4
Intel Based Red Hat Enterprise Linux 3.0/ 4.0 e GNU C++

32-bit systems

White-Box Enterprise 3
SuSE 9.1 Enterprise
Mandrake 10

¢ Intel C++ 8.1/9.0/9.1

EM64T/AMD64 ¢ GNU C++
64-bit systems ¢ Intel C++ 8.1/9.0/9.1

Fedora Core 2 /3
Red Hat Enterprise Linux 4.0

Due to constant updates of the compilers, these requirements are subjected to
change without further notice. Please refer to the latest version of compiler
requirements at http://www.ancad.com/requirements.html.

INSTALLATION

This section provides step-by-step instructions for installing MATFOR. If you
encounter any problems during the installation, please contact support@ancad.com.

WINDOWS INSTALLATION

e Pre-Installation

p wDdPE

Exit any of MATFOR programs executing;

Remove all previous versions of MATFOR components if this is an upgrade;
Ensure the compiler requirements are satisfied;

Obtain administrator rights under Windows 98/2000/NT/XP.

* Begin Installation

1.

Insert the MATFOR CD into the CD-ROM drive.

The standard MATFOR Installation Procedure shall start automatically. If the
Procedure fails to start, you may manually start it by double-clicking on the
MATFOR.exe file under the <CDROM>\Content\ path.

Follow the self-explanatory instructions in the Procedure to set up all MATFOR
components.

Specify a destination folder to create MATFOR through the Procedure.
By default, the Package creates a program group in your C drive under the


http://www.ancad.com/requirements.html
mailto:support@ancad.com
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path C:\Program Files\AnCAD\MATFORA4\.

e Set Environment Path

The Procedure automatically sets the $PATH and $MATFOR4DIR environment
variables.

To manually set the environment variables:

1.
2.

Go to Control Panel\System.

In the System Dialog Box, select the Advance label and click on the
Environment Variables tab.

In the System Variables Box, add <MATFOR4>\bin and <MATFOR4>\tools
to the [path] variable.

NOTE
<MATFOR4> shall specify the directory under which MATFOR s installed.
i.e. C:\\Program Files\AnCAD\MATFOR4

LINUX INSTALLATION

e Pre-Installation

o 0 bk wdhpE

Exit any of MATFOR programs executing.

Remove all previous versions of MATFOR components if this is an upgrade.
Ensure the OS Requirements are satisfied.

Ensure the Compiler Requirements are satisfied.

Obtain root rights under Linux OS.

Run the ‘rpm —ivh compat-libstdc++-33-3.2.3-47.3.i386.rpm’ command to
install the compat-libstdc++-33 package. (Optional)

* Begin Installation

Open a command shell.

Change the current directory to the one containing the
matfor_c-4.xx-i686.rpm Installer.

Run the ‘rpm —ivh matfor_c-4.xx -i686.rpm’ command.

Follow the self-explanatory instructions in the Procedure to set up all
MATFOR components. By default, the Installer creates a program group
under the path /usr/lib/matfor4.

* Environment Path Settings

The Procedure automatically sets the $PATH and $SMATFOR4DIR environment
variables.
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To manually set the environment variables:
1. Add the following lines to your ~/.bashrc file.

2. export MATFOR4DIR=/usr/lib/matfor4
export LD_LIBRARY_PATH=3$MATFORA4DIR/lib:$LD_LIBRARY_PATH
export PATH=$MATFOR4DIR/tools:$PATH

3. Runthe ‘source ~/.bashrc’ command or re-login your system.

IV. REGISTRATION

At the end of installation, you are required to enter the License Password for
registration, which can only be obtained by submitting the Host ID of your local
machine to AnCAD, Inc.

1. Go to http://www.ancad.com/activation.php to activate MATFOR product with the
Serial Number and Host ID information.

2. MATFOR license key should be sent to you through the email provided within 24
hours.

(Note: trial users may receive trial keys via email upon the receipt of download
request. Please go to http://webphp/download.php to submit your request.)

UNDER WINDOWS

The registration program can be launched from Start » Program Files p>
MATFOR4 P Utilities > Register MATFOR 4 in Fortran (or C++)

UNDER LINUX
o« Goto/usr/lib/matfor4d/tools.

« Type ./reg_xxx to launch the registration program.

V. FLOATING LICENSE & CLASSROOM LICENSE

To enable a group of developers to share a pool of licenses more efficiently, MATFOR
offers floating licenses and classroom licenses for cross-system/cross-platform
environments. The floating license is designed to be used in any shared network
environment; the classroom license is designed for the purpose of teaching in an
academic environment. Any project developed under MATFOR classroom license
may not be redistributed to a third party with profit interest or being a commercial
institution.


http://www.ancad.com/activation.php
http://webphp/download.php
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These license models consist of one or more license servers; the license server runs
the license management process and monitors number of concurrent users using
MATFOR licenses in the network. The installation steps are:

WINDOWS INSTALLATION

¢ |nstallation of License Servers

1.

Run license_server.exe (download from http://www.ancad.com/activation.php)
on machines designated as license servers.

Retrieve required information from the machine.
Under command prompt,

i.  Change directory to C:\Program Files\AnCAD\License Server.
ii. Execute Imtools to get Ethernet Address and Host Name.
Collect the following product information:

i. ~ Compiler version

ii. Operating system

iii. Number of license of each version

Obtain license file(s) for license server(s).

i. Go to http://www.ancad.com/activation.php to activate MATFOR with the
Serial Number and Host ID information.

ii. The license file(s) should be sent to you through the email provided within
24 hours.

5. Place the license file xxx.lic into <AnCAD=>\License Server directory.

6. To start the license server.

Under command prompt, type:
Imgrd —c xxx.lic or
Imgrd —c . for multiple license files.

* Configuration in Client Computers

1.

Install MATFOR on machines designated as clients.

2. Go to Start P> Program Files » MATFOR4 P Utilities P Register MATFOR.
3.
4. Fillin the Host Name or IP Address of the license server in the blank area. (IP

Under Registration Window, choose Network License.

Address can be obtained from the license server by typing Imhostid
-internet —n under command prompt.)

LINUX INSTALLATION


http://www.ancad.com/activation.php
http://www.ancad.com/activation.php
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¢ |nstallation of License Servers

1. Run license server executable file (download from
http://www.ancad.com/activation.php) on machines designated as license
servers.

tar zxf license_server.tar.gz —c /usr/lib

2. Retrieve required information from the machine.
Under command shell,

i. Goto/usr/lib/matfor_licsvr

ii. Type ./Imhostid —n to get Ethernet Address.

iii. Type ./Imhostid —hostname —n to get Host Name.
3. Collect the following product information:

i.  Compiler version

ii. Operating system

iii. Number of license of each version
4. Obtain license file(s) for license server(s).

i. Go to http://www.ancad.com/activation.php to activate MATFOR with the
Serial Number and Host ID information.

ii. The license file(s) should be sent to you through the email provided within
24 hours.

5. Place the license file xxx.lic into /usr/lib/matfor_licsvr directory.
6. Start the license server.

Under command prompt, type:

Imgrd —c xxx.lic or

Imgrd —c . for multiple license files.

* Configuration in Client Computers
1. Install MATFOR on machines designated as clients.
2. Goto /usr/lib/matfor4 and type ./reg_xxx
3. Under Registration Window, choose Network License.
4

. Fill in the Host Name or IP Address of the license server in the blank area. (IP
Address can be obtained from the license server by typing Imhostid
-internet —n under command shell.)

For other questions regarding MATFOR floating license or classroom license
installation and registration, please contact support@ancad.com.
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Chapter

PROJECT SETTINGS

Due to the variety in MATFOR-supporting compilers, this chapter is composed to
guide users to configure project settings under different compiler environments.

IN WINDOWS

. BORLAND C++ BUILDER

1. Open Borland C++ Builder 6.0.
2. Select File » New P Other.
3. Click on the New tab, select Console Wizard, and click OK.

X
[ ata Modules I Buziness I Web Documents I WebServices
Hew I ActiveR | Formz I Dialogs I Frojects
i oy
Batch File C File CLx CLx Data
Application kodule
0 o @ A
CLx Faorm CL¥ Frame  CL¥ Thread  Component
Object
. L
C2RR
Control Panel  Control Panel Cpp File Data Module  DLL “Wizard
Application t odule LI
) Copy ) [nheit € Lse
oK I Cancel | Help |

4. Select C++ and check Multi Threaded and Console Application.
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5

. Click OK.

Congole Wizard x|

—Source Type
L 28

{

[ UsevwCL

[ Usze
v bulti Threaded
v LConzole &pplicatio

A~ Specify project source

| N

] Cancel | Help

6.

8.

Select Options from the Project menu.

X

Select the Directories/Conditionals tab.
Under Include path, type in: $(MATFOR4DIR)\include;
Under Library path, type in: $(MATFORA4DIR)\lib\bcb;
Werzion Info I Packages I Tazm I CodelGuard
Forms I Application I Campiler I Advanced Compiler | C++
Pazcal I Liriker I Advanced Linker Directones/Conditionals
— Directaries —
Include path: $EMATFOR4DIR Ninclude SR CENinclude; $(B j J
Library path: [MATFEIFH4DIH]\Ii@EB]'\F’roiects\Lib;j J
Debug source path: I$[BEB]'\SDU[CE'WD| j J
|ntermediate autput: I jJ
Final output; I jJ
BPI/LIE output: | =] J
— Conditionals
Conditional defines: | DEBUG =] J
— Aliazes
Unit gliazes: I jJ

[~ Default ak I Cancel | Help

10. Add the following code to the header of the program(s):

#pragma link "fml.lib"
#pragma link "fgl.lib"

MICROSOFT VISUAL C++

1.
2.

Open Microsoft Visual C++ 6.0.
Go to File » New.
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3. Select the project type Win 32 Console Application.
4, Enter a name for the new project, specify its location, and click OK.
5. Select An empty project and click Finish.

Files Projects | Workspaces | Other Documents |

Project name:

demol
Location:

|D:‘|.demo1 emol J

& Create new workspace
1 Additol currentworks pace

7| Dependency of:

| Ef

Platforms:
[Wiin32

“hat kind of Console Application do you
want to create?

¢ A simple application.
¢ A "Hello, World!"" application.
" An application that supports MFC.

< Back MNext > | Finish I Cancel

6. Select Settings from the Project menu.
7. Click on the C/C++ label and select Preprocessor from the Category menu.
8. Under Additional include directories, type in: $(MATFOR4DIR)\include.



MATFOR QUICK START

13

Project Settings

Settings For: |Win32 Debug

[

Categong |F‘repmcessur )} j Reset |

Preprocessor definitions:
IWIN32,_DEBUG,_CONSOLE,_MBCSl

Undefined symbols: [” Undefine all symbols

Additional include directories:

E!EATFOFMDIR]\incIude p)

[~ Ignore standard include paths

Project Options:

fnologo {MLd M3 {Gm JGX fZ1 {Od [I o
"'S[MATFORADIR}include D "WIN32" |D " DEBUG" D

" CONSOLE"/D"™ MBCS" [Fp"Debug{demol.pch® X i

el 3
General | Debug | Fortran | CJC++ | Link | Flesug EE

0k | Cancel

9. Click on the Link label and select Input from the Category menu.
10. Under Object/Library Modules, add: fml.lib fgl.lib (and spml.lib if using

MATFOR Sparse Array).

11. Under Additional library directories, type in: $(MATFOR4DIR)\lib\vc6

Settings For:

Win32 Debug

[

General | Debug | Fortran | CiC++ | Link | Fleso; EE

Categor( |Input > j Beset |

i odules:
Llib fgl.li rmel32.lib user32.lib gdi32.lib winspool.lib

Ignore libraries: [~ Ignore all default libraries

Force symbol references:

Additj
MATFORADIR)\libyvch
Project Options:

fml.lib fgl.lib kernel32.lib user32.lib gdi32.lib i’
winspool.lib comdlig32.lib advapi3Z.lib shell32.lib
ole32.lib oleaut32.lib uuid.lib odbc32.lib odbccp32.lib H

2]

Ok | Cancel |

12. Click on the C/C++ and select Code Generation from the Category menu.

13. Under Use Run-time Library, choose Multithreaded DLL.
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Project Settings

Settings For:

Win32 Debug

j General | Debug | Fortran CJC++ | Link | Resug EE

21x

Categoi

Processor:

de Generation

j Reset |
e library:

[Blend =

Calling convention:

Struct member alignment:

I_cdecl * j IB Bytes * j
Project Options:
Inologo MD /W3 1Gm JGX [Z] |Od |D "WIN32" [D o

" DEBUG" /D" _CONSOLE"/D" MBCS"
{Fp"'Debug/demol.pch' fvX [Fo"Debugf {Fd''Debug/ Ll

o |

Cancel |

. MICROSOFT VISUAL C++.NET 2003 & 2005
1. Open Microsoft Visual Studio 2005.

Go to File » New Project.

2
3. Select Visual C++ Projects from the Project Types menu.
4

Select Win32 Console Application from Templates and create a solution
name. (Under Visual Studio 2003, please select Win32 Console Project).

5. Enter a name for the new file and click OK.

Wew Froject

Froject types: Templates:
(- Vizual Baste ¥isual Studio installed templates
=3 Windowes Bocms baplication ZACLR Comsole Application
(| -A Win32 Consale Application EATL Project
e PP fep plinadion S Makefile Project
ﬁ.ASP.NET Web Service @ATL Smart Device Project
lfﬂ(:hss Library TEICLR Empty Project
[ Empty Project ﬂElMFC AetiveE Control
MFC DLL ;EMFC Smert Device Lctivel Control
aﬁMFC Smeart Device Application JbMFC Smeart Device DLL
[E Win32 Projsct g@ Win32 Smart Device Project —
E Wind ows Forms Control Librany :-EE Wind ows Service
ﬁ cuztonwiz _I

|4 project for creati

conzole application

Name: [demal \‘
Location: Iﬁ
Solution Name: [demal

LI Brovwse. . |

[V Create directory for solution
™ 4dd to Someee Conteal

[ ox ]

Cancel

6. Click on Finish.

7. Select Properties from the Project menu.
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8. Go to General under the C/C++ folder.
9.

In Additional Include Directories, type in: $(MATFOR4DIR)\include

demol Propert
Configuration: | Active(Debug) | Platform: [Active(Win32) ~|  Confignration Mansger... |
e —
- Commeon Properties Additional Include Directories | $(MATFORADIR Y\include ;I
B Cionggmr:fn Properties Resolve #using References
e Debug Information Format Program Database for Edit & Continue (/ZI)
Suppress Startup Banner Tes (fnologo)
TWarning Lewvel Level 3 (fW3)
; Ffiomn : —
Freprocessor Detect 64 h.1t Portability Tssues Yes ({WpbHd)
- Code Generation Treat Wamnings As Errors Ho
- Language Tse UNICODE Response Files Tes
- Precompiled Headers
- Output Files
- Browss Information
- dvanced
----- Commnand Line
[+ Linker
[+ Manifest Tool
- ML Document Generator
[+ Browse Information
- Build Events
- Cugtom Build Step
[+ Web Deployment
Additional Include Directories
Specifies one or more directories to add to the include path; v semi-colon delimited list if more than one.
({I[path])
’TI Cancel | Apply |

10. Go to Code Generation, in Runtime Library, select: Multi-threaded DLL

(/MD)

demol Property Fages

Configurstion; | Astive(Debug)

|

(=9 Configuration Properties
Cremeral
Debugging
9 CiC++
Cremeral
Optimization
Language
Precompiled Heade:
Output Files
Brows Informatior
Adwaneed
Command Line
[ Linker
23 Browse Information
23 Build Events
23 Custorn Build Step
23 Web Deplowment

1 |

x| Ptform: IECﬁVB(WﬁﬁE) =l Configuration Manager... |
Enable String Pooling o
Enable Minimal Rebuild Yes (/Gm)
Enable C++ Exceptions Tes (EHax)
Smaller Tvpe Check No
Bazic Funtime Checks Both uin
Runtime Library Multi-threaded DLL (/b j
Struct Member Alignment Defanlt
Buffer Security Check Wa
Enable Function-Level Linking o
Enable Enhanced Instroction Set Not 3et
Runtime Library
Specify runtime library for linking. (M T, M Td, HD, M{Dd, ML, BL)

[ ok ]

Cancel |

Apply Help

11. Go to General under the Linker folder.

12. In Additional Library Directories, type in: $(MATFOR4DIR)\lib\vc8
(For users of Visual Studio 2003, please type in: $(MATFOR4DIR)\lib\vc7)
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Confignration: |Active(Debug) =l Plattorm: [Active(Win32) >|  Configmstion Manager.. |
- Comrmon Properties COutput File 00D Projectilame) exe
(=) Configuration Properties Show Progress ot Set
- Gremeral Vers
.. Debugging rsion
M- CiC++ Enable Incremental Linking Yes (/INCREMENTAL)
[=)- Linkg Buppress Startup Banner Fes (HOLOGOY
- Ignore Import Libracy Ha
. Manifest File Register Cutput Ho

Additinna] Liby : ;I

LI Link Library Dependencies Tez
O ptimization -
Evnbedded IDL s Library Dependency Inputs Mo
A dvanced Uz UNICODE Response Files Tez
- Comuand Line
¢ Manifest Tool

/- ML Docwment Generator
|- Browse Information

+- Build Events

#- Custorn Budd Step

¢ Web Deployment

-

Additional Library Directories
Specifies one or more additional pathe to seanch for libraries; configuration specific; use semi-colon delimited list
if more than one.  {LIBPATH:[dir])

[0):4 I Cangel Apply

13. Go to Input under the Linker folder.
14. In Additional Dependencies, add: fml.lib fgl.lib (and spml.lib if using

MATFOR Sparse Array).

Confignration: |Active(Debug) =] Biattorm: [Active(Win32) =] | Confignsstion Manager. . |
[ Comumon Properties Additional Dependenc fml lib fgl lib spml.lib J
1=)- Comfiguration Properties Tgnore Al Defanlt Libariss No

... Feneral I Specific Lib
. Debuesi znore Specific Library
- CACH Iodule Definition File
- L:i.nker Add Module to Lsembly
ity Embed Managed Resource File
| hEamites File Force Symbol References
-Debugging Delay Loaded DLLs
dyem hssernbly Link Resource
- Optimization
-Embedded IDL
- Advanced
----- Command Line
[+ Manifest Tool
- KML Document Generator
[#]- Browse Information
[+ Build Events
[#- Custom Build Step
[+ Web Deployment
Additional Dependencies
Specifies additional items to add to the link line {ex: kemel32 1ib); configuration specific.

O | Camel | apply

15. Go to Precompiled Headers under the C/C++ folder.

16. In Creative/Use Precompiled Header, select Not Using Precompiled
Header.
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Configuration: | Active(Debug) | Platform: [Active(Win32) ~|  Confignration Mansger... |

- Common Properties Not Using Precompiled Headers

B Confignration Properties

Precompiled Header File

- Browss Information
- Advanced

[+ Linker

[+ Manifest Tool

- ML Document Generator
[+ Browse Information

- Build Events

- Cugtom Build Step

[+ Web Deployment

CreatefUse Precompiled Header
Enables creation or vz of a precompiled header during the build.  (¥e, Fu)

0K I Cancel Apply

IV. INTEL C++
1. Repeat Step 1 through 6 in previous section (lll. MICROSOFT VISUAL
C++ .NET 2003 & 2005)

2. Select Convert to use Intel® C++ Project System from the Project menu.
3. Click Yes.

Confirmatinn ]

To vz Intel(R) C++ Project Systern, the project files must be converted to an appropriate format. If you proceed with this
operation, any tntermediate and outpot files previovsly built by the Microsoft Visual C++% NET* might not be valid for
uze with the Tntel(R) C++ compiler. Thuz, yon need to either Eebnild or Clean the project after converting. Sounce files

will not be changed.
Comtinue to change project swstemns?

4. Repeat Step 7 through 16 in previous section

IN LINUX

V. ALL COMPILERS

1. Open Command Prompt.
2. Copy linux_xxx_template.mak from /usr/lib/matfor4/tools/template to the
directory of the project.
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3. Rename the make file to linux_xxx.mak.
4. Modify linux_xxx.mak as required.

5. Type make —f linux_xxx.mak to build and compile the project.

TO RUN A DEMO CASE

UNDER WINDOWS

1. Go to the directory where MATFOR 4 is installed.
2. Opendemo/ cpp/<demo case>.

3. Select the .dsw file to run the demo case.

UNDER LINUX

1. To compile demo cases all at once, go to /usr/lib/matfor4/demo/cpp

To compile each demo case individually, go to
usr/lib/matfor4/demo/cpp/<demo case>.

2. Type make —f linux_gcc.mak in GNU C++ environment, or
type make —f linux_icc.mak in Intel C++ environment

3. Go tothe /usr/lib/matfor4/demo/cpp/<demo case> to run each demo case.
For example,

cd $SMATFOR4DIR/demo/cpp/3dplot
/3dPlot
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Chapter

FUNDAMENTALS

This chapter is an introductory summary on how to integrate MATFOR into C++
programming.  Beginning with mfArray, the core of MATFOR, the chapter
subsequently introduces the numerical library and the visualization library.

. MFARRAY

mfArray is a dynamic array endorsing the data types and dimensions listed in Table
3.1

Data Type Statement

const char * a = “string”

bool a=true

Int a=1

float a=1.0f

double a=3.1418f

dcomplex a = dcomplex (2.0f, 3.0f)

Table 3.1 | mfArray Data Types

mfArray Declaration
1. Include MATFOR library to appropriately contain mfArray.
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2. Declare mfArray using the format mfArray <variable>

Example Code (ch3-1)

#include “fml.h" /I Include the library file fml.h

void main()

{
mfArray X, y; I/l Declare mfArray variables x and y
X = 6.0; Il X is a scalar

y =mfVv(1.0, 2.0, 3.0, 4.0, 5.0); //yis a l-by-five vector containing
real values

mfDisplay(x, “x”,y, “y”); [/ Call mfDisplay function to display x
and y data

I NUMERICAL PROCEDURES

MATFOR embraces a comprehensive set of numerical procedures furnished with
easy-to-call syntax to complement mfArray. Various categories of numerical
procedures are contained in the set and are hereto listed in Table 3.2.

For a complete list of the numerical routines and descriptions on their usage and
functionality, please refer to the Reference Guide.
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Procedure Group Example Description

Data Manipulations mfSort Sort data in ascending order
Arithmetic Operators mfRDiv Right-divide the matrix
Trigonometry mfCos Request cosine function
Exponential mfLog Request natural logarithm
Complex miConj Generate conjugate of

Rounding and Remainder  mfCaell

complex

Round towards positive

infinity
Matrices mfMagic Construct magic square
Matrix Manipulations mfFind Find indices of nonzero
elements
Matrix Analysis mfNorm Generate matrix/vector norm

Request Cholesky

Linear Equations mfChol o
factorization
Eigenvalues and Singular Perform Schur
mfSchur -
Values decomposition
Factorization Ultilities mfBalance Perform diagonal scaling

Table 3.2 | Numerical Procedure Brief

Numerical Procedure Call

1. Include “fml.h” to appropriately contain the numerical routine(s).

2. To retrieve the procedure,

Example Code (ch3-2)

#include “fml.h”

Use the assignment operator “=", or

Simply call.

void main()

{

mfArray m, i, j;
m = mfMagic(3);

tom

/I Include the library file fml.h

I/l Declare mfArray variables m, i, and |
/l Construct a 3-by-3 magic matrix and assign it

mfFind(mfOut(i, j), m); // Retrieve the row-column indices of the
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nonzero(s) in m

/l'i and j describe the row and column,
respectively

mfDisplay(m); // Display matrix m

mfDisplay(i, “i”,j, “j"); // Call mfDisplay function to display x and y
data
}
Result

. VISUALIZATION PROCEDURES

In addition to the numerical procedures, MATFOR endorses a collection of
visualization routines to enhance data comprehension. Table 3.3 summarizes the
procedures and introduces an example routine with description for each procedure

group.

Procedure Group Example Description

Set the frame size of Graphics
Viewer window

Window Management mfWindowSize
Visualization Controls mfSubplot Create subplot in active figure
Graph Options mfSurf Construct 3D surface plot

Construct 3D Delaunay
triangulation

Adyanced Graph mfGetDelaunay3
Options
Object Manipulations  mfObjOrigin Set the origin of the drawn object

Specify the colormap type of the

Appearance Settings  mfColormap drawn object

Annotations mfTitle Annotate the graph with title

3D Objects mfSphere Draw a sphere

Table 3.3 | Visualization Procedure Brief
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For a complete list of the visualization routines and descriptions on their usage and
functionality, please refer to the Reference Guide.

Visualization Procedure Call
1. Include “fgl.h” to appropriately contain the visualization routine(s).
2. To retrieve the procedure,

- Use the assignment operator “=", or

- Simply call.

Example Code (ch3-3)

#include “fml.h” /I Include the library file fml.h
#include “fgl.h” /l Include the library file fgl.h
void main()
{
mfArray nx, ny, nz;
mfArray X, Y, z, c, tet; I/l Declare mfArray variables
nx = mfLinspace(-2, 2.2, 21); /I Construct linearly spaced vector nx

ny = mfLinspace(-2, 2.25, 17); /I Construct linearly spaced vector ny
nz = mfLinspace(-1.5, 1.6, 31); // Construct linearly spaced vector nz

mfMeshgrid(mfOut(y, x, z), ny, nx, nz); // Construct grid matrices for
3D plotting

¢ = 2 * mfCos(x*x) * mfExp( — (y*y) — (z*z)); // Mathematically define c
tet = mfGetDelaunay3(x, y, 2); // Construct 3D Delaunay triangulation

mfTetSliceXYZ( tet, X, y, z, c,
mfV(-1.0, 1.0), 0, -0.75); /I Display orthogonal sliced planes

mfViewPause(); /l Pause to display the graph



24 MATFOR QuUICK START

Result

Value
1.96

0.98

0.00

-0.98

-1.96




A FIRST PROGRAM

This chapter presents one simple visualization program for users to manipulate and

Chapter

extends as animation and recording procedures are introduced.

HELLO SURFACE

The section shall take you step by step to create a surface plot.

Create a New Project

1.
2.

Select the project type Win 32 Console Application.

Name the project “demol,” specify its location, and click OK.

New

Files Projects ]Workspaces | Other Documents I

e

[\

—Win32 Console Application

%] Win32 Static Library

Pojectn
demol|
Location:

[DAdemot _]

' Create new workspace

Platforms:
VWin32

0K | Cancel
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3. Select An empty project and click Finish

Win12 Console Application - Step 1 of 1

What kind of Console Application do you
want to create?

+ An emply project,

" A simple application.

" A"Hello, World!"' application.

" An application that supports MFC.

< Back ‘ ‘ Finish | Cancel

4. Select the file type C++ Source File.
5. Name the file “mainl,” specify its location, and click OK.

New

Files | Projects | VWorkspaces | Other Documents J

<#Active Server Page Iv Add to project:
Binary File
i Bitmap File ldEITllﬂ L]

T/ Resource Script

/= Resource Template
SQL Script File
Text File

[ H n .
98 Ces Source Flle —

™ Cursor File Fi

[ Fortran Fixed Format Source File @

[d) Fortran Free Format Source File ndin]

[8]HTML Page i

[ Jlcon File Location:

L= Macro File lC:\demu] __J

o]

Cancel
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Adding the Source Code (ch4-1)
In “mainl.cpp,” type in:

#include “fml.h” /I Include the library file fml.h
#include “fgl.h” /I Include the library file fgl.h

int main(int argc, char* argv(])

{
mfArray X, Yy, z; /I Declare mfArray variables
mfMeshgrid( mfOut(x, y), /I Construct grid matrices for 3D
plotting
mfLinspace(-3, 3, 30),
mfLinspace(-3, 3, 30) );
z = mfSin(x) * mfCos(y); / Mathematically define z
mfSurf(x, y, z); I/l Plot a surf using mfArray x, Y,
and z
mfViewPause(); I/l Pause to display the graph
return O;
}

Line-by-Line Walkthrough

#include “fml.h”
This includes the library file fml.h which contains the MATFOR numerical procedures.

#include “fgl.h”

This includes the library file fgl.h which contains the MATFOR visualization
procedures.

mfArray X, Y, z;
This declares mfArray variables x, y, and z.

mfMeshgrid( mfOut(x, y), mfLinspace(-3, 3, 30), mfLinspace(-3, 3, 30) );

This creates x and y grid matrices from the domains specified by
mfLinspace-generated vectors.

- mfOut(x, y) specifies x and y as mfArray outputs.

- mfLinspace(-3, 3, 30) constructs a vector with 30 linearly spaced points between
-3 and 3.
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z = mfSin(x) * mfCos(y);
This defines z mathematically.

mfSurf( x,y, z);
This creates a three-dimensional surface plot of the x-, y-, and z-coordinates.

mfViewPause();

This halts program execution for graphical display. mfViewPause() should be added
after each set of graphical creation routines.

Adding Library and Include paths:
1. Select Settings from the Project menu.

2. Click on the C/C++ label and select Preprocessor from the Category pull-down
menu.

3. Under Additional include directories, type in $(MATFORA4DIR)/include.

Project Settings

Settings For: 'Win32 Debug - General | Debug | Fortran CJC++ | Link | Resoi EE

B oo

Cateaoq: Erepmcessor > j Beset

Preprocessor definitions:
|WIN32,_DEBUG,_CONSOLE,_MBCS

Undefined symbols: ™ Undefine all symbols
<. S[MATFORADIRfinclude] __~7

[~ lgnore standard include paths

Project Options:

fnologo /MLd W3 1Gm JGX [Z1 {Od }I
"'S$[MATFORADIR){include" |D "WIN32" {D ""_DEBUG" /D
" _CONSOLE" /D" _MBCS" [Fp"Debugfdemol.pch' fyX

0K | Cancel |

| ITT +-3

4. Click on the Link label and select Input from the Category pull-down menu.
5. Under Object/Library Modules, add fml.lib and fgl.lib.
6. Under Additional library directories, type in $(MATFOR4DIR)\lib\vc6.
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Project Settings

Settings For: |Win32 Debug j General | Debug | Fortran | C{C++ Link | Resol EE

+
& Categur@ j Reset

: : modules:
fml.lib fgl.li

Ignore libraries: [ Ignore all default libraries

Force symbol references:

Additional library path:

(C|SMATFORADIR\libtvch >
T Opti :

fml.lib fgl.lib /nologo fsubsystem:console ~
fincremental:yes /pdb'Debugf/demol.pdb' fdebug =
tmachine:1386 lout""Debugfdemol.exe" fpdbtype:sept

0K | Cancel ‘

7. Click on the C/C++ and select Code Generation from the Category pull-down
menu.

8. Under Use Run-time Library, choose Debug Multithreaded DLL.

Project Settings

Settings For: |Win32 Debug j General | Debug | Fortran C{C++ | Link | Resol EE

o= e

Processor: Use run-time library:

\Blend * M@ Debug Multithreaded DLEIDS
Calling convention: Struct member alignment:
|_cdec| * j |B Bytes * j

Project Options:

fnologo {MDd W3 JGm [GX [Z1 10d fI A
"S[MATFOR_DIR){include" }D ""WIN32" /D" _DEBUG" JD
" CONSOLE" D" MBCS" [Fp"Debug/demol.pch" fvX

0K | Cancel
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Compile and Run

Bl MATFOR 4.1 - [Figure 1] =3
o Fle View Sefting Tools Toolber Windows Help

g2 a8 Mo e hae ML ZA B

I[I. TO ANIMATE HELLO SURFACE
In this section, the Hello Surface demo code is modified to generate animation.

Animation

Animations effects are produced by continuously updating data displayed in the
Graphics Viewer.

To Animate Data

1. Include “fgl.h” to appropriately contain the visualization routine(s).

Construct and initialize the mfArrays for plotting.

Create a static plot of the graph to be animated.

Set up an iteration loop for the range of data to be observed through animation.

o bk 0D

Within the loop, use procedure call mfGSet(handle, ‘axis-data’, data) to update the
targeted data of the current draw.

6. Update the drawn figure accordingly by using procedure mfDrawNow.

7. Use procedure call mfViewPause after the end of animation to observe the static
graph.
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Example Code (ch4-2)
Modify the previously created “mainl.cpp” file as follows and rename it “main2.cpp”

#include “fml.h" /I Include the library file fml.h
#include “fgl.h” /I Include the library file fgl.h

int main(int argc, char* argv(])

{
mfArray X, Y, z, h; I/l Declare mfArray variables
inti; // Declare an integer variable
mfMeshgrid( mfOut(x, y), I/l Construct grid matrices for 3D
plotting
mfLinspace(-3, 3, 30),
mfLinspace(-3, 3, 30) );
for (i =1; i <=30; i++) Il Create loop
{
z = mfSin(x+i/8.0) * mfCos(y); // Mathematically define z
ifi==1) { // Plot a surf using mfArrays X, y, and z
h = mfSurf(x, y, z) ;
mfDrawNow();
}
else { / Update the figure as the

z-coordinate varies
mfGSet(h, “zdata”, z);

mfDrawNow();
}
} / End loop
mfViewPause(); I/l Pause to display the graph
return O;

Line-by-Line Walkthrough
#include “fml.h”

This includes the library file fml.h which contains the MATFOR numerical procedures.
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#include “fgl.h”

This includes the library file fgl.h which contains the MATFOR visualization
procedures.

mfArray X, Y, z, h;
This declares mfArray variables x, y, z, and h.

inti;
This declares an integer variable i.

mfMeshgrid( mfOut(x, y), mfLinspace(-3, 3, 30), mfLinspace(-3, 3, 30) );

This generates x and y grid matrices from the domains specified by the
mfLinspace-generated vectors. This procedure aims to solve functions for two
variables by plotting 3D graphs.

for(i=1; i<=30; i++)
This creates a loop running from i=1 to i=30.

z = mfSin(x +i/8.0d0) * mfCos(y);
This defines z mathematically. Note that the equation involves the loop index i.

if i==1)
At the beginning of the loop,
h = mfSurf(x, y, z);
This creates a three-dimensional surface plot of the x-, y-, and z-coordinates.
mfDrawNow();
This displays the initial figure.

else
At all other times during loop execution,
mfGSet(h, “zdata”, z);
This sets the z-coordinate for update.
mfDrawNow/();
This displays and updates the figure during loop execution.

mfViewPause();
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This halts program execution for graphical display.

Compile and Run
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[ll. TO RECORD HELLO SURFACE

This section revises the previous sample code to perform animation
recording.

Recording

MATFOR allows recording of animated simulation to facilitate date
presentation with comprehensiveness and readability.

To Record Animation
1. Include “fgl.h” to appropriately contain the visualization routine(s).

2. Use procedures mfRecordStart(“animation.avi”) and
mfRecordEnd() before and after the animation codes to record the
animation.

Example Code (ch4-3)

Add the recording routines to the previously created “main2.cpp” file and rename it
“main3.cpp” (Note: only the modified and added lines are shown in colors):
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Chapter

THE ADVANCED FEATURES

This chapter presents the innovative MATFOR 4 features that are functionally
powerful in advanced programming. The first part concerns mfPlayer, which aims to
enhance data presentation and accessibility. The second part introduces MATFOR
GUI Builder with its friendly interface. The last part focuses on MATFOR widget
components, and how they are used to facilitate application-building and code
integration.

. MFPLAYER

mfPlayer is an exclusive visual tool by which the previously saved numerical data is
read and displayed. As MATFOR saves the simulated data into a MATFOR-defined
MFA file, mfPlayer is one approach to present the file as a recorded animation.

To record simulated result(s) into an MFA file, simply use procedures
msRecordStart() and msRecordEnd() before and after the animation codes to
record the animation:
call msRecordStart( 'filename.mfa’ )
/[ animation codes
call msRecordEnd
To play an MFA file with mfPlayer.

1. Go to Start » Program Files » MATFOR4 P Utilities P mfPlayer
2. Click Open File to find MFA file and click Play.
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B MATFOR 4.1 - Dute Viswsr
B Dov oo
O o b oceddwidin: B0 — | Digits: & — ——

i 5 = =
aamean  emmen  ammx || | e

asTEl| e ased 3-:‘»:1»-’ -
dgEmss|  dDmsE)  dEmal S
LEE LM sl .
wrs, dmmal e || et [Redes | |
s s GATE || csersen

JisEl awmEm 27Dk

Jamew  wiesis3|  jAISTR
sl 1m9%|  omoe
A 02D o)
0261 7 6. -4 TR
Al amwemi|  ammn
ans13M| 25103 -3seeam
AW e e
O L
B T o
ARMET AU AT
agmrnl | Aven
AEWR  ADIEE AR | s el
AT 4350601 Dain Rurge Deleenon

T
SR LTI zmj:l
| [
_

%

b

Firws Yorw Jotiae Jool Todw fikp Coshntm
o0 @%ae BN 2w tpgnne @V IRE W 0

. MATFOR GUI BUILDER

MATFOR GUI Builder allows users to create an interface of their preference,
facilitating application-building by packaging the complex codes.

To Build an Application

1. Go to Start » Program Files » MATFOR4 P> Utilities and run MATFOR GUI
Builder.

Ed MATFOR GUI Builder 1.0
File Edit Tools Window Help

N IEEEE Y
@ v E A6 & FEE]E . s e
x|

Objects I:I L .’ ........................................

E""DF'Dml L

caphion Forml
color pelelsd || fecccccccccccaaaaaaooooscaaaaoooooonooooooaa
height F7 e ] R A T

icon (Momne)

|Pr0perb' Falue I:ﬁﬁ:ﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁ:ﬁﬁﬁﬁﬁﬁﬁﬁﬁﬁ:ﬁﬁﬁﬁﬁﬁﬁ

name Foml
tac n hd|

2. Add MATFOR Window and Button; click on Button.
3. Set/Align to alButtom; enter Close for to; and type in btnClose for
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Name|

4. Select OnClick from [Event Handler and set it to btnClose_Click.

5. Set MATFOR Window Align to alClient.

B4 MATFOR GUI Builder 1.0
File Edit Tools Window Help
o d]ec][sma|rEr@® [ @A& & @ REE]
EN | 5A Formi

fowees ]

=} EFuml

[ pstnrmindowt
|_ok | Buttonl

Prope Value -
alBotom \ =
wallp | falee
aption. Close \

| [ I
down fake
Tt fake
Sonkolor | #000000
£hyph {nong)
sowpindex. |0
height 31
name Button!
-

INvizn 526 ]
A" /
A\ 435
ONJick bmcmék

6. Click Save and select C++ Export Tab.
7. Name the file “demo2.mfui.”
8. Select the checkboxes C++ Main and VC++ 6.0 Project.

Save Query

MATFOR UT Form Filk D:Aemo2idemo mind _I

Fortran Export | C++ Export |

—C4+ Source Export
< v T+t Bource Code
AT FTOeCT Bapoi]
<~E Tigual C++ 6.0 Projecj ) [ Wisnal C++ Net Project

I Intel C++ 8.1 Project [ Intel C++ 9.0 Project

—C+ Maketile Bxport
[ VisslCe+ 60 [ Visusl G+ Net [T Ectlend Ct+ Brilder
[ Intel C++ 8.1 (WinIA32) [ Intel C++ 90 {Win TA3Z) [~ GHU C++ (Linux TA3Z)

[~ IntslC++ 8.0 Linux IA32) [ Intsl C++ 90 {Linux [432) [~ GNU Ct+ (Linux EMG4T)
[~ IntlC4+ 8.1 LinuxEMG4T) | Intel C++ 9.0 (Linux EMB4T)

Save | Cangel I

9. Open the project “demo2_vc6.dsp,” and modify the code in “demo2.cpp” as
follows:

MF_CALLBACK btnClose_Click(const char* sender)
{
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exit(0);

Compile and Run.

. MATFOR WIDGET

As MATFOR GUI Builder develops an interface MFUI file, the MATFOR widget
component along with MATFOR libraries can be embedded into common Ul design
environments to enable application execution on multiple C++ compilers.

Integration with Visual C++ (ch5-2)
1. Select the project type MFC AppWizard (exe).
2. Name the project “demo3,” specify its location, and press OK.
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RIX

New
Files Projects I Waorksp | Other D t I
21 ATL COM AppWizard FWin32 App  Prgieetname:
% Cluster Resource Type Wizard ~1Win32 Cor

#'| Custom AppWizard [%)Win32 Dyr
‘& Database Project %|Win32 Sta

58 DevStudio Add-in Wizard

5 Extended Stored Proc Wizard
I Fortran COM Server
~Fortran Console Application
%] Fortran Dynamic Link Library

‘#|Fortran Static Library c Ad
'=]Fortran Windows Application o
& [5API Extension Wizard

'™ Fortran Standard Graphics or Quick¥in Application + Create new workspace

Platforms:

#'Win32

<_

0K | Cancel

3. Select Multiple documents and click Finish.

HMFC AppWizard - Step 1

=TT "~ Single document
* Multiple documents

" Dialog based

v Document/¥iew architecture support?

What language would you like your resources in?

[

< Back | Next > ‘ Finish

Cancel

4. Open “demo3View.cpp” and add:

#include "MxWidget.h"
#include "fml.h"
#include "fgl.h"

Then add,

void CDemo3View::OnDraw(CDC* pDC)
{
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CDemo3Doc* pDoc = GetDocument();
ASSERT_VALID(pDoc);

// TODO: Add draw code for native data here

Il Add this line to draw content when OnDraw occurs
m_Widget->Render();

5. Add the following codes to “demo3View.h":

class MxWidget;
class CDemo3View : public CView

{
protected:

MxWidget* m_Widget;
)i

6. Open MFC ClassWizard (Ctr+W)and set Class Name to CDemo3View.

7. Under Messages, select WM_CREATE, WM_ERASEBKGND, and WM_SIZE
and click Add Function respectively.

MFC ClassWizard ZIx
ge Maps ] Member Variables I Automation I ActiveX Events I Class Info |
Broject: pREeET____———  AddClass... ~
‘demoi} LJ Cnemoii\lri_ew o -
D:demo3tdemo3View.h, D:A\demo3idemo3View.cpp Q

Object IDs: Messages: Delete Function
CDemo3View =
ID_APP_ABOUT Edibtni:
ID_APP_EXIT

ID_EDIT_COPY

ID_EDIT_CUT

ID_EDIT_PASTE 4

1ID_EDIT_UNDO v YWWLBUTTONDBLCLK

Member functions:
¥ OnEndPrinting %

OnEraseBkgnd ON_WM_ERASEBKGND
¥ OnPreparePrinting

W OnSize ON_WM_SIZE

¥ PreCreateWindow

|

Description: Indicates when background of window needs erasing

0K | Cancel ‘

8. Add/Modify the following codes in “demo3View.cpp”:
int CDemo3View::OnCreate(LPCREATESTRUCT IpCreateStruct)

{
if (CView::OnCreate(lpCreateStruct) ==-1)

return -1;
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static int flag = 0;

I/l Create MxWidget by given win32 window handle
m_Widget = new MxWidget(this->m_hWnd);
m_Widget->SetBackground(0.2, 0.5, 0.7);
m_Widget->SetActive();

/I Create surf or other draw other contents
mfArray Xx,y,z;

mfCreateSurfData( mfOut(x, vy, z), 1, 30, 35);
mfSurf( x,y, z);

mfResetCamera();

/I Optional: change view mode
if (flag==0)
{ mfAxis2DMode();
flag = 1;
}
else
{ mfAxis3DMode();
flag = 0;

return O;

void CDemo3View::OnSize(UINT nType, int cX, int cy)

{
CView::0OnSize(nType, cX, cy);
/l Resize when necessary
m_Widget->SetSize(cx, cy);

}

BOOL CDemo3View::OnEraseBkgnd(CDC* pDC)
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/Il Overwrite OnEraseBkgnd function to avoid screen flick
return true;

9. Select Settings from the Project menu.

10.Click on the C/C++ label and select Preprocessor from the Category pull-down
menu

11.Under Additional include directories, type in $(MATFORA4DIR)/include.

Project Settings

Settings For: |Win32 Debug - General | Debug | Fortran  C{C++ | Link | Resoi EE

) Categ :ﬂémp. >J Reset

Preprocessor definitions:
|WIN32,_DEBUG,_WINDOWS,_AFXDLL._MECS

Undefined symbols: [~ Undefine all symbols

Additional include directories:
q S[MATFORADIR){include

I~ Ignore standard include paths

Project Options:

fnologo /MDd A3 [Gm [GX £21 #O0d I
"S[MATFORADIR){include"” {D "WIN32" /D " DEBUG" {D
" WINDOWS" ID ""_AFXDLL" {D " MBCS"

0K | Cancel |

| [

12.Click on the Link label and select Input from the Category pull-down menu.
13.Under Additional library path, type in $(MATFORA4DIR)/lib/vc6.

Project Settings

Settings For! |Win32 Debug - General | Debug | Fortran | CliC++ Link | Resoi EE

emm|
CatEQQE: |Input )j Reset

Objectflibrary modules:
[fimLlib tgl.lib
Ignore libraries: I~ Ignore all default libraries

Force symbol references:

Additional Iihra[z path:

(_|SIMATFORADIR)flibjve6
T ek :

fml.lib fgl.lib fnologo }subsystem:windows fad
fincrementaliyes fpdb"Debug/demo3.pdb" fdebug
fmachine:1386 Jout"Debug/demo3.exe" pdbtype:sept

0K | Cancel
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Compile and Run
Click on New button once to plot Demo 32.

#+ demo3 - Demo31

HEE EEE MR \RE RAW
DEH =8 & 2

B Demo32

?__i' Demo31

Integration with Borland C++ Builder (ch5-3)

1. Go to File and select Close All.

2. Go to File and select Open Project.
Select $(MATFOR4DIR)\Component\bcb\BMXWidgetPkg.bpk.
Click Compile and then Install.

3. Save and Close.

Package - BMatforWid zeifkg hpk

it (5 = @
Compile Add Remove I niztall Optionz
Files | Path ﬂ

EID Containz

-] BMatforwidget.cpp D A\MATFOR4\Componentybch
' @ B atforawfidget.der DAMATFOR4MComponentibeb
@ BM atforw idgetPk. .. D:AMATFOR4ACompaonentsbch
@ B atforw/idgetPk. .. D AMATFOR4AComponentibch
=21 Requires

~E] tlbpi

@ vl bpi

4. Go to File and select New — Application to open a new application.
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5. Add Button and BMatforwidget to Form1.
=]

Databaze Tools Window Help <Mone: || & o
th] Dialous] ‘win 3.1 ] Samnles] Activexl CDM+] InterB aze Admin] Servers] Indy Clients | Indw Serverz | Indv Misc | foic »

6. Select Button and enter Close for [Caption|
Select OnClick from and set it to Button1Click.
7. Add the following codes:

X1

void __ fastcall TForm1::Button1Click(TObject *Sender)

{
Close();

8. Press [F9 to compile and run.

9. Select OnCreate from and set it to FormCreate.
10. Add the following codes:

void __ fastcall TForm1::FormCreate(TObject *Sender)
{
mfArray Xx,y,z;
mfCreateSurfData( mfOut(x, vy, z), 1, 30, 35);
mfSurf( x,y, z);
mfDrawNow();



MATFOR QUICK START 45

11.Add the following headers to “Unitl.cpp”:

#include "fml.h"

#include "fgl.h"
#pragma link "fml.lib"
#pragma link "fgl.lib"

12.Go to Project->Options and select Directories/Conditionals to add paths.
13.In Include Path, add $(MATFOR4DIR)\component\bcb.

In Library Path, add $(MATFOR4DIR)\component\bcb.

14.Save Project (“Projectl.bpr”) and Unitl (“Unitl.cpp”).
15.1f the following dialog box appears, type in:

$(MATFOR4DIR)\Component\bcb\BMXWidget.h

Find Header File X]

|Inahble to find header file for component: Bibd atforafidget

Header File: |$[M.t’-‘«T FOR4DIR“componentybchhE M atforwidget.

Browze
kK | LCancel ‘ Help |

Compile and Run

Close

Integration with Win32 SDK (ch5-4)
1. Prepare a Win32 skeleton program and a makefile (see “win32_skeleton.cpp”

and “win32_skeleton.mak”) and rename them as "demo7.cpp” and “Makefile.”
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2. Add variable declarations in long FAR PASCAL WndProc(...) of “demo7.cpp™:
static MxWidget *mxWidget;
static int winSizeX = 420;
static int winSizeY = 420;

3. Add include files in “demo7.cpp”:

#include "MxWidget.h"
#include "fml.h"
#include "fgl.h"

4. Add additional codes to handle WM_CREATE in “demo7.cpp”:

case WM_CREATE:
{
CreateWindow("button","Exit",

WS_CHILD | WS_VISIBLE | SS_CENTER |
WS_CLIPSIBLINGS,

0,0,420,40,
hwnd,(HMENU)1,

(HINSTANCE)GetWindowLong(hwnd,GWL_HINSTANCE),
NULL);

mxWidget = new MxWidget(hwnd);
mxWidget->SetPosition(0, 40);
mxWidget->SetSize(winSizeX, winSizeY);
mxWidget->SetActive();

mfArray Xx,y,z;

mfCreateSurfData( mfOut(x, y, z), 1, 30, 35);
mfSurf( x,y, z);

mfResetCamera();

mfDrawNow ();

return O;
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5. Add additional codes to handle WM_SIZE in “demo7.cpp”:
case WM_SIZE:
winSizeX = LOWORD(IParam);
winSizeY = HIWORD(IParam) - 40;
mxWidget->SetSize(winSizeX, winSizeY);
return O;

6. Add additional codes to handle WM_COMMAND in “demo7.cpp™

case WM_COMMAND:
switch (wParam)

{ casel:
PostQuitMessage (0);
break; }

return O,

7. Modify “Makfile.” For example:

SOURCES =demo7.cpp

OBJECTS = demo7.0Dbj

TARGET = demo7.exe

INCPATH = -I"$(MATFOR4DIR\include"

LFLAGS= /NOLOGO /DEBUG /SUBSYSTEM:windows
LIBPATH:"$(MATFORADIR\Iib"

LIBS = kernel32.lib user32.1ib gdi32.lib fgl.lib fml.lib mxui.lib

Build and Run

Ml Draw Window
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