VSignal.ExternalBase Namespace

VSignal.ExternalBase Namespace Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Classes
 | Class | Description
Public class | TExternalBase | ExternalBase - Base class implementing the IExternalDll interface. Any C# external user DLL must inherit this class and override implementation for Init and DoCompute.
Protected class | TExternalBaseDllData | DLLData - This class represents a data object used by the user DLL. Before DLL's computation stage, Visual Signal's ExternalDll will pass input descriptors and data via setInputDescriptors(String), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double) and converted automatically to an array of DllData objects. User DLL may access these info directly via the member _inputData, or via functions such as GetInputDataRe(Int32, Int32), GetInputDataIm(Int32, Int32), etc.
Protected class | TExternalBaseDllInputType | DllInputType - This class represents an input type accepted by the user DLL. The user DLL should initialize the number of accepted DllInputType objects and store them in _inputTypes list in Init using AcceptInput() function. This information will be used by Visual Signal to determine whether an input connection to the user's DLL is valid or not.
Protected class | TExternalBaseDllProperty | (Deprecated) DllProperty - This class represents a property used by the user DLL. The user DLL should initialize the number of required DllProperty objects and store them in _properties dictionary in Init using RegisterProperty(). Before DLL's computation stage, Visual Signal's ExternalDll will update the value of the properties via setProperties(String); after DLL's computation, user DLL is responsible for updating the property values via UpdateProperty(String, Object). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable.
Public class | TExternalBaseFileAttribute | This is the File attribute to be used when defining a filename-related property, indicating that the property is a file path, and can invoke the OpenFile dialog in Visual Signal. The filters used in OpenFile dialog can be specified using the standard "|"-separated .Net filter specification in [filter]. For example: "Text files (*.txt)|*.txt|All files (*.*)|*.*", or "Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*"
Public class | TExternalBasePropertyOrderAttribute | This is the PropertyOrder attribute to be used when defining a property, indicating the order in which the property is to be displayed in the VisualSignal property window.
Public class | TExternalForm | TExternalFormBase - Base class implementing the [!:IExternalForm] interface. Any C# external user dialog DLL must inherit this class and override implementation for [!:Init] and [!:DoCompute].
Public class | TExternalViewer | ExternalViewer - Base viewer class inherited from TExternalBase, and also implementing the IExternalViewer interface . Any C# external user viewer DLL must inherit this class and override implementation for Init and DoCompute, and optionally UpdateViewerProperty.
Interfaces
 | Interface | Description
Public interface | IExternalDll | IExternalDll - Interface of externally visible functions provided by all external user DLLs. All functions exported in the interface are used by Visual Signal's ExternalDll module to communicate with and control the execution of the user DLL. Default implementations will be provided in TExternalBase, which can be inherited to provide custom behaviour.
Public interface | IExternalLicenseManager | IExternalLicenseManager - Interface of external license manager. If license control is required in an external module, a license manager must be implemented according to this interface, and its ID registered in the module. Visual Signal will be responsible for the creation and initialization of all license managers available in the External directory. For security reasons, the implemented license manager *must* be included in the same assembly as the associated external modules to prevent spoofing. However, it is possible to implement IExternalLicenseManager as proxy license managers to be included in various assemblies, and have the proxy license managers accessing a central license control manager located in a separate assembly. *** Note that the implemented license manager class, as well as license controlled modules must be "sealed" to prevent re-inheriting the classes.
Public interface | IExternalViewer | IExternalViewer - Interface of externally visible functions provided by external user viewers. All functions exported in the interface are used by Visual Signal's ExternalDll module to communicate with and control the execution of the user DLL. Default implementations will be provided in TExternalViewer, which can be inherited to provide custom behaviour.
Enumerations
 | Enumeration | Description
Public enumeration | AssociationTypes |
Public enumeration | TExternalBaseInputChannelTypes | This is the InputChanneltypes enumeration for all possible channel types
Public enumeration | TExternalBaseInputCoordinateTypes | This is the InputCoordinateTypes enumeration for all possible coordinate types.
Public enumeration | TExternalBaseInputDataTypes | This is the InputDataTypes enumeration for all possible acceptable data types.
Public enumeration | TExternalBaseInputValueTypes | This is the InputValueTypes enumeration for all possible data value types

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


AssociationTypes Enumeration

AssociationTypes Enumeration Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "T:VSignal.ExternalBase.AssociationTypes"]

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public enum AssociationTypes
Public Enumeration AssociationTypes
public enum class AssociationTypes
type AssociationTypes
Members
Member name | Value | Description
None | 0 |
Property | 1 |
Action | 2 |
See Also

Reference

VSignal.ExternalBase Namespace


IExternalDll Interface

IExternalDll Interface Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

IExternalDll - Interface of externally visible functions provided by all external user DLLs. All functions exported in the interface are used by Visual Signal's ExternalDll module to communicate with and control the execution of the user DLL. Default implementations will be provided in TExternalBase, which can be inherited to provide custom behaviour.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IExternalDll
Public Interface IExternalDll
public interface class IExternalDll
type IExternalDll =  interface end

The IExternalDll type exposes the following members.

Methods
 | Name | Description
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL.
Public method | getDllInfo | Interface for exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, and properties.
Public method | getOutputCoordinates | Interface for exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.
Public method | getOutputDataRe | Interface for exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.
Public method | getOutputDescriptor | Interface for exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.
Public method | getProperties | Interface for exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.
Public method | setInputCoordinates | Interface for exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.
Public method | setInputDataIm | Interface for exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.
Public method | setInputDataRe | Interface for exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.
Public method | setInputDescriptors | Interface for exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.
Public method | setProperties | Interface for exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


IExternalDll Methods

IExternalDll Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The IExternalDll type exposes the following members.

Methods
 | Name | Description
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL.
Public method | getDllInfo | Interface for exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, and properties.
Public method | getOutputCoordinates | Interface for exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.
Public method | getOutputDataRe | Interface for exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.
Public method | getOutputDescriptor | Interface for exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.
Public method | getProperties | Interface for exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.
Public method | setInputCoordinates | Interface for exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.
Public method | setInputDataIm | Interface for exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.
Public method | setInputDataRe | Interface for exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.
Public method | setInputDescriptors | Interface for exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.
Public method | setProperties | Interface for exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.
Top
See Also

Reference

IExternalDll Interface


IExternalDll.compute Method

IExternalDllcompute Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
bool compute()
Function compute As Boolean
bool compute()
abstract compute : unit -> bool

Return Value

Type: Boolean
Returns True if computation is successful.
See Also

Reference

IExternalDll Interface


IExternalDll.getDllInfo Method

IExternalDllgetDllInfo Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, and properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
string getDllInfo()
Function getDllInfo As String
String^ getDllInfo()
abstract getDllInfo : unit -> string

Return Value

Type: String
Returns the XML string containing DLL Info.
See Also

Reference

IExternalDll Interface


IExternalDll.getOutputCoordinates Method

IExternalDllgetOutputCoordinates Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
Object[] getOutputCoordinates(
    int dim
)
Function getOutputCoordinates (
    dim As Integer
) As Object()
array<Object^>^ getOutputCoordinates(
    int dim
)
abstract getOutputCoordinates :
        dim : int -> Object[]

Parameters

dim
Type: SystemInt32
Specifies the zero-based input data dimension index.

Return Value

Type: Object
Returns the array containing the input data coordinates corresponding to the specified input data dimension.
See Also

Reference

IExternalDll Interface


IExternalDll.getOutputDataIm Method

IExternalDllgetOutputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
double[] getOutputDataIm(
    int channel
)
Function getOutputDataIm (
    channel As Integer
) As Double()
array<double>^ getOutputDataIm(
    int channel
)
abstract getOutputDataIm :
        channel : int -> float[]

Parameters

channel
Type: SystemInt32
Specifies the zero-based input data channel index.

Return Value

Type: Double
Returns the output data (imaginary part) in the form of a double[] array.
See Also

Reference

IExternalDll Interface


IExternalDll.getOutputDataRe Method

IExternalDllgetOutputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
double[] getOutputDataRe(
    int channel
)
Function getOutputDataRe (
    channel As Integer
) As Double()
array<double>^ getOutputDataRe(
    int channel
)
abstract getOutputDataRe :
        channel : int -> float[]

Parameters

channel
Type: SystemInt32
Specifies the zero-based input data channel index.

Return Value

Type: Double
Returns the output data (real part) in the form of a double[] array.
See Also

Reference

IExternalDll Interface


IExternalDll.getOutputDescriptor Method

IExternalDllgetOutputDescriptor Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
string getOutputDescriptor()
Function getOutputDescriptor As String
String^ getOutputDescriptor()
abstract getOutputDescriptor : unit -> string

Return Value

Type: String
Returns the XML string of the output descriptor.
See Also

Reference

IExternalDll Interface


IExternalDll.getProperties Method

IExternalDllgetProperties Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
string getProperties()
Function getProperties As String
String^ getProperties()
abstract getProperties : unit -> string

Return Value

Type: String
Returns the XML string containing the updated property values after user DLL's computation.
See Also

Reference

IExternalDll Interface


IExternalDll.setInputCoordinates Method

IExternalDllsetInputCoordinates Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setInputCoordinates(
    int input,
    int dim,
    Object[] array
)
Sub setInputCoordinates (
    input As Integer,
    dim As Integer,
    array As Object()
)
void setInputCoordinates(
    int input,
    int dim,
    array<Object^>^ array
)
abstract setInputCoordinates :
        input : int *
        dim : int *
        array : Object[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
dim
Type: SystemInt32
Specifies the zero-based input data dimension index.
array
Type: SystemObject
Specifies the array containing the input data coordinates corresponding to the specified input and dimension.
See Also

Reference

IExternalDll Interface


IExternalDll.setInputDataIm Method

IExternalDllsetInputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setInputDataIm(
    int input,
    int channel,
    double[] array
)
Sub setInputDataIm (
    input As Integer,
    channel As Integer,
    array As Double()
)
void setInputDataIm(
    int input,
    int channel,
    array<double>^ array
)
abstract setInputDataIm :
        input : int *
        channel : int *
        array : float[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input data channel index.
array
Type: SystemDouble
Specifies the array containing the imaginary part of the input data corresponding to the specified input and channel.
See Also

Reference

IExternalDll Interface


IExternalDll.setInputDataRe Method

IExternalDllsetInputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setInputDataRe(
    int input,
    int channel,
    double[] array
)
Sub setInputDataRe (
    input As Integer,
    channel As Integer,
    array As Double()
)
void setInputDataRe(
    int input,
    int channel,
    array<double>^ array
)
abstract setInputDataRe :
        input : int *
        channel : int *
        array : float[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input data channel index.
array
Type: SystemDouble
Specifies the array containing the real part of the input data corresponding to the specified input and channel.
See Also

Reference

IExternalDll Interface


IExternalDll.setInputDescriptors Method

IExternalDllsetInputDescriptors Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setInputDescriptors(
    string xml
)
Sub setInputDescriptors (
    xml As String
)
void setInputDescriptors(
    String^ xml
)
abstract setInputDescriptors :
        xml : string -> unit

Parameters

xml
Type: SystemString
Specifies the XML string containing input descriptors before user DLL's computation.
See Also

Reference

IExternalDll Interface


IExternalDll.setProperties Method

IExternalDllsetProperties Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setProperties(
    string xml
)
Sub setProperties (
    xml As String
)
void setProperties(
    String^ xml
)
abstract setProperties :
        xml : string -> unit

Parameters

xml
Type: SystemString
Specifies the XML string containing new property values before user DLL's computation.
See Also

Reference

IExternalDll Interface


IExternalLicenseManager Interface

IExternalLicenseManager Interface Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

IExternalLicenseManager - Interface of external license manager. If license control is required in an external module, a license manager must be implemented according to this interface, and its ID registered in the module. Visual Signal will be responsible for the creation and initialization of all license managers available in the External directory. For security reasons, the implemented license manager *must* be included in the same assembly as the associated external modules to prevent spoofing. However, it is possible to implement IExternalLicenseManager as proxy license managers to be included in various assemblies, and have the proxy license managers accessing a central license control manager located in a separate assembly. *** Note that the implemented license manager class, as well as license controlled modules must be "sealed" to prevent re-inheriting the classes.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IExternalLicenseManager
Public Interface IExternalLicenseManager
public interface class IExternalLicenseManager
type IExternalLicenseManager =  interface end

The IExternalLicenseManager type exposes the following members.

Methods
 | Name | Description
Public method | LoadLicenses | This function must perform the necessary loading of any encrypted license files. Visual Signal will automatically call this function during program start-up.
Public method | VerifyLicense | This function must perform the necessary decryption of license files and try to match it against the specified licenseName. Any external modules using the license manager must register a license name in its Init. Visual Signal will automatically call this function when license verification is required.
Top
Properties
 | Name | Description
Public property | ID | Gets the license manager's ID name. Any license manager implementing this interface is responsible for assigning itself a unique ID name. Any external modules using the license manager must also register this ID in its Init.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


IExternalLicenseManager Methods

IExternalLicenseManager Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The IExternalLicenseManager type exposes the following members.

Methods
 | Name | Description
Public method | LoadLicenses | This function must perform the necessary loading of any encrypted license files. Visual Signal will automatically call this function during program start-up.
Public method | VerifyLicense | This function must perform the necessary decryption of license files and try to match it against the specified licenseName. Any external modules using the license manager must register a license name in its Init. Visual Signal will automatically call this function when license verification is required.
Top
See Also

Reference

IExternalLicenseManager Interface


IExternalLicenseManager.LoadLicenses Method

IExternalLicenseManagerLoadLicenses Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This function must perform the necessary loading of any encrypted license files. Visual Signal will automatically call this function during program start-up.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void LoadLicenses()
Sub LoadLicenses
void LoadLicenses()
abstract LoadLicenses : unit -> unit
See Also

Reference

IExternalLicenseManager Interface


IExternalLicenseManager.VerifyLicense Method

IExternalLicenseManagerVerifyLicense Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This function must perform the necessary decryption of license files and try to match it against the specified licenseName. Any external modules using the license manager must register a license name in its Init. Visual Signal will automatically call this function when license verification is required.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
bool VerifyLicense(
    string licenseName
)
Function VerifyLicense (
    licenseName As String
) As Boolean
bool VerifyLicense(
    String^ licenseName
)
abstract VerifyLicense :
        licenseName : string -> bool

Parameters

licenseName
Type: SystemString
Specifies the license name to be matched against loaded license files. Any external modules using the license manager must register a license name in its Init.

Return Value

Type: Boolean
Returns true if license name is valid.
See Also

Reference

IExternalLicenseManager Interface


IExternalLicenseManager Properties

IExternalLicenseManager Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The IExternalLicenseManager type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets the license manager's ID name. Any license manager implementing this interface is responsible for assigning itself a unique ID name. Any external modules using the license manager must also register this ID in its Init.
Top
See Also

Reference

IExternalLicenseManager Interface


IExternalLicenseManager.ID Property

IExternalLicenseManagerID Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the license manager's ID name. Any license manager implementing this interface is responsible for assigning itself a unique ID name. Any external modules using the license manager must also register this ID in its Init.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
string ID { get; }
ReadOnly Property ID As String
    Get
property String^ ID {
    String^ get ();
}
abstract ID : string with get

Property Value

Type: String
See Also

Reference

IExternalLicenseManager Interface


IExternalViewer Interface

IExternalViewer Interface Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

IExternalViewer - Interface of externally visible functions provided by external user viewers. All functions exported in the interface are used by Visual Signal's ExternalDll module to communicate with and control the execution of the user DLL. Default implementations will be provided in TExternalViewer, which can be inherited to provide custom behaviour.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public interface IExternalViewer : IExternalDll
Public Interface IExternalViewer
    Inherits IExternalDll
public interface class IExternalViewer : IExternalDll
type IExternalViewer =
    interface
        interface IExternalDll
    end

The IExternalViewer type exposes the following members.

Methods
 | Name | Description
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. (Inherited from IExternalDll.)
Public method | getDllInfo | Interface for exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, and properties. (Inherited from IExternalDll.)
Public method | getOutputCoordinates | Interface for exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDataRe | Interface for exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDescriptor | Interface for exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL. (Inherited from IExternalDll.)
Public method | getProperties | Interface for exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL. (Inherited from IExternalDll.)
Public method | getViewerPanel | Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user DLL
Public method | setBackColor | Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color
Public method | setInputCoordinates | Interface for exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDataIm | Interface for exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDataRe | Interface for exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDescriptors | Interface for exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL. (Inherited from IExternalDll.)
Public method | setProperties | Interface for exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL. (Inherited from IExternalDll.)
Public method | setTitle | Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


IExternalViewer Methods

IExternalViewer Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The IExternalViewer type exposes the following members.

Methods
 | Name | Description
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. (Inherited from IExternalDll.)
Public method | getDllInfo | Interface for exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, and properties. (Inherited from IExternalDll.)
Public method | getOutputCoordinates | Interface for exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDataRe | Interface for exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL. (Inherited from IExternalDll.)
Public method | getOutputDescriptor | Interface for exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL. (Inherited from IExternalDll.)
Public method | getProperties | Interface for exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL. (Inherited from IExternalDll.)
Public method | getViewerPanel | Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user DLL
Public method | setBackColor | Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color
Public method | setInputCoordinates | Interface for exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDataIm | Interface for exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDataRe | Interface for exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL. (Inherited from IExternalDll.)
Public method | setInputDescriptors | Interface for exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL. (Inherited from IExternalDll.)
Public method | setProperties | Interface for exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL. (Inherited from IExternalDll.)
Public method | setTitle | Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title
Top
See Also

Reference

IExternalViewer Interface


IExternalViewer.getViewerPanel Method

IExternalViewergetViewerPanel Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user DLL

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
Panel getViewerPanel()
Function getViewerPanel As Panel
Panel^ getViewerPanel()
abstract getViewerPanel : unit -> Panel

Return Value

Type: Panel
Returns the external System.Windows.Forms.Panel object.
See Also

Reference

IExternalViewer Interface


IExternalViewer.setBackColor Method

IExternalViewersetBackColor Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setBackColor(
    Color color
)
Sub setBackColor (
    color As Color
)
void setBackColor(
    Color color
)
abstract setBackColor :
        color : Color -> unit

Parameters

color
Type: System.DrawingColor
See Also

Reference

IExternalViewer Interface


IExternalViewer.setTitle Method

IExternalViewersetTitle Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
void setTitle(
    string title,
    bool showTitle
)
Sub setTitle (
    title As String,
    showTitle As Boolean
)
void setTitle(
    String^ title,
    bool showTitle
)
abstract setTitle :
        title : string *
        showTitle : bool -> unit

Parameters

title
Type: SystemString
showTitle
Type: SystemBoolean
See Also

Reference

IExternalViewer Interface


TExternalBase Class

TExternalBase Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

ExternalBase - Base class implementing the IExternalDll interface. Any C# external user DLL must inherit this class and override implementation for Init and DoCompute.
Inheritance Hierarchy
SystemObject
VSignal.ExternalBaseTExternalBase
VSignal.ExternalBaseTExternalViewer

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public class TExternalBase : IExternalDll
Public Class TExternalBase
    Implements IExternalDll
public ref class TExternalBase : IExternalDll
type TExternalBase =
    class
        interface IExternalDll
    end

The TExternalBase type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBase | Initializes a new instance of the TExternalBase class
Top
Methods
 | Name | Description
Protected method | AcceptInput(TExternalBaseInputDataTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Protected method | AcceptInput(TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. This function just calls the protected function DoCompute, which the user DLL must override with own implementation. External properties, input and output data are processed by Visual Signal before and after the execution of this function. User should expect _inputData to contain the input data and update _outputData to sent to Visual Signal. User should also expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.
Protected method | DoCompute | Protected virtual function "DoCompute", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function compute which is in turn used by Visual Signal's ExternalDll module to start computation.
Public method | doubleClick | Interface for exported function "doubleClick", used by Visual Signal's ExternalDll module to handle the callback when user double-clicks the corresponding Visual Signal component. This function just calls the protected function OnDoubleClick, which the user DLL can override with own implementation. Like compute, external properties are processed by Visual Signal before and after the execution of this function; however, input and output data are not processed. User should expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getDllInfo | Exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, license control and properties.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetInputCoords | Protected function "GetInputCoords", provided to the user DLL to obtain the input coordinates.
Protected method | GetInputDataExtension | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the input data extension.
Protected method | GetInputDataExtensionKeys | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the available input data extension keys.
Protected method | GetInputDataIm | Protected function "GetInputDataRe", provided to the user DLL to obtain the imaginary part of the input data.
Protected method | GetInputDataRe | Protected function "GetInputDataRe", provided to the user DLL to obtain the real part of the input data.
Public method | getOutputCoordinates | Exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.
Public method | getOutputDataRe | Exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.
Public method | getOutputDescriptor | Exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.
Public method | getProperties | Exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.
Protected method | GetPropertyValue | (Deprecated) Protected function "GetPropertyValue", provided to the user DLL for retrieving the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be accessed like regular C# public properties.
Public method | GetType | (Inherited from Object.)
 | GetXmlField | Static utility function "GetXmlField", provided for general use to obtain a field value from an XML document.
Protected method | Init | Protected virtual function "Init", intended to be overridden by the inherited user DLL class to provide the initialization function. This function is called by the exported function getDllInfo.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDoubleClick | Protected virtual function "OnDoubleClick", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function doubleClick which is in turn used by Visual Signal's ExternalDll module to handle callback when user double-clicked on the module.
 | ParseExternalXmlInfo | Parse external DLL info from XML
Protected method | RegisterProperty | (Deprecated) Protected function "RegisterProperty", proved to the user DLL for registering properties used by the DLL computation. This function should be invoked in Init, and the registered properties will be passed to Visual Signal's ExternalDll module via getDllInfo and become available in the module's property dialog for editing. The current values will be communicated back and forth between ExternalDll module and the user DLL via setProperties(String) and getProperties exported functions. This is deprecated. Property values can now be defined like regular C# properties, with appropriate attributes attached to the properties to define their categories, display names, descriptions, etc. Properties must be public and browsable.
Protected method | SetExtendedInfo | Protected virtual function "SetExtendedInfo", intended to be overridden by the inherited non-user class to set additional root attributes. This function is called by the exported function getDllInfo.
Public method | setInputCoordinates | Exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.
Public method | setInputDataIm | Exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.
Public method | setInputDataRe | Exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.
Public method | setInputDescriptors | Exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.
Protected method | SetOutputCoords | Protected function "SetOutputCoords", provided to the user DLL to set the output coordinates.
Protected method | SetOutputDataExtension | Protected function "SetOutputDataExtension", provided to the user DLL to set the output data extension info.
Protected method | SetOutputDataIm | Protected function "SetOutputDataIm", provided to the user DLL to set the imaginary part of the output data.
Protected method | SetOutputDataRe | Protected function "SetOutputDataRe", provided to the user DLL to set the real part of the output data.
Public method | setProperties | Exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.
 | SetXmlField | Static utility function "SetXmlField", provided for general use to set a field value in an XML document.
Public method | ToString | (Inherited from Object.)
Protected method | UpdateProperty | (Deprecated) Protected function "UpdateProperty", provided to the user DLL for updating the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be updated like regular C# public properties.
Top
Fields
 | Name | Description
Protected field | _inputData | This protected member will be initialized and updated by Visual Signal's ExternalDll module via setInputDescriptors(String), setInputCoordinates(Int32, Int32, Object), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double). The user DLL can directly access the DllData objects to obtain the data descriptor information.
Protected field | _inputTypes | This protected member contains a table of TExternalBaseDllInputType objects which stores the parameters used by the DLL. The table (in the form of a List) should be initialized in Init using AcceptInput().
Protected field | _outputData | This protected member should be initialized and updated in the user DLL's DoCompute function to contain the output data (only one allowed).
Protected field | _properties | (Deprecated) This protected member contains a table of TExternalBaseDllProperty objects which stores the parameters used by the DLL. The table (in the form of a Dictionary) should be initialized in Init using RegisterProperty(). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable.
Protected field | _props | This protected member contains a table of ExtensionProperty objects which stores the parameters used by the use's DLL, it is not necessary to access this object directly. Use RegisterProperty(String, Type, Object, String, String, String, String, Int32), GetPropertyValue(String), and UpdateProperty(String, Object) functions instead to initialize, get, and set properties.
Top
Properties
 | Name | Description
Protected property | InfoText | Set this property in Init to register the infoText of the user module. This will appear in Visual Signal as a tooltip for the DLL.
Protected property | LicenseManagerID | Set this property in Init to register the license manager ID. If a license manager matching the ID were found, Visual Signal will attempt to use license control for the user module. If the property is not set or set to an empty string, license control will not be used for the user module.
Protected property | LicenseName | Set this property in Init to register the license name. Visual Signal will attempt to match the license name against any license files loaded by the license manager. If no valid license file matches the license name, then the user module will not be available for use in Visual Signal. For security reasons, the module will also not be available if a license manager matching LicenseManagerID were *not* found.
Protected property | MinInputCount | Set this property in Init to register the minimum number of inputs acceptable by the user DmoduleLL.
Protected property | Name | Set this property in Init to register the name of the user module.
Protected property | Version | Set this property in Init to register the version of the user module.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase Constructor

TExternalBase Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TExternalBase class

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalBase()
Public Sub New
public:
TExternalBase()
new : unit -> TExternalBase
See Also

Reference

TExternalBase Class


TExternalBase Fields

TExternalBase Fields Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBase type exposes the following members.

Fields
 | Name | Description
Protected field | _inputData | This protected member will be initialized and updated by Visual Signal's ExternalDll module via setInputDescriptors(String), setInputCoordinates(Int32, Int32, Object), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double). The user DLL can directly access the DllData objects to obtain the data descriptor information.
Protected field | _inputTypes | This protected member contains a table of TExternalBaseDllInputType objects which stores the parameters used by the DLL. The table (in the form of a List) should be initialized in Init using AcceptInput().
Protected field | _outputData | This protected member should be initialized and updated in the user DLL's DoCompute function to contain the output data (only one allowed).
Protected field | _properties | (Deprecated) This protected member contains a table of TExternalBaseDllProperty objects which stores the parameters used by the DLL. The table (in the form of a Dictionary) should be initialized in Init using RegisterProperty(). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable.
Protected field | _props | This protected member contains a table of ExtensionProperty objects which stores the parameters used by the use's DLL, it is not necessary to access this object directly. Use RegisterProperty(String, Type, Object, String, String, String, String, Int32), GetPropertyValue(String), and UpdateProperty(String, Object) functions instead to initialize, get, and set properties.
Top
See Also

Reference

TExternalBase Class


TExternalBase._inputData Field

TExternalBase_inputData Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member will be initialized and updated by Visual Signal's ExternalDll module via setInputDescriptors(String), setInputCoordinates(Int32, Int32, Object), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double). The user DLL can directly access the DllData objects to obtain the data descriptor information.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected TExternalBaseDllData[] _inputData
Protected _inputData As TExternalBaseDllData()
protected:
array<TExternalBaseDllData^>^ _inputData
val mutable _inputData: TExternalBaseDllData[]

Field Value

Type: TExternalBaseDllData
See Also

Reference

TExternalBase Class


TExternalBase._inputTypes Field

TExternalBase_inputTypes Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains a table of TExternalBaseDllInputType objects which stores the parameters used by the DLL. The table (in the form of a List) should be initialized in Init using AcceptInput().

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected List<TExternalBaseDllInputType> _inputTypes
Protected _inputTypes As List(Of TExternalBaseDllInputType)
protected:
List<TExternalBaseDllInputType^>^ _inputTypes
val mutable _inputTypes: List<TExternalBaseDllInputType>

Field Value

Type: List TExternalBaseDllInputType
See Also

Reference

TExternalBase Class


TExternalBase._outputData Field

TExternalBase_outputData Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member should be initialized and updated in the user DLL's DoCompute function to contain the output data (only one allowed).

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected TExternalBaseDllData _outputData
Protected _outputData As TExternalBaseDllData
protected:
TExternalBaseDllData^ _outputData
val mutable _outputData: TExternalBaseDllData

Field Value

Type: TExternalBaseDllData
See Also

Reference

TExternalBase Class


TExternalBase._properties Field

TExternalBase_properties Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

(Deprecated) This protected member contains a table of TExternalBaseDllProperty objects which stores the parameters used by the DLL. The table (in the form of a Dictionary) should be initialized in Init using RegisterProperty(). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Dictionary<string, TExternalBaseDllProperty> _properties
Protected _properties As Dictionary(Of String, TExternalBaseDllProperty)
protected:
Dictionary<String^, TExternalBaseDllProperty^>^ _properties
val mutable _properties: Dictionary<string, TExternalBaseDllProperty>

Field Value

Type: Dictionary String, TExternalBaseDllProperty
See Also

Reference

TExternalBase Class


TExternalBase._props Field

TExternalBase_props Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains a table of ExtensionProperty objects which stores the parameters used by the use's DLL, it is not necessary to access this object directly. Use RegisterProperty(String, Type, Object, String, String, String, String, Int32), GetPropertyValue(String), and UpdateProperty(String, Object) functions instead to initialize, get, and set properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected ExtensionPropertiesBase _props
Protected _props As ExtensionPropertiesBase
protected:
ExtensionPropertiesBase^ _props
val mutable _props: ExtensionPropertiesBase

Field Value

Type: ExtensionPropertiesBase
See Also

Reference

TExternalBase Class


TExternalBase Methods

TExternalBase Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBase type exposes the following members.

Methods
 | Name | Description
Protected method | AcceptInput(TExternalBaseInputDataTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Protected method | AcceptInput(TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. This function just calls the protected function DoCompute, which the user DLL must override with own implementation. External properties, input and output data are processed by Visual Signal before and after the execution of this function. User should expect _inputData to contain the input data and update _outputData to sent to Visual Signal. User should also expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.
Protected method | DoCompute | Protected virtual function "DoCompute", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function compute which is in turn used by Visual Signal's ExternalDll module to start computation.
Public method | doubleClick | Interface for exported function "doubleClick", used by Visual Signal's ExternalDll module to handle the callback when user double-clicks the corresponding Visual Signal component. This function just calls the protected function OnDoubleClick, which the user DLL can override with own implementation. Like compute, external properties are processed by Visual Signal before and after the execution of this function; however, input and output data are not processed. User should expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getDllInfo | Exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, license control and properties.
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetInputCoords | Protected function "GetInputCoords", provided to the user DLL to obtain the input coordinates.
Protected method | GetInputDataExtension | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the input data extension.
Protected method | GetInputDataExtensionKeys | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the available input data extension keys.
Protected method | GetInputDataIm | Protected function "GetInputDataRe", provided to the user DLL to obtain the imaginary part of the input data.
Protected method | GetInputDataRe | Protected function "GetInputDataRe", provided to the user DLL to obtain the real part of the input data.
Public method | getOutputCoordinates | Exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.
Public method | getOutputDataRe | Exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.
Public method | getOutputDescriptor | Exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.
Public method | getProperties | Exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.
Protected method | GetPropertyValue | (Deprecated) Protected function "GetPropertyValue", provided to the user DLL for retrieving the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be accessed like regular C# public properties.
Public method | GetType | (Inherited from Object.)
 | GetXmlField | Static utility function "GetXmlField", provided for general use to obtain a field value from an XML document.
Protected method | Init | Protected virtual function "Init", intended to be overridden by the inherited user DLL class to provide the initialization function. This function is called by the exported function getDllInfo.
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDoubleClick | Protected virtual function "OnDoubleClick", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function doubleClick which is in turn used by Visual Signal's ExternalDll module to handle callback when user double-clicked on the module.
 | ParseExternalXmlInfo | Parse external DLL info from XML
Protected method | RegisterProperty | (Deprecated) Protected function "RegisterProperty", proved to the user DLL for registering properties used by the DLL computation. This function should be invoked in Init, and the registered properties will be passed to Visual Signal's ExternalDll module via getDllInfo and become available in the module's property dialog for editing. The current values will be communicated back and forth between ExternalDll module and the user DLL via setProperties(String) and getProperties exported functions. This is deprecated. Property values can now be defined like regular C# properties, with appropriate attributes attached to the properties to define their categories, display names, descriptions, etc. Properties must be public and browsable.
Protected method | SetExtendedInfo | Protected virtual function "SetExtendedInfo", intended to be overridden by the inherited non-user class to set additional root attributes. This function is called by the exported function getDllInfo.
Public method | setInputCoordinates | Exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.
Public method | setInputDataIm | Exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.
Public method | setInputDataRe | Exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.
Public method | setInputDescriptors | Exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.
Protected method | SetOutputCoords | Protected function "SetOutputCoords", provided to the user DLL to set the output coordinates.
Protected method | SetOutputDataExtension | Protected function "SetOutputDataExtension", provided to the user DLL to set the output data extension info.
Protected method | SetOutputDataIm | Protected function "SetOutputDataIm", provided to the user DLL to set the imaginary part of the output data.
Protected method | SetOutputDataRe | Protected function "SetOutputDataRe", provided to the user DLL to set the real part of the output data.
Public method | setProperties | Exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.
 | SetXmlField | Static utility function "SetXmlField", provided for general use to set a field value in an XML document.
Public method | ToString | (Inherited from Object.)
Protected method | UpdateProperty | (Deprecated) Protected function "UpdateProperty", provided to the user DLL for updating the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be updated like regular C# public properties.
Top
See Also

Reference

TExternalBase Class


TExternalBase.AcceptInput Method

TExternalBaseAcceptInput Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Protected method | AcceptInput(TExternalBaseInputDataTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Protected method | AcceptInput(TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.
Top
See Also

Reference

TExternalBase Class


TExternalBase.AcceptInput Method (TExternalBase.InputDataTypes)

TExternalBaseAcceptInput Method (TExternalBaseInputDataTypes) Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void AcceptInput(
    TExternalBaseInputDataTypes dataType
)
Protected Sub AcceptInput (
    dataType As TExternalBaseInputDataTypes
)
protected:
void AcceptInput(
    TExternalBaseInputDataTypes dataType
)
member AcceptInput :
        dataType : TExternalBaseInputDataTypes -> unit

Parameters

dataType
Type: VSignal.ExternalBaseTExternalBaseInputDataTypes
Specifies the accepted input data type.
Remarks
This overloaded function accepts ony the data type, all other parameters will be set to "any".
See Also

Reference

TExternalBase Class
AcceptInput Overload


TExternalBase.AcceptInput Method (TExternalBase.InputDataTypes, Int32, TExternalBase.InputCoordinateTypes, TExternalBase.InputChannelTypes, TExternalBase.InputValueTypes)

TExternalBaseAcceptInput Method (TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void AcceptInput(
    TExternalBaseInputDataTypes dataType,
    int rank,
    TExternalBaseInputCoordinateTypes coordinateType,
    TExternalBaseInputChannelTypes channelType,
    TExternalBaseInputValueTypes dataValueType
)
Protected Sub AcceptInput (
    dataType As TExternalBaseInputDataTypes,
    rank As Integer,
    coordinateType As TExternalBaseInputCoordinateTypes,
    channelType As TExternalBaseInputChannelTypes,
    dataValueType As TExternalBaseInputValueTypes
)
protected:
void AcceptInput(
    TExternalBaseInputDataTypes dataType,
    int rank,
    TExternalBaseInputCoordinateTypes coordinateType,
    TExternalBaseInputChannelTypes channelType,
    TExternalBaseInputValueTypes dataValueType
)
member AcceptInput :
        dataType : TExternalBaseInputDataTypes *
        rank : int *
        coordinateType : TExternalBaseInputCoordinateTypes *
        channelType : TExternalBaseInputChannelTypes *
        dataValueType : TExternalBaseInputValueTypes -> unit

Parameters

dataType
Type: VSignal.ExternalBaseTExternalBaseInputDataTypes
Specifies the accepted input data type.
rank
Type: SystemInt32
Specifies the accepted input data rank. Specifying a 0 means that any data rank is accepted.
coordinateType
Type: VSignal.ExternalBaseTExternalBaseInputCoordinateTypes
Specifies the accepted input coordinate type.
channelType
Type: VSignal.ExternalBaseTExternalBaseInputChannelTypes
Specifies the accepted input channel type.
dataValueType
Type: VSignal.ExternalBaseTExternalBaseInputValueTypes
Specifies the accepted input data value type.
See Also

Reference

TExternalBase Class
AcceptInput Overload


TExternalBase.compute Method

TExternalBasecompute Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. This function just calls the protected function DoCompute, which the user DLL must override with own implementation. External properties, input and output data are processed by Visual Signal before and after the execution of this function. User should expect _inputData to contain the input data and update _outputData to sent to Visual Signal. User should also expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool compute()
Public Function compute As Boolean
public:
virtual bool compute() sealed
abstract compute : unit -> bool
override compute : unit -> bool

Return Value

Type: Boolean
Returns True if computation is successful.

Implements

IExternalDllcompute
See Also

Reference

TExternalBase Class


TExternalBase.DoCompute Method

TExternalBaseDoCompute Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected virtual function "DoCompute", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function compute which is in turn used by Visual Signal's ExternalDll module to start computation.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual bool DoCompute()
Protected Overridable Function DoCompute As Boolean
protected:
virtual bool DoCompute()
abstract DoCompute : unit -> bool
override DoCompute : unit -> bool

Return Value

Type: Boolean
Returns True if computation is successful.
See Also

Reference

TExternalBase Class


TExternalBase.doubleClick Method

TExternalBasedoubleClick Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "doubleClick", used by Visual Signal's ExternalDll module to handle the callback when user double-clicks the corresponding Visual Signal component. This function just calls the protected function OnDoubleClick, which the user DLL can override with own implementation. Like compute, external properties are processed by Visual Signal before and after the execution of this function; however, input and output data are not processed. User should expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void doubleClick()
Public Sub doubleClick
public:
void doubleClick()
member doubleClick : unit -> unit
See Also

Reference

TExternalBase Class


TExternalBase.getDllInfo Method

TExternalBasegetDllInfo Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, license control and properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string getDllInfo()
Public Function getDllInfo As String
public:
virtual String^ getDllInfo() sealed
abstract getDllInfo : unit -> string
override getDllInfo : unit -> string

Return Value

Type: String
Returns the XML string containing DLL Info.

Implements

IExternalDllgetDllInfo
See Also

Reference

TExternalBase Class


TExternalBase.GetInputCoords Method

TExternalBaseGetInputCoords Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "GetInputCoords", provided to the user DLL to obtain the input coordinates.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Object[] GetInputCoords(
    int input,
    int dim
)
Protected Function GetInputCoords (
    input As Integer,
    dim As Integer
) As Object()
protected:
array<Object^>^ GetInputCoords(
    int input,
    int dim
)
member GetInputCoords :
        input : int *
        dim : int -> Object[]

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
dim
Type: SystemInt32
Specifies the zero-based input coordinate dimension index.

Return Value

Type: Object
Returns the input coordinates as an object[] array. The actual type of the coordinate values can be double-precision values, System.DateTime values, or strings.
See Also

Reference

TExternalBase Class


TExternalBase.GetInputDataExtension Method

TExternalBaseGetInputDataExtension Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the input data extension.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Object GetInputDataExtension(
    int input,
    string key
)
Protected Function GetInputDataExtension (
    input As Integer,
    key As String
) As Object
protected:
Object^ GetInputDataExtension(
    int input,
    String^ key
)
member GetInputDataExtension :
        input : int *
        key : string -> Object

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
key
Type: SystemString
Specifies the input data extension key.

Return Value

Type: Object
Returns the input data extension value for the specified input and key.
See Also

Reference

TExternalBase Class


TExternalBase.GetInputDataExtensionKeys Method

TExternalBaseGetInputDataExtensionKeys Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the available input data extension keys.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string[] GetInputDataExtensionKeys(
    int input
)
Protected Function GetInputDataExtensionKeys (
    input As Integer
) As String()
protected:
array<String^>^ GetInputDataExtensionKeys(
    int input
)
member GetInputDataExtensionKeys :
        input : int -> string[]

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.

Return Value

Type: String
Returns the string array of extension keys for the specified input.
See Also

Reference

TExternalBase Class


TExternalBase.GetInputDataIm Method

TExternalBaseGetInputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "GetInputDataRe", provided to the user DLL to obtain the imaginary part of the input data.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected double[] GetInputDataIm(
    int input,
    int channel
)
Protected Function GetInputDataIm (
    input As Integer,
    channel As Integer
) As Double()
protected:
array<double>^ GetInputDataIm(
    int input,
    int channel
)
member GetInputDataIm :
        input : int *
        channel : int -> float[]

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input channel index.

Return Value

Type: Double
Returns the imaginary part of the input data as a double[] array.
See Also

Reference

TExternalBase Class


TExternalBase.GetInputDataRe Method

TExternalBaseGetInputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "GetInputDataRe", provided to the user DLL to obtain the real part of the input data.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected double[] GetInputDataRe(
    int input,
    int channel
)
Protected Function GetInputDataRe (
    input As Integer,
    channel As Integer
) As Double()
protected:
array<double>^ GetInputDataRe(
    int input,
    int channel
)
member GetInputDataRe :
        input : int *
        channel : int -> float[]

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input channel index.

Return Value

Type: Double
Returns the real part of the input data as a double[] array.
See Also

Reference

TExternalBase Class


TExternalBase.getOutputCoordinates Method

TExternalBasegetOutputCoordinates Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object[] getOutputCoordinates(
    int dim
)
Public Function getOutputCoordinates (
    dim As Integer
) As Object()
public:
virtual array<Object^>^ getOutputCoordinates(
    int dim
) sealed
abstract getOutputCoordinates :
        dim : int -> Object[]
override getOutputCoordinates :
        dim : int -> Object[]

Parameters

dim
Type: SystemInt32
Specifies the zero-based input data dimension index.

Return Value

Type: Object
Returns the array containing the input data coordinates corresponding to the specified input data dimension.

Implements

IExternalDllgetOutputCoordinates(Int32)
See Also

Reference

TExternalBase Class


TExternalBase.getOutputDataIm Method

TExternalBasegetOutputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] getOutputDataIm(
    int channel
)
Public Function getOutputDataIm (
    channel As Integer
) As Double()
public:
virtual array<double>^ getOutputDataIm(
    int channel
) sealed
abstract getOutputDataIm :
        channel : int -> float[]
override getOutputDataIm :
        channel : int -> float[]

Parameters

channel
Type: SystemInt32
Specifies the zero-based input data channel index.

Return Value

Type: Double
Returns the output data (imaginary part) in the form of a double[] array.

Implements

IExternalDllgetOutputDataIm(Int32)
See Also

Reference

TExternalBase Class


TExternalBase.getOutputDataRe Method

TExternalBasegetOutputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] getOutputDataRe(
    int channel
)
Public Function getOutputDataRe (
    channel As Integer
) As Double()
public:
virtual array<double>^ getOutputDataRe(
    int channel
) sealed
abstract getOutputDataRe :
        channel : int -> float[]
override getOutputDataRe :
        channel : int -> float[]

Parameters

channel
Type: SystemInt32
Specifies the zero-based input data channel index.

Return Value

Type: Double
Returns the output data (real part) in the form of a double[] array.

Implements

IExternalDllgetOutputDataRe(Int32)
See Also

Reference

TExternalBase Class


TExternalBase.getOutputDescriptor Method

TExternalBasegetOutputDescriptor Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string getOutputDescriptor()
Public Function getOutputDescriptor As String
public:
virtual String^ getOutputDescriptor() sealed
abstract getOutputDescriptor : unit -> string
override getOutputDescriptor : unit -> string

Return Value

Type: String
Returns the XML string of the output descriptor.

Implements

IExternalDllgetOutputDescriptor
See Also

Reference

TExternalBase Class


TExternalBase.getProperties Method

TExternalBasegetProperties Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string getProperties()
Public Function getProperties As String
public:
virtual String^ getProperties() sealed
abstract getProperties : unit -> string
override getProperties : unit -> string

Return Value

Type: String
Returns the XML string containing the updated property values after user DLL's computation.

Implements

IExternalDllgetProperties
See Also

Reference

TExternalBase Class


TExternalBase.GetPropertyValue Method

TExternalBaseGetPropertyValue Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

(Deprecated) Protected function "GetPropertyValue", provided to the user DLL for retrieving the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be accessed like regular C# public properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Object GetPropertyValue(
    string name
)
Protected Function GetPropertyValue (
    name As String
) As Object
protected:
Object^ GetPropertyValue(
    String^ name
)
member GetPropertyValue :
        name : string -> Object

Parameters

name
Type: SystemString
Specifies the name of the property.

Return Value

Type: Object
Returns the property value.
See Also

Reference

TExternalBase Class


TExternalBase.GetXmlField Method

TExternalBaseGetXmlField Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Static utility function "GetXmlField", provided for general use to obtain a field value from an XML document.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public static Object GetXmlField(
    XmlElement root,
    string fieldName,
    bool isRequired = true
)
Public Shared Function GetXmlField (
    root As XmlElement,
    fieldName As String,
    Optional isRequired As Boolean = true
) As Object
public:
static Object^ GetXmlField(
    XmlElement^ root,
    String^ fieldName,
    bool isRequired = true
)
static member GetXmlField :
        root : XmlElement *
        fieldName : string *
        ?isRequired : bool
(* Defaults:
        let _isRequired = defaultArg isRequired true
*)
-> Object

Parameters

root
Type: System.XmlXmlElement
Specifies the XML root element.
fieldName
Type: SystemString
Specifies the name of the field to be updated.
isRequired (Optional)
Type: SystemBoolean
Specifies True if the field is required. An exception will be thrown if a required field is missing in the XML document. Default is true.

Return Value

Type: Object
Returns the field values as an System.Object. User must cast the return value to T[].
See Also

Reference

TExternalBase Class


TExternalBase.Init Method

TExternalBaseInit Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected virtual function "Init", intended to be overridden by the inherited user DLL class to provide the initialization function. This function is called by the exported function getDllInfo.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void Init()
Protected Overridable Sub Init
protected:
virtual void Init()
abstract Init : unit -> unit
override Init : unit -> unit
See Also

Reference

TExternalBase Class


TExternalBase.OnDoubleClick Method

TExternalBaseOnDoubleClick Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected virtual function "OnDoubleClick", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function doubleClick which is in turn used by Visual Signal's ExternalDll module to handle callback when user double-clicked on the module.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnDoubleClick()
Protected Overridable Sub OnDoubleClick
protected:
virtual void OnDoubleClick()
abstract OnDoubleClick : unit -> unit
override OnDoubleClick : unit -> unit
See Also

Reference

TExternalBase Class


TExternalBase.ParseExternalXmlInfo Method

TExternalBaseParseExternalXmlInfo Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Parse external DLL info from XML

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public static void ParseExternalXmlInfo(
    XmlElement root,
    out string apiVersion,
    out string language,
    out string version,
    out string name,
    out int minInputCount,
    out string infoText,
    out string licenseManagerID,
    out string licenseName
)
Public Shared Sub ParseExternalXmlInfo (
    root As XmlElement,
    <OutAttribute> ByRef apiVersion As String,
    <OutAttribute> ByRef language As String,
    <OutAttribute> ByRef version As String,
    <OutAttribute> ByRef name As String,
    <OutAttribute> ByRef minInputCount As Integer,
    <OutAttribute> ByRef infoText As String,
    <OutAttribute> ByRef licenseManagerID As String,
    <OutAttribute> ByRef licenseName As String
)
public:
static void ParseExternalXmlInfo(
    XmlElement^ root,
    [OutAttribute] String^% apiVersion,
    [OutAttribute] String^% language,
    [OutAttribute] String^% version,
    [OutAttribute] String^% name,
    [OutAttribute] int% minInputCount,
    [OutAttribute] String^% infoText,
    [OutAttribute] String^% licenseManagerID,
    [OutAttribute] String^% licenseName
)
static member ParseExternalXmlInfo :
        root : XmlElement *
        apiVersion : string byref *
        language : string byref *
        version : string byref *
        name : string byref *
        minInputCount : int byref *
        infoText : string byref *
        licenseManagerID : string byref *
        licenseName : string byref -> unit

Parameters

root
Type: System.XmlXmlElement
Root XML element to parse from
apiVersion
Type: SystemString
Output API version
language
Type: SystemString
Output DLL language
version
Type: SystemString
Output DLL version
name
Type: SystemString
Output DLL name
minInputCount
Type: SystemInt32
Output min. number of inputs
infoText
Type: SystemString
Output optional info text
licenseManagerID
Type: SystemString
Output optional license manager ID
licenseName
Type: SystemString
Output optional license name
See Also

Reference

TExternalBase Class


TExternalBase.RegisterProperty Method

TExternalBaseRegisterProperty Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

(Deprecated) Protected function "RegisterProperty", proved to the user DLL for registering properties used by the DLL computation. This function should be invoked in Init, and the registered properties will be passed to Visual Signal's ExternalDll module via getDllInfo and become available in the module's property dialog for editing. The current values will be communicated back and forth between ExternalDll module and the user DLL via setProperties(String) and getProperties exported functions. This is deprecated. Property values can now be defined like regular C# properties, with appropriate attributes attached to the properties to define their categories, display names, descriptions, etc. Properties must be public and browsable.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void RegisterProperty(
    string name,
    Type type,
    Object defaultValue,
    string category,
    string displayName,
    string description,
    string tags = null,
    int order = -1
)
Protected Sub RegisterProperty (
    name As String,
    type As Type,
    defaultValue As Object,
    category As String,
    displayName As String,
    description As String,
    Optional tags As String = Nothing,
    Optional order As Integer = -1
)
protected:
void RegisterProperty(
    String^ name,
    Type^ type,
    Object^ defaultValue,
    String^ category,
    String^ displayName,
    String^ description,
    String^ tags = nullptr,
    int order = -1
)
member RegisterProperty :
        name : string *
        type : Type *
        defaultValue : Object *
        category : string *
        displayName : string *
        description : string *
        ?tags : string *
        ?order : int
(* Defaults:
        let _tags = defaultArg tags null
        let _order = defaultArg order -1
*)
-> unit

Parameters

name
Type: SystemString
Specifies the name of the property.
type
Type: SystemType
Specifies the System.Type of the property. Currently, only the following types are handled:
Type | Description
System.Boolean | Use typeof(bool) to obtain this System.Type.
System.Int32 | Use typeof(int) to obtain this System.Type.
System.Double | Use typeof(double) to obtain this System.Type.
System.String | Use typeof(string) to obtain this System.Type.
System.Int32[] | Use typeof(int[]) to obtain this System.Type. This will be handled in Visual Signal's property dialog as a string delimiited by ",", ";", or " ".
System.Double[] | Use typeof(double[]) to obtain this System.Type. This will be handled in Visual Signal's property dialog as a string delimiited by ",", ";", or " ".
System.Enum | Use typeof({enumType}) to obtain the type, where {enumType} is a user-defined enum type whose base type is System.Enum. This will be handled in Visual Signal's property dialog as a pull-down menu.
defaultValue
Type: SystemObject
Specifies the default value of the property.
category
Type: SystemString
Specifies the category of the property.
displayName
Type: SystemString
Specifies the display name of the property.
description
Type: SystemString
Specifies the description of the property.
tags (Optional)
Type: SystemString
Specifies comma-separated tags for special purposes. Currently supports:
Type | Description
"ReadOnly" | Specifies that the property is read-only when displayed in Visual Signal.
"File:[fileter]" | Specifies that the property is a file path, and can invoke the OpenFile dialog in Visual Signal. The filters used in OpenFile dialog can be specified using the standard "|"-separated .Net filter specification in [filter]. For example: "Text files (*.txt)|*.txt|All files (*.*)|*.*", or "Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*"
order (Optional)
Type: SystemInt32
Specifies the order of the property
See Also

Reference

TExternalBase Class


TExternalBase.SetExtendedInfo Method

TExternalBaseSetExtendedInfo Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected virtual function "SetExtendedInfo", intended to be overridden by the inherited non-user class to set additional root attributes. This function is called by the exported function getDllInfo.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetExtendedInfo(
    XmlDocument xdoc
)
Protected Overridable Sub SetExtendedInfo (
    xdoc As XmlDocument
)
protected:
virtual void SetExtendedInfo(
    XmlDocument^ xdoc
)
abstract SetExtendedInfo :
        xdoc : XmlDocument -> unit
override SetExtendedInfo :
        xdoc : XmlDocument -> unit

Parameters

xdoc
Type: System.XmlXmlDocument
Specifies the XML document containing the module info.
See Also

Reference

TExternalBase Class


TExternalBase.setInputCoordinates Method

TExternalBasesetInputCoordinates Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setInputCoordinates(
    int input,
    int dim,
    Object[] array
)
Public Sub setInputCoordinates (
    input As Integer,
    dim As Integer,
    array As Object()
)
public:
virtual void setInputCoordinates(
    int input,
    int dim,
    array<Object^>^ array
) sealed
abstract setInputCoordinates :
        input : int *
        dim : int *
        array : Object[] -> unit
override setInputCoordinates :
        input : int *
        dim : int *
        array : Object[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index
dim
Type: SystemInt32
Specifies the zero-based input data dimension index
array
Type: SystemObject
Specifies the array containing the input data coordinates corresponding to the specified input and dimension

Implements

IExternalDllsetInputCoordinates(Int32, Int32, Object)
See Also

Reference

TExternalBase Class


TExternalBase.setInputDataIm Method

TExternalBasesetInputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setInputDataIm(
    int input,
    int channel,
    double[] array
)
Public Sub setInputDataIm (
    input As Integer,
    channel As Integer,
    array As Double()
)
public:
virtual void setInputDataIm(
    int input,
    int channel,
    array<double>^ array
) sealed
abstract setInputDataIm :
        input : int *
        channel : int *
        array : float[] -> unit
override setInputDataIm :
        input : int *
        channel : int *
        array : float[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input data channel index.
array
Type: SystemDouble
Specifies the array containing the imaginary part of the input data corresponding to the specified input and channel.

Implements

IExternalDllsetInputDataIm(Int32, Int32, Double)
See Also

Reference

TExternalBase Class


TExternalBase.setInputDataRe Method

TExternalBasesetInputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setInputDataRe(
    int input,
    int channel,
    double[] array
)
Public Sub setInputDataRe (
    input As Integer,
    channel As Integer,
    array As Double()
)
public:
virtual void setInputDataRe(
    int input,
    int channel,
    array<double>^ array
) sealed
abstract setInputDataRe :
        input : int *
        channel : int *
        array : float[] -> unit
override setInputDataRe :
        input : int *
        channel : int *
        array : float[] -> unit

Parameters

input
Type: SystemInt32
Specifies the zero-based input data index.
channel
Type: SystemInt32
Specifies the zero-based input data channel index.
array
Type: SystemDouble
Specifies the array containing the real part of the input data corresponding to the specified input and channel.

Implements

IExternalDllsetInputDataRe(Int32, Int32, Double)
See Also

Reference

TExternalBase Class


TExternalBase.setInputDescriptors Method

TExternalBasesetInputDescriptors Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setInputDescriptors(
    string xml
)
Public Sub setInputDescriptors (
    xml As String
)
public:
virtual void setInputDescriptors(
    String^ xml
) sealed
abstract setInputDescriptors :
        xml : string -> unit
override setInputDescriptors :
        xml : string -> unit

Parameters

xml
Type: SystemString
Specifies the XML string containing input descriptors before user DLL's computation.

Implements

IExternalDllsetInputDescriptors(String)
See Also

Reference

TExternalBase Class


TExternalBase.SetOutputCoords Method

TExternalBaseSetOutputCoords Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "SetOutputCoords", provided to the user DLL to set the output coordinates.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void SetOutputCoords(
    int dim,
    Object[] coords
)
Protected Sub SetOutputCoords (
    dim As Integer,
    coords As Object()
)
protected:
void SetOutputCoords(
    int dim,
    array<Object^>^ coords
)
member SetOutputCoords :
        dim : int *
        coords : Object[] -> unit

Parameters

dim
Type: SystemInt32
Specifies the zero-based input coordinate dimension index.
coords
Type: SystemObject
The output coordinates as an object[] array. The actual type of the coordinate values can be double-precision values, System.DateTime values, or strings.
See Also

Reference

TExternalBase Class


TExternalBase.SetOutputDataExtension Method

TExternalBaseSetOutputDataExtension Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "SetOutputDataExtension", provided to the user DLL to set the output data extension info.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void SetOutputDataExtension(
    string key,
    Object value
)
Protected Sub SetOutputDataExtension (
    key As String,
    value As Object
)
protected:
void SetOutputDataExtension(
    String^ key,
    Object^ value
)
member SetOutputDataExtension :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString
Specifies the output data extension key.
value
Type: SystemObject
Specifies the output data extension value.
See Also

Reference

TExternalBase Class


TExternalBase.SetOutputDataIm Method

TExternalBaseSetOutputDataIm Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "SetOutputDataIm", provided to the user DLL to set the imaginary part of the output data.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void SetOutputDataIm(
    int channel,
    double[] data
)
Protected Sub SetOutputDataIm (
    channel As Integer,
    data As Double()
)
protected:
void SetOutputDataIm(
    int channel,
    array<double>^ data
)
member SetOutputDataIm :
        channel : int *
        data : float[] -> unit

Parameters

channel
Type: SystemInt32
Specifies the zero-based input channel index.
data
Type: SystemDouble
Specifies the imaginary part of the output data as a double[] array.
See Also

Reference

TExternalBase Class


TExternalBase.SetOutputDataRe Method

TExternalBaseSetOutputDataRe Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Protected function "SetOutputDataRe", provided to the user DLL to set the real part of the output data.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void SetOutputDataRe(
    int channel,
    double[] data
)
Protected Sub SetOutputDataRe (
    channel As Integer,
    data As Double()
)
protected:
void SetOutputDataRe(
    int channel,
    array<double>^ data
)
member SetOutputDataRe :
        channel : int *
        data : float[] -> unit

Parameters

channel
Type: SystemInt32
Specifies the zero-based input channel index.
data
Type: SystemDouble
Specifies the real part of the output data as a double[] array.
See Also

Reference

TExternalBase Class


TExternalBase.setProperties Method

TExternalBasesetProperties Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setProperties(
    string xml
)
Public Sub setProperties (
    xml As String
)
public:
virtual void setProperties(
    String^ xml
) sealed
abstract setProperties :
        xml : string -> unit
override setProperties :
        xml : string -> unit

Parameters

xml
Type: SystemString
Specifies the XML string containing new property values before user DLL's computation.

Implements

IExternalDllsetProperties(String)
See Also

Reference

TExternalBase Class


TExternalBase.SetXmlField Method

TExternalBaseSetXmlField Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Static utility function "SetXmlField", provided for general use to set a field value in an XML document.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public static void SetXmlField(
    XmlDocument xdoc,
    XmlElement elm,
    string fieldName,
    Object values
)
Public Shared Sub SetXmlField (
    xdoc As XmlDocument,
    elm As XmlElement,
    fieldName As String,
    values As Object
)
public:
static void SetXmlField(
    XmlDocument^ xdoc,
    XmlElement^ elm,
    String^ fieldName,
    Object^ values
)
static member SetXmlField :
        xdoc : XmlDocument *
        elm : XmlElement *
        fieldName : string *
        values : Object -> unit

Parameters

xdoc
Type: System.XmlXmlDocument
Specifies the XML document object.
elm
Type: System.XmlXmlElement
Specifies the XML element within the document.
fieldName
Type: SystemString
Specifies the field name to be updated.
values
Type: SystemObject
Specifies the field values, as an Array, to be updated.
See Also

Reference

TExternalBase Class


TExternalBase.UpdateProperty Method

TExternalBaseUpdateProperty Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

(Deprecated) Protected function "UpdateProperty", provided to the user DLL for updating the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be updated like regular C# public properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected void UpdateProperty(
    string name,
    Object value
)
Protected Sub UpdateProperty (
    name As String,
    value As Object
)
protected:
void UpdateProperty(
    String^ name,
    Object^ value
)
member UpdateProperty :
        name : string *
        value : Object -> unit

Parameters

name
Type: SystemString
Specifies the name of the property.
value
Type: SystemObject
Specifies the current value of the property.
See Also

Reference

TExternalBase Class


TExternalBase Properties

TExternalBase Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBase type exposes the following members.

Properties
 | Name | Description
Protected property | InfoText | Set this property in Init to register the infoText of the user module. This will appear in Visual Signal as a tooltip for the DLL.
Protected property | LicenseManagerID | Set this property in Init to register the license manager ID. If a license manager matching the ID were found, Visual Signal will attempt to use license control for the user module. If the property is not set or set to an empty string, license control will not be used for the user module.
Protected property | LicenseName | Set this property in Init to register the license name. Visual Signal will attempt to match the license name against any license files loaded by the license manager. If no valid license file matches the license name, then the user module will not be available for use in Visual Signal. For security reasons, the module will also not be available if a license manager matching LicenseManagerID were *not* found.
Protected property | MinInputCount | Set this property in Init to register the minimum number of inputs acceptable by the user DmoduleLL.
Protected property | Name | Set this property in Init to register the name of the user module.
Protected property | Version | Set this property in Init to register the version of the user module.
Top
See Also

Reference

TExternalBase Class


TExternalBase.InfoText Property

TExternalBaseInfoText Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the infoText of the user module. This will appear in Visual Signal as a tooltip for the DLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string InfoText { set; }
Protected WriteOnly Property InfoText As String
    Set
protected:
property String^ InfoText {
    void set (String^ value);
}
member InfoText : string with set

Property Value

Type: String
See Also

Reference

TExternalBase Class


TExternalBase.LicenseManagerID Property

TExternalBaseLicenseManagerID Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the license manager ID. If a license manager matching the ID were found, Visual Signal will attempt to use license control for the user module. If the property is not set or set to an empty string, license control will not be used for the user module.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string LicenseManagerID { set; }
Protected WriteOnly Property LicenseManagerID As String
    Set
protected:
property String^ LicenseManagerID {
    void set (String^ value);
}
member LicenseManagerID : string with set

Property Value

Type: String
See Also

Reference

TExternalBase Class


TExternalBase.LicenseName Property

TExternalBaseLicenseName Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the license name. Visual Signal will attempt to match the license name against any license files loaded by the license manager. If no valid license file matches the license name, then the user module will not be available for use in Visual Signal. For security reasons, the module will also not be available if a license manager matching LicenseManagerID were *not* found.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string LicenseName { set; }
Protected WriteOnly Property LicenseName As String
    Set
protected:
property String^ LicenseName {
    void set (String^ value);
}
member LicenseName : string with set

Property Value

Type: String
See Also

Reference

TExternalBase Class


TExternalBase.MinInputCount Property

TExternalBaseMinInputCount Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the minimum number of inputs acceptable by the user DmoduleLL.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected int MinInputCount { set; }
Protected WriteOnly Property MinInputCount As Integer
    Set
protected:
property int MinInputCount {
    void set (int value);
}
member MinInputCount : int with set

Property Value

Type: Int32
See Also

Reference

TExternalBase Class


TExternalBase.Name Property

TExternalBaseName Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the name of the user module.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string Name { set; }
Protected WriteOnly Property Name As String
    Set
protected:
property String^ Name {
    void set (String^ value);
}
member Name : string with set

Property Value

Type: String
See Also

Reference

TExternalBase Class


TExternalBase.Version Property

TExternalBaseVersion Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set this property in Init to register the version of the user module.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string Version { set; }
Protected WriteOnly Property Version As String
    Set
protected:
property String^ Version {
    void set (String^ value);
}
member Version : string with set

Property Value

Type: String
See Also

Reference

TExternalBase Class


TExternalBase.DllData Class

TExternalBaseDllData Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

DLLData - This class represents a data object used by the user DLL. Before DLL's computation stage, Visual Signal's ExternalDll will pass input descriptors and data via setInputDescriptors(String), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double) and converted automatically to an array of DllData objects. User DLL may access these info directly via the member _inputData, or via functions such as GetInputDataRe(Int32, Int32), GetInputDataIm(Int32, Int32), etc.
Inheritance Hierarchy
SystemObject
VSignal.ExternalBaseTExternalBaseDllData

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected class DllData
Protected Class DllData
protected ref class DllData
type DllData =  class end

The TExternalBaseDllData type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBaseDllData | Empty constructor for the DllData class.
Public method | TExternalBaseDllData(String, String, Int32, Boolean, Int32) | Constructor for the DllData class. This constructor will set the data rank, and allocate coordinates and related arrays accordingly.
Top
Methods
 | Name | Description
Public method | AddEvent | Add an event to the extension to the data extensions.
Public method | DeserializeExtensions | Deserialize extension data from XML
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEventFields | Get all event fields from the data extension.
Public method | GetEvents | Get all events from the data extensions.
Public method | GetExtension | Obtain the extension info value of a specific key.
Public method | GetExtensionKeys | Obtain all the extension info keys available.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SerializeExtensions | Serialize extension data to XML
Public method | SetEventFields | Set up event fields in the data extensions.
Public method | SetExtension | Setting a data extension info. Extension info will be used by specific VisualSignal components and data, such as "BitsPerSample" for audio data, or "XAxisTitle" for channel viewer.
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ChannelCount | Get/Set the channel count. Setting the property will automatically allocate DataArray, ImagArray, and ChannelNames arrays.
Public property | ChannelNames | Get/Set channel names.
Public property | Coordinates | Get/Set the coordinate values in the form of a object[][] array for "Indexed" coordinate Formats. This property is not used for "Regular" format. The outer level represents multiple dimensions.
Public property | DataArray | Get/Set the real part of the data values in the form of a double[][] array. The outer level represents multiple channels.
Public property | Formats | Get/Set the format of each dimension's coordinate. Currently supported formats are "Regular" and "Indexed". The "Regular" coordinate format requires only Starts and Intervals properties to define the regularly-spaced coordinates; the "Indexed" format requires the Coordinates property to define the array of coordinates.
Public property | ImagArray | Get/Set the imaginary part of the data values in the form of a double[][] array. The outer level represents multiple channels.
Public property | Intervals | Get/Set the interval value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed".
Public property | IsComplex | Get/Set whether data is complex (True/False).
Public property | IsDateTimes | Get/Set whether each dimension's coordinate is encoded DateTime value (True/False).
Public property | Lengths | Get/Set data lengths. For multi-dimensional data, the int[] array represents the length for each dimension. For a vector data, length of int[] array is 1.
Public property | Name | Get/Set the data name
Public property | Rank | Get/Set the data rank. Setting this property will automatically allocate Formats, Intervals, IsDateTimes, Lengths, Starts, Units, and Coordinates arrays.
Public property | Starts | Get/Set the starting value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed". The actual values can be double-precision values, or a System.DateTime objects depending on the IsDateTimes[] status. User must cast to the appropriate type when reading this property.
Public property | Type | Get/Set the data type. Type could be one of the following strings: "Signal", "Spectra", and "Numeric"
Public property | Units | Get/Set the unit string of each dimension's coordinate.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


DllData Constructor

DllData Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Overload List
 | Name | Description
Public method | TExternalBaseDllData | Empty constructor for the DllData class.
Public method | TExternalBaseDllData(String, String, Int32, Boolean, Int32) | Constructor for the DllData class. This constructor will set the data rank, and allocate coordinates and related arrays accordingly.
Top
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData Constructor

TExternalBaseDllData Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Empty constructor for the DllData class.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public DllData()
Public Sub New
public:
DllData()
new : unit -> DllData
See Also

Reference

TExternalBaseDllData Class
TExternalBaseDllData Overload


TExternalBase.DllData Constructor (String, String, Int32, Boolean, Int32)

TExternalBaseDllData Constructor (String, String, Int32, Boolean, Int32) Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Constructor for the DllData class. This constructor will set the data rank, and allocate coordinates and related arrays accordingly.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public DllData(
    string name,
    string type,
    int nch,
    bool isComplex,
    int rank = 1
)
Public Sub New (
    name As String,
    type As String,
    nch As Integer,
    isComplex As Boolean,
    Optional rank As Integer = 1
)
public:
DllData(
    String^ name,
    String^ type,
    int nch,
    bool isComplex,
    int rank = 1
)
new :
        name : string *
        type : string *
        nch : int *
        isComplex : bool *
        ?rank : int
(* Defaults:
        let _rank = defaultArg rank 1
*)
-> DllData

Parameters

name
Type: SystemString
Specifies the data name.
type
Type: SystemString
Specifies the data type.
nch
Type: SystemInt32
Specifies the number of channels
isComplex
Type: SystemBoolean
Specifies True if data is complex. ImagArray is ignored for non-complex data.
rank (Optional)
Type: SystemInt32
Specifies the rank of the data
See Also

Reference

TExternalBaseDllData Class
TExternalBaseDllData Overload


DllData Methods

DllData Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllData type exposes the following members.

Methods
 | Name | Description
Public method | AddEvent | Add an event to the extension to the data extensions.
Public method | DeserializeExtensions | Deserialize extension data from XML
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetEventFields | Get all event fields from the data extension.
Public method | GetEvents | Get all events from the data extensions.
Public method | GetExtension | Obtain the extension info value of a specific key.
Public method | GetExtensionKeys | Obtain all the extension info keys available.
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | SerializeExtensions | Serialize extension data to XML
Public method | SetEventFields | Set up event fields in the data extensions.
Public method | SetExtension | Setting a data extension info. Extension info will be used by specific VisualSignal components and data, such as "BitsPerSample" for audio data, or "XAxisTitle" for channel viewer.
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.AddEvent Method

TExternalBaseDllDataAddEvent Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Add an event to the extension to the data extensions.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AddEvent(
    Object[] eventObjects
)
Public Function AddEvent (
    eventObjects As Object()
) As Boolean
public:
bool AddEvent(
    array<Object^>^ eventObjects
)
member AddEvent :
        eventObjects : Object[] -> bool

Parameters

eventObjects
Type: SystemObject
Specifies the objects associated to the event to be added.

Return Value

Type: Boolean
Returns false if the add process fails.
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.DeserializeExtensions Method

TExternalBaseDllDataDeserializeExtensions Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Deserialize extension data from XML

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void DeserializeExtensions(
    XmlElement root
)
Public Sub DeserializeExtensions (
    root As XmlElement
)
public:
void DeserializeExtensions(
    XmlElement^ root
)
member DeserializeExtensions :
        root : XmlElement -> unit

Parameters

root
Type: System.XmlXmlElement
Root XML element to deserialize extensions from.
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.GetEventFields Method

TExternalBaseDllDataGetEventFields Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get all event fields from the data extension.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Tuple<string, Type>[] GetEventFields()
Public Function GetEventFields As Tuple(Of String, Type)()
public:
array<Tuple<String^, Type^>^>^ GetEventFields()
member GetEventFields : unit -> Tuple<string, Type>[]

Return Value

Type: Tuple String, Type
Returns all the event fields as an array of string/Type tuples.
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.GetEvents Method

TExternalBaseDllDataGetEvents Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get all events from the data extensions.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object[][] GetEvents()
Public Function GetEvents As Object()()
public:
array<array<Object^>^>^ GetEvents()
member GetEvents : unit -> Object[][]

Return Value

Type: Object
Returns the event objects of all the events as an object[][].
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.GetExtension Method

TExternalBaseDllDataGetExtension Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Obtain the extension info value of a specific key.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object GetExtension(
    string key
)
Public Function GetExtension (
    key As String
) As Object
public:
Object^ GetExtension(
    String^ key
)
member GetExtension :
        key : string -> Object

Parameters

key
Type: SystemString
Specify the extension key.

Return Value

Type: Object
Returns the extension value associated with the specified key.
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.GetExtensionKeys Method

TExternalBaseDllDataGetExtensionKeys Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Obtain all the extension info keys available.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] GetExtensionKeys()
Public Function GetExtensionKeys As String()
public:
array<String^>^ GetExtensionKeys()
member GetExtensionKeys : unit -> string[]

Return Value

Type: String
Returns an array of key strings
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.SerializeExtensions Method

TExternalBaseDllDataSerializeExtensions Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Serialize extension data to XML

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void SerializeExtensions(
    XmlDocument xdoc,
    XmlElement root
)
Public Sub SerializeExtensions (
    xdoc As XmlDocument,
    root As XmlElement
)
public:
void SerializeExtensions(
    XmlDocument^ xdoc,
    XmlElement^ root
)
member SerializeExtensions :
        xdoc : XmlDocument *
        root : XmlElement -> unit

Parameters

xdoc
Type: System.XmlXmlDocument
XML document
root
Type: System.XmlXmlElement
Root XML element under XML document
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.SetEventFields Method

TExternalBaseDllDataSetEventFields Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set up event fields in the data extensions.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool SetEventFields(
    Tuple<string, Type>[] fields
)
Public Function SetEventFields (
    fields As Tuple(Of String, Type)()
) As Boolean
public:
bool SetEventFields(
    array<Tuple<String^, Type^>^>^ fields
)
member SetEventFields :
        fields : Tuple<string, Type>[] -> bool

Parameters

fields
Type: SystemTuple String, Type
Specifies the event fields as an array of String/Type tuples.

Return Value

Type: Boolean
Returns false if the setup process fails.
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.SetExtension Method

TExternalBaseDllDataSetExtension Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Setting a data extension info. Extension info will be used by specific VisualSignal components and data, such as "BitsPerSample" for audio data, or "XAxisTitle" for channel viewer.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void SetExtension(
    string key,
    Object value
)
Public Sub SetExtension (
    key As String,
    value As Object
)
public:
void SetExtension(
    String^ key,
    Object^ value
)
member SetExtension :
        key : string *
        value : Object -> unit

Parameters

key
Type: SystemString
Specifies the extension key.
value
Type: SystemObject
Specifies the extension value.
See Also

Reference

TExternalBaseDllData Class


DllData Properties

DllData Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllData type exposes the following members.

Properties
 | Name | Description
Public property | ChannelCount | Get/Set the channel count. Setting the property will automatically allocate DataArray, ImagArray, and ChannelNames arrays.
Public property | ChannelNames | Get/Set channel names.
Public property | Coordinates | Get/Set the coordinate values in the form of a object[][] array for "Indexed" coordinate Formats. This property is not used for "Regular" format. The outer level represents multiple dimensions.
Public property | DataArray | Get/Set the real part of the data values in the form of a double[][] array. The outer level represents multiple channels.
Public property | Formats | Get/Set the format of each dimension's coordinate. Currently supported formats are "Regular" and "Indexed". The "Regular" coordinate format requires only Starts and Intervals properties to define the regularly-spaced coordinates; the "Indexed" format requires the Coordinates property to define the array of coordinates.
Public property | ImagArray | Get/Set the imaginary part of the data values in the form of a double[][] array. The outer level represents multiple channels.
Public property | Intervals | Get/Set the interval value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed".
Public property | IsComplex | Get/Set whether data is complex (True/False).
Public property | IsDateTimes | Get/Set whether each dimension's coordinate is encoded DateTime value (True/False).
Public property | Lengths | Get/Set data lengths. For multi-dimensional data, the int[] array represents the length for each dimension. For a vector data, length of int[] array is 1.
Public property | Name | Get/Set the data name
Public property | Rank | Get/Set the data rank. Setting this property will automatically allocate Formats, Intervals, IsDateTimes, Lengths, Starts, Units, and Coordinates arrays.
Public property | Starts | Get/Set the starting value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed". The actual values can be double-precision values, or a System.DateTime objects depending on the IsDateTimes[] status. User must cast to the appropriate type when reading this property.
Public property | Type | Get/Set the data type. Type could be one of the following strings: "Signal", "Spectra", and "Numeric"
Public property | Units | Get/Set the unit string of each dimension's coordinate.
Top
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.ChannelCount Property

TExternalBaseDllDataChannelCount Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the channel count. Setting the property will automatically allocate DataArray, ImagArray, and ChannelNames arrays.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int ChannelCount { get; set; }
Public Property ChannelCount As Integer
    Get
    Set
public:
property int ChannelCount {
    int get ();
    void set (int value);
}
member ChannelCount : int with get, set

Property Value

Type: Int32
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.ChannelNames Property

TExternalBaseDllDataChannelNames Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set channel names.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] ChannelNames { get; set; }
Public Property ChannelNames As String()
    Get
    Set
public:
property array<String^>^ ChannelNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ChannelNames : string[] with get, set

Property Value

Type: String
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Coordinates Property

TExternalBaseDllDataCoordinates Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the coordinate values in the form of a object[][] array for "Indexed" coordinate Formats. This property is not used for "Regular" format. The outer level represents multiple dimensions.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object[][] Coordinates { get; set; }
Public Property Coordinates As Object()()
    Get
    Set
public:
property array<array<Object^>^>^ Coordinates {
    array<array<Object^>^>^ get ();
    void set (array<array<Object^>^>^ value);
}
member Coordinates : Object[][] with get, set

Property Value

Type: Object
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.DataArray Property

TExternalBaseDllDataDataArray Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the real part of the data values in the form of a double[][] array. The outer level represents multiple channels.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public double[][] DataArray { get; set; }
Public Property DataArray As Double()()
    Get
    Set
public:
property array<array<double>^>^ DataArray {
    array<array<double>^>^ get ();
    void set (array<array<double>^>^ value);
}
member DataArray : float[][] with get, set

Property Value

Type: Double
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Formats Property

TExternalBaseDllDataFormats Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the format of each dimension's coordinate. Currently supported formats are "Regular" and "Indexed". The "Regular" coordinate format requires only Starts and Intervals properties to define the regularly-spaced coordinates; the "Indexed" format requires the Coordinates property to define the array of coordinates.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] Formats { get; set; }
Public Property Formats As String()
    Get
    Set
public:
property array<String^>^ Formats {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Formats : string[] with get, set

Property Value

Type: String
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.ImagArray Property

TExternalBaseDllDataImagArray Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the imaginary part of the data values in the form of a double[][] array. The outer level represents multiple channels.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public double[][] ImagArray { get; set; }
Public Property ImagArray As Double()()
    Get
    Set
public:
property array<array<double>^>^ ImagArray {
    array<array<double>^>^ get ();
    void set (array<array<double>^>^ value);
}
member ImagArray : float[][] with get, set

Property Value

Type: Double
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Intervals Property

TExternalBaseDllDataIntervals Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the interval value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed".

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public double[] Intervals { get; set; }
Public Property Intervals As Double()
    Get
    Set
public:
property array<double>^ Intervals {
    array<double>^ get ();
    void set (array<double>^ value);
}
member Intervals : float[] with get, set

Property Value

Type: Double
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.IsComplex Property

TExternalBaseDllDataIsComplex Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set whether data is complex (True/False).

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool IsComplex { get; set; }
Public Property IsComplex As Boolean
    Get
    Set
public:
property bool IsComplex {
    bool get ();
    void set (bool value);
}
member IsComplex : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.IsDateTimes Property

TExternalBaseDllDataIsDateTimes Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set whether each dimension's coordinate is encoded DateTime value (True/False).

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool[] IsDateTimes { get; set; }
Public Property IsDateTimes As Boolean()
    Get
    Set
public:
property array<bool>^ IsDateTimes {
    array<bool>^ get ();
    void set (array<bool>^ value);
}
member IsDateTimes : bool[] with get, set

Property Value

Type: Boolean
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Lengths Property

TExternalBaseDllDataLengths Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set data lengths. For multi-dimensional data, the int[] array represents the length for each dimension. For a vector data, length of int[] array is 1.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int[] Lengths { get; set; }
Public Property Lengths As Integer()
    Get
    Set
public:
property array<int>^ Lengths {
    array<int>^ get ();
    void set (array<int>^ value);
}
member Lengths : int[] with get, set

Property Value

Type: Int32
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Name Property

TExternalBaseDllDataName Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the data name

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Rank Property

TExternalBaseDllDataRank Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the data rank. Setting this property will automatically allocate Formats, Intervals, IsDateTimes, Lengths, Starts, Units, and Coordinates arrays.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rank { get; set; }
Public Property Rank As Integer
    Get
    Set
public:
property int Rank {
    int get ();
    void set (int value);
}
member Rank : int with get, set

Property Value

Type: Int32
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Starts Property

TExternalBaseDllDataStarts Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the starting value of each dimension's coordinate if the coordinate Formats is "Regular". This property is not used if the format is "Indexed". The actual values can be double-precision values, or a System.DateTime objects depending on the IsDateTimes[] status. User must cast to the appropriate type when reading this property.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object[] Starts { get; set; }
Public Property Starts As Object()
    Get
    Set
public:
property array<Object^>^ Starts {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}
member Starts : Object[] with get, set

Property Value

Type: Object
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Type Property

TExternalBaseDllDataType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the data type. Type could be one of the following strings: "Signal", "Spectra", and "Numeric"

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllData.Units Property

TExternalBaseDllDataUnits Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get/Set the unit string of each dimension's coordinate.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string[] Units { get; set; }
Public Property Units As String()
    Get
    Set
public:
property array<String^>^ Units {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Units : string[] with get, set

Property Value

Type: String
See Also

Reference

TExternalBaseDllData Class


TExternalBase.DllInputType Class

TExternalBaseDllInputType Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

DllInputType - This class represents an input type accepted by the user DLL. The user DLL should initialize the number of accepted DllInputType objects and store them in _inputTypes list in Init using AcceptInput() function. This information will be used by Visual Signal to determine whether an input connection to the user's DLL is valid or not.
Inheritance Hierarchy
SystemObject
VSignal.ExternalBaseTExternalBaseDllInputType

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected class DllInputType
Protected Class DllInputType
protected ref class DllInputType
type DllInputType =  class end

The TExternalBaseDllInputType type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBaseDllInputType | DllInputType constructor.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize |
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | InputChannelType | Gets the accepted input channel type.
Public property | InputCoordinateType | Gets the accepted input data coordinate type.
Public property | InputDataType | Gets the accepted input data type.
Public property | InputValueType | Gets the accepted input data value type.
Public property | Rank | Gets the accepted input data rank.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.DllInputType Constructor

TExternalBaseDllInputType Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

DllInputType constructor.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public DllInputType(
    TExternalBaseInputDataTypes dataType,
    int rank,
    TExternalBaseInputCoordinateTypes coordinateType,
    TExternalBaseInputChannelTypes channelType,
    TExternalBaseInputValueTypes dataValueType
)
Public Sub New (
    dataType As TExternalBaseInputDataTypes,
    rank As Integer,
    coordinateType As TExternalBaseInputCoordinateTypes,
    channelType As TExternalBaseInputChannelTypes,
    dataValueType As TExternalBaseInputValueTypes
)
public:
DllInputType(
    TExternalBaseInputDataTypes dataType,
    int rank,
    TExternalBaseInputCoordinateTypes coordinateType,
    TExternalBaseInputChannelTypes channelType,
    TExternalBaseInputValueTypes dataValueType
)
new :
        dataType : TExternalBaseInputDataTypes *
        rank : int *
        coordinateType : TExternalBaseInputCoordinateTypes *
        channelType : TExternalBaseInputChannelTypes *
        dataValueType : TExternalBaseInputValueTypes -> DllInputType

Parameters

dataType
Type: VSignal.ExternalBaseTExternalBaseInputDataTypes
Specifies the accepted input data type.
rank
Type: SystemInt32
Specifies the accepted input data rank. Specifying a 0 means that any data rank is accepted.
coordinateType
Type: VSignal.ExternalBaseTExternalBaseInputCoordinateTypes
Specifies the accepted input coordinate type.
channelType
Type: VSignal.ExternalBaseTExternalBaseInputChannelTypes
Specifies the accepted input channel type.
dataValueType
Type: VSignal.ExternalBaseTExternalBaseInputValueTypes
Specifies the accepted input data value type.
See Also

Reference

TExternalBaseDllInputType Class


DllInputType Methods

DllInputType Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllInputType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | Serialize |
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.Serialize Method

TExternalBaseDllInputTypeSerialize Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for "M:VSignal.ExternalBase.TExternalBase.DllInputType.Serialize(System.Xml.XmlDocument,System.Xml.XmlElement)"]

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void Serialize(
    XmlDocument xdoc,
    XmlElement root
)
Public Sub Serialize (
    xdoc As XmlDocument,
    root As XmlElement
)
public:
void Serialize(
    XmlDocument^ xdoc,
    XmlElement^ root
)
member Serialize :
        xdoc : XmlDocument *
        root : XmlElement -> unit

Parameters

xdoc
Type: System.XmlXmlDocument

[Missing <param name="xdoc"/> documentation for "M:VSignal.ExternalBase.TExternalBase.DllInputType.Serialize(System.Xml.XmlDocument,System.Xml.XmlElement)"]

root
Type: System.XmlXmlElement

[Missing <param name="root"/> documentation for "M:VSignal.ExternalBase.TExternalBase.DllInputType.Serialize(System.Xml.XmlDocument,System.Xml.XmlElement)"]

See Also

Reference

TExternalBaseDllInputType Class


DllInputType Properties

DllInputType Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllInputType type exposes the following members.

Properties
 | Name | Description
Public property | InputChannelType | Gets the accepted input channel type.
Public property | InputCoordinateType | Gets the accepted input data coordinate type.
Public property | InputDataType | Gets the accepted input data type.
Public property | InputValueType | Gets the accepted input data value type.
Public property | Rank | Gets the accepted input data rank.
Top
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.InputChannelType Property

TExternalBaseDllInputTypeInputChannelType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the accepted input channel type.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalBaseInputChannelTypes InputChannelType { get; }
Public ReadOnly Property InputChannelType As TExternalBaseInputChannelTypes
    Get
public:
property TExternalBaseInputChannelTypes InputChannelType {
    TExternalBaseInputChannelTypes get ();
}
member InputChannelType : TExternalBaseInputChannelTypes with get

Property Value

Type: TExternalBaseInputChannelTypes
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.InputCoordinateType Property

TExternalBaseDllInputTypeInputCoordinateType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the accepted input data coordinate type.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalBaseInputCoordinateTypes InputCoordinateType { get; }
Public ReadOnly Property InputCoordinateType As TExternalBaseInputCoordinateTypes
    Get
public:
property TExternalBaseInputCoordinateTypes InputCoordinateType {
    TExternalBaseInputCoordinateTypes get ();
}
member InputCoordinateType : TExternalBaseInputCoordinateTypes with get

Property Value

Type: TExternalBaseInputCoordinateTypes
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.InputDataType Property

TExternalBaseDllInputTypeInputDataType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the accepted input data type.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalBaseInputDataTypes InputDataType { get; }
Public ReadOnly Property InputDataType As TExternalBaseInputDataTypes
    Get
public:
property TExternalBaseInputDataTypes InputDataType {
    TExternalBaseInputDataTypes get ();
}
member InputDataType : TExternalBaseInputDataTypes with get

Property Value

Type: TExternalBaseInputDataTypes
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.InputValueType Property

TExternalBaseDllInputTypeInputValueType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the accepted input data value type.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalBaseInputValueTypes InputValueType { get; }
Public ReadOnly Property InputValueType As TExternalBaseInputValueTypes
    Get
public:
property TExternalBaseInputValueTypes InputValueType {
    TExternalBaseInputValueTypes get ();
}
member InputValueType : TExternalBaseInputValueTypes with get

Property Value

Type: TExternalBaseInputValueTypes
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllInputType.Rank Property

TExternalBaseDllInputTypeRank Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the accepted input data rank.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int Rank { get; }
Public ReadOnly Property Rank As Integer
    Get
public:
property int Rank {
    int get ();
}
member Rank : int with get

Property Value

Type: Int32
See Also

Reference

TExternalBaseDllInputType Class


TExternalBase.DllProperty Class

TExternalBaseDllProperty Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

(Deprecated) DllProperty - This class represents a property used by the user DLL. The user DLL should initialize the number of required DllProperty objects and store them in _properties dictionary in Init using RegisterProperty(). Before DLL's computation stage, Visual Signal's ExternalDll will update the value of the properties via setProperties(String); after DLL's computation, user DLL is responsible for updating the property values via UpdateProperty(String, Object). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable.
Inheritance Hierarchy
SystemObject
VSignal.ExternalBaseTExternalBaseDllProperty

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected class DllProperty
Protected Class DllProperty
protected ref class DllProperty
type DllProperty =  class end

The TExternalBaseDllProperty type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBaseDllProperty | DllProperty constructor.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Category | Gets the property category.
Public property | Description | Gets the property description.
Public property | DisplayName | Gets the property display name.
Public property | Name | Gets the name of the property.
Public property | Order | Gets the property order.
Public property | Tags | Gets the property tags
Public property | Type | Gets the System.Type of the property.
Public property | Value | Gets/Sets the current value of the property.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.DllProperty Constructor

TExternalBaseDllProperty Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

DllProperty constructor.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public DllProperty(
    string name,
    Type type,
    Object defaultValue,
    string category,
    string displayName,
    string description,
    string tags = null,
    int order = -1
)
Public Sub New (
    name As String,
    type As Type,
    defaultValue As Object,
    category As String,
    displayName As String,
    description As String,
    Optional tags As String = Nothing,
    Optional order As Integer = -1
)
public:
DllProperty(
    String^ name,
    Type^ type,
    Object^ defaultValue,
    String^ category,
    String^ displayName,
    String^ description,
    String^ tags = nullptr,
    int order = -1
)
new :
        name : string *
        type : Type *
        defaultValue : Object *
        category : string *
        displayName : string *
        description : string *
        ?tags : string *
        ?order : int
(* Defaults:
        let _tags = defaultArg tags null
        let _order = defaultArg order -1
*)
-> DllProperty

Parameters

name
Type: SystemString
Specifies the name of the property.
type
Type: SystemType
Specifies the System.Type of the property.
defaultValue
Type: SystemObject
Specifies the default value of the property.
category
Type: SystemString
Specifies the category of the property.
displayName
Type: SystemString
Specifies the display name of the property.
description
Type: SystemString
Specifies the description of the property.
tags (Optional)
Type: SystemString
Specifies comma-separated tags for special purposes. Currently supports: 1. "ReadOnly" - specifies that the property is read-only when displayed in Visual Signal. 2. "File:[fileter]" - specifies that the property is a file path, and can invoke the OpenFile dialog in Visual Signal. The filters used in OpenFile dialog can be specified using the standard .Net filter specification in [filter]. For example: "Text files (*.txt)|*.txt|All files (*.*)|*.*", or "Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*"
order (Optional)
Type: SystemInt32
Specifies the order of the property.
See Also

Reference

TExternalBaseDllProperty Class


DllProperty Methods

DllProperty Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetType | (Inherited from Object.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
See Also

Reference

TExternalBaseDllProperty Class


DllProperty Properties

DllProperty Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseDllProperty type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets the property category.
Public property | Description | Gets the property description.
Public property | DisplayName | Gets the property display name.
Public property | Name | Gets the name of the property.
Public property | Order | Gets the property order.
Public property | Tags | Gets the property tags
Public property | Type | Gets the System.Type of the property.
Public property | Value | Gets/Sets the current value of the property.
Top
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Category Property

TExternalBaseDllPropertyCategory Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the property category.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Category { get; }
Public ReadOnly Property Category As String
    Get
public:
property String^ Category {
    String^ get ();
}
member Category : string with get

Property Value

Type: String
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Description Property

TExternalBaseDllPropertyDescription Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the property description.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
public:
property String^ Description {
    String^ get ();
}
member Description : string with get

Property Value

Type: String
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.DisplayName Property

TExternalBaseDllPropertyDisplayName Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the property display name.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
public:
property String^ DisplayName {
    String^ get ();
}
member DisplayName : string with get

Property Value

Type: String
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Name Property

TExternalBaseDllPropertyName Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the name of the property.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Order Property

TExternalBaseDllPropertyOrder Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the property order.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}
member Order : int with get

Property Value

Type: Int32
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Tags Property

TExternalBaseDllPropertyTags Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the property tags

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Tags { get; }
Public ReadOnly Property Tags As String
    Get
public:
property String^ Tags {
    String^ get ();
}
member Tags : string with get

Property Value

Type: String
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Type Property

TExternalBaseDllPropertyType Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets the System.Type of the property.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Type Type { get; }
Public ReadOnly Property Type As Type
    Get
public:
property Type^ Type {
    Type^ get ();
}
member Type : Type with get

Property Value

Type: Type
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.DllProperty.Value Property

TExternalBaseDllPropertyValue Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Gets/Sets the current value of the property.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

TExternalBaseDllProperty Class


TExternalBase.FileAttribute Class

TExternalBaseFileAttribute Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the File attribute to be used when defining a filename-related property, indicating that the property is a file path, and can invoke the OpenFile dialog in Visual Signal. The filters used in OpenFile dialog can be specified using the standard "|"-separated .Net filter specification in [filter]. For example: "Text files (*.txt)|*.txt|All files (*.*)|*.*", or "Image Files(*.BMP;*.JPG;*.GIF)|*.BMP;*.JPG;*.GIF|All files (*.*)|*.*"
Inheritance Hierarchy
SystemObject
SystemAttribute
VSignal.ExternalBaseTExternalBaseFileAttribute

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
[AttributeUsageAttribute(AttributeTargets.Property)]
public class FileAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property)>
Public Class FileAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class FileAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Property)>]
type FileAttribute =
    class
        inherit Attribute
    end

The TExternalBaseFileAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBaseFileAttribute | Define a file attribute.
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Filter | The filter to use in the file dialog.
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.FileAttribute Constructor

TExternalBaseFileAttribute Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Define a file attribute.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public FileAttribute(
    string filter
)
Public Sub New (
    filter As String
)
public:
FileAttribute(
    String^ filter
)
new :
        filter : string -> FileAttribute

Parameters

filter
Type: SystemString
The filter to use in the file dialog associated with the property. The following is an example of a filter string: "Text files (*.txt)|*.txt|All files (*.*)|*.*"
See Also

Reference

TExternalBaseFileAttribute Class


FileAttribute Methods

FileAttribute Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseFileAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

TExternalBaseFileAttribute Class


FileAttribute Properties

FileAttribute Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBaseFileAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Filter | The filter to use in the file dialog.
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

TExternalBaseFileAttribute Class


TExternalBase.FileAttribute.Filter Property

TExternalBaseFileAttributeFilter Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The filter to use in the file dialog.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Filter { get; }
Public ReadOnly Property Filter As String
    Get
public:
property String^ Filter {
    String^ get ();
}
member Filter : string with get

Property Value

Type: String
Remarks
The following is an example of a filter string: "Text files (*.txt)|*.txt|All files (*.*)|*.*"
See Also

Reference

TExternalBaseFileAttribute Class


TExternalBase.InputChannelTypes Enumeration

TExternalBaseInputChannelTypes Enumeration Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the InputChanneltypes enumeration for all possible channel types

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public enum InputChannelTypes
Public Enumeration InputChannelTypes
public enum class InputChannelTypes
type InputChannelTypes
Members
Member name | Value | Description
Any | 0 | Accepts any channel types
Single | 1 | Accepts only single-channel data
Multiple | 2 | Accepts only multi-channel data
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.InputCoordinateTypes Enumeration

TExternalBaseInputCoordinateTypes Enumeration Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the InputCoordinateTypes enumeration for all possible coordinate types.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public enum InputCoordinateTypes
Public Enumeration InputCoordinateTypes
public enum class InputCoordinateTypes
type InputCoordinateTypes
Members
Member name | Value | Description
Any | 0 | Accepts any coordinate type
Regular | 1 | Accepts coordinate at regular interval
Indexed | 2 | Accepts coordinate indexed, sorted in increasing order.
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.InputDataTypes Enumeration

TExternalBaseInputDataTypes Enumeration Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the InputDataTypes enumeration for all possible acceptable data types.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public enum InputDataTypes
Public Enumeration InputDataTypes
public enum class InputDataTypes
type InputDataTypes
Members
Member name | Value | Description
Any | 0 | Accepts any data type
Numeric | 1 | Accepts pure numeric data (single value, vector, matrix, etc)
Signal | 2 | Accepts 1D time-domain signal with units (multi-channel)
Audio | 3 | Accepts 1D time-domain signal, no units, playable as WAV (multi-channel)
Image | 4 | Accepts 2D raw image data, no units, but viewable as image (multi-channel)
Spectra | 5 | Accepts 2D time-frequency spectra with units (single channel only)
Remarks
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.InputValueTypes Enumeration

TExternalBaseInputValueTypes Enumeration Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the InputValueTypes enumeration for all possible data value types

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public enum InputValueTypes
Public Enumeration InputValueTypes
public enum class InputValueTypes
type InputValueTypes
Members
Member name | Value | Description
Any | 0 | Accepts any data value types
Real | 1 | Accepts only real values
Complex | 2 | Accepts only complex values
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.PropertyOrderAttribute Class

TExternalBasePropertyOrderAttribute Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This is the PropertyOrder attribute to be used when defining a property, indicating the order in which the property is to be displayed in the VisualSignal property window.
Inheritance Hierarchy
SystemObject
SystemAttribute
VSignal.ExternalBaseTExternalBasePropertyOrderAttribute

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
[AttributeUsageAttribute(AttributeTargets.Property)]
public class PropertyOrderAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property)>
Public Class PropertyOrderAttribute
    Inherits Attribute
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class PropertyOrderAttribute : public Attribute
[<AttributeUsageAttribute(AttributeTargets.Property)>]
type PropertyOrderAttribute =
    class
        inherit Attribute
    end

The TExternalBasePropertyOrderAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalBasePropertyOrderAttribute | Define the property order
Top
Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Order | The property order
Public property | TypeId | (Inherited from Attribute.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalBase.PropertyOrderAttribute Constructor

TExternalBasePropertyOrderAttribute Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Define the property order

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public PropertyOrderAttribute(
    int order
)
Public Sub New (
    order As Integer
)
public:
PropertyOrderAttribute(
    int order
)
new :
        order : int -> PropertyOrderAttribute

Parameters

order
Type: SystemInt32
The property order associated with the property.
See Also

Reference

TExternalBasePropertyOrderAttribute Class


PropertyOrderAttribute Methods

PropertyOrderAttribute Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBasePropertyOrderAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Inherited from Attribute.)
Protected method | Finalize | (Inherited from Object.)
Public method | GetHashCode | (Inherited from Attribute.)
Public method | GetType | (Inherited from Object.)
Public method | IsDefaultAttribute | (Inherited from Attribute.)
Public method | Match | (Inherited from Attribute.)
Protected method | MemberwiseClone | (Inherited from Object.)
Public method | ToString | (Inherited from Object.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | _AttributeGetIDsOfNames | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfo | (Inherited from Attribute.)
Explicit interface implementation | _AttributeGetTypeInfoCount | (Inherited from Attribute.)
Explicit interface implementation | _AttributeInvoke | (Inherited from Attribute.)
Top
See Also

Reference

TExternalBasePropertyOrderAttribute Class


PropertyOrderAttribute Properties

PropertyOrderAttribute Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalBasePropertyOrderAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Order | The property order
Public property | TypeId | (Inherited from Attribute.)
Top
See Also

Reference

TExternalBasePropertyOrderAttribute Class


TExternalBase.PropertyOrderAttribute.Order Property

TExternalBasePropertyOrderAttributeOrder Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The property order

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public int Order { get; }
Public ReadOnly Property Order As Integer
    Get
public:
property int Order {
    int get ();
}
member Order : int with get

Property Value

Type: Int32
See Also

Reference

TExternalBasePropertyOrderAttribute Class


TExternalForm Class

TExternalForm Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

TExternalFormBase - Base class implementing the [!:IExternalForm] interface. Any C# external user dialog DLL must inherit this class and override implementation for [!:Init] and [!:DoCompute].
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
VSignal.ExternalBaseTExternalForm

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public class TExternalForm : Form
Public Class TExternalForm
    Inherits Form
public ref class TExternalForm : public Form
type TExternalForm =
    class
        inherit Form
    end

The TExternalForm type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalForm | Initializes a new instance of the TExternalForm class
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | Associate | AssociateProperty - associate a control's property with a Visual Signal component property
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Form.)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, Object) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Properties
 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UpdatedProperties | UpdatedProperties - gets the XmlDocument containing updated values of associated properties. This property is used by Visual Signal only.
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | VSPath | VSPath - for specifying the Visual Signal installation path. This property is used by Visual Signal only.
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | UpdateVS | UpdateVS - for specifying the Visual Signal function to execute when associated actions are triggered. This property is used by Visual Signal only.
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IContainerControlActivateControl | (Inherited from ContainerControl.)
Explicit interface implementation | IDropTargetOnDragDrop | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragEnter | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragLeave | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragOver | (Inherited from Control.)
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalForm Constructor

TExternalForm Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TExternalForm class

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalForm()
Public Sub New
public:
TExternalForm()
new : unit -> TExternalForm
See Also

Reference

TExternalForm Class


TExternalForm Methods

TExternalForm Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalForm type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | (Inherited from Control.)
Public method | Activate | (Inherited from Form.)
Protected method | ActivateMdiChild | (Inherited from Form.)
Public method | AddOwnedForm | (Inherited from Form.)
Protected method | AdjustFormScrollbars | (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. (Inherited from Form.)
Public method | Associate | AssociateProperty - associate a control's property with a Visual Signal component property
Public method | BeginInvoke(Delegate) | (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | (Inherited from Control.)
Public method | BringToFront | (Inherited from Control.)
Protected method | CenterToParent | (Inherited from Form.)
Protected method | CenterToScreen | (Inherited from Form.)
Public method | Close | (Inherited from Form.)
Public method | Contains | (Inherited from Control.)
Protected method | CreateAccessibilityInstance | (Inherited from Control.)
Public method | CreateControl | (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | (Inherited from Control.)
Protected method | CreateHandle | (Inherited from Form.)
Public method | CreateObjRef | (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | (Inherited from Control.)
Public method | Dispose | (Inherited from Component.)
Protected method | Dispose(Boolean) | (Inherited from Form.)
Public method | DoDragDrop | (Inherited from Control.)
Public method | DrawToBitmap | (Inherited from Control.)
Public method | EndInvoke | (Inherited from Control.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Component.)
Public method | FindForm | (Inherited from Control.)
Public method | Focus | (Inherited from Control.)
Protected method | GetAccessibilityObjectById | (Inherited from Control.)
Protected method | GetAutoSizeMode | (Inherited from Control.)
Public method | GetChildAtPoint(Point) | (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | (Inherited from Control.)
Public method | GetContainerControl | (Inherited from Control.)
Public method | GetHashCode | (Inherited from Object.)
Public method | GetLifetimeService | (Inherited from MarshalByRefObject.)
Public method | GetNextControl | (Inherited from Control.)
Public method | GetPreferredSize | (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | (Inherited from ScrollableControl.)
Protected method | GetService | (Inherited from Component.)
Protected method | GetStyle | (Inherited from Control.)
Protected method | GetTopLevel | (Inherited from Control.)
Public method | GetType | (Inherited from Object.)
Public method | Hide | (Inherited from Control.)
Public method | InitializeLifetimeService | (Inherited from MarshalByRefObject.)
Protected method | InitLayout | (Inherited from Control.)
Public method | Invalidate | (Inherited from Control.)
Public method | Invalidate(Region) | (Inherited from Control.)
Public method | Invalidate(Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle) | (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | (Inherited from Control.)
Public method | Invoke(Delegate) | (Inherited from Control.)
Public method | Invoke(Delegate, Object) | (Inherited from Control.)
Protected method | InvokeGotFocus | (Inherited from Control.)
Protected method | InvokeLostFocus | (Inherited from Control.)
Protected method | InvokeOnClick | (Inherited from Control.)
Protected method | InvokePaint | (Inherited from Control.)
Protected method | InvokePaintBackground | (Inherited from Control.)
Protected method | IsInputChar | (Inherited from Control.)
Protected method | IsInputKey | (Inherited from Control.)
Public method | LayoutMdi | (Inherited from Form.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | (Inherited from Control.)
Protected method | OnActivated | (Inherited from Form.)
Protected method | OnAutoSizeChanged | (Inherited from Control.)
Protected method | OnAutoValidateChanged | (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | (Inherited from Control.)
Protected method | OnBackgroundImageChanged | (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | (Inherited from Form.)
Protected method | OnBindingContextChanged | (Inherited from Control.)
Protected method | OnCausesValidationChanged | (Inherited from Control.)
Protected method | OnChangeUICues | (Inherited from Control.)
Protected method | OnClick | (Inherited from Control.)
Protected method | OnClientSizeChanged | (Inherited from Control.)
Protected method | OnClosed | (Inherited from Form.)
Protected method | OnClosing | (Inherited from Form.)
Protected method | OnContextMenuChanged | (Inherited from Control.)
Protected method | OnContextMenuStripChanged | (Inherited from Control.)
Protected method | OnControlAdded | (Inherited from Control.)
Protected method | OnControlRemoved | (Inherited from Control.)
Protected method | OnCreateControl | (Inherited from Form.)
Protected method | OnCursorChanged | (Inherited from Control.)
Protected method | OnDeactivate | (Inherited from Form.)
Protected method | OnDockChanged | (Inherited from Control.)
Protected method | OnDoubleClick | (Inherited from Control.)
Protected method | OnDragDrop | (Inherited from Control.)
Protected method | OnDragEnter | (Inherited from Control.)
Protected method | OnDragLeave | (Inherited from Control.)
Protected method | OnDragOver | (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | (Inherited from Control.)
Protected method | OnFormClosed | (Inherited from Form.)
Protected method | OnFormClosing | (Inherited from Form.)
Protected method | OnGiveFeedback | (Inherited from Control.)
Protected method | OnGotFocus | (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | (Inherited from Form.)
Protected method | OnHelpRequested | (Inherited from Control.)
Protected method | OnImeModeChanged | (Inherited from Control.)
Protected method | OnInputLanguageChanged | (Inherited from Form.)
Protected method | OnInputLanguageChanging | (Inherited from Form.)
Protected method | OnInvalidated | (Inherited from Control.)
Protected method | OnKeyDown | (Inherited from Control.)
Protected method | OnKeyPress | (Inherited from Control.)
Protected method | OnKeyUp | (Inherited from Control.)
Protected method | OnLayout | (Inherited from Form.)
Protected method | OnLeave | (Inherited from Control.)
Protected method | OnLoad | (Inherited from Form.)
Protected method | OnLocationChanged | (Inherited from Control.)
Protected method | OnLostFocus | (Inherited from Control.)
Protected method | OnMarginChanged | (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | (Inherited from Form.)
Protected method | OnMaximumSizeChanged | (Inherited from Form.)
Protected method | OnMdiChildActivate | (Inherited from Form.)
Protected method | OnMenuComplete | (Inherited from Form.)
Protected method | OnMenuStart | (Inherited from Form.)
Protected method | OnMinimumSizeChanged | (Inherited from Form.)
Protected method | OnMouseCaptureChanged | (Inherited from Control.)
Protected method | OnMouseClick | (Inherited from Control.)
Protected method | OnMouseDoubleClick | (Inherited from Control.)
Protected method | OnMouseDown | (Inherited from Control.)
Protected method | OnMouseEnter | (Inherited from Control.)
Protected method | OnMouseHover | (Inherited from Control.)
Protected method | OnMouseLeave | (Inherited from Control.)
Protected method | OnMouseMove | (Inherited from Control.)
Protected method | OnMouseUp | (Inherited from Control.)
Protected method | OnMouseWheel | (Inherited from ScrollableControl.)
Protected method | OnMove | (Inherited from Control.)
Protected method | OnNotifyMessage | (Inherited from Control.)
Protected method | OnPaddingChanged | (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | (Inherited from Control.)
Protected method | OnParentBindingContextChanged | (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | (Inherited from Control.)
Protected method | OnParentEnabledChanged | (Inherited from Control.)
Protected method | OnParentFontChanged | (Inherited from Control.)
Protected method | OnParentForeColorChanged | (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | (Inherited from Control.)
Protected method | OnParentVisibleChanged | (Inherited from Control.)
Protected method | OnPreviewKeyDown | (Inherited from Control.)
Protected method | OnPrint | (Inherited from Control.)
Protected method | OnQueryContinueDrag | (Inherited from Control.)
Protected method | OnRegionChanged | (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | (Inherited from Form.)
Protected method | OnResizeEnd | (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | (Inherited from Form.)
Protected method | OnScroll | (Inherited from ScrollableControl.)
Protected method | OnShown | (Inherited from Form.)
Protected method | OnSizeChanged | (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | (Inherited from Control.)
Protected method | OnTabIndexChanged | (Inherited from Control.)
Protected method | OnTabStopChanged | (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | (Inherited from Control.)
Protected method | OnValidating | (Inherited from Control.)
Protected method | OnVisibleChanged | (Inherited from Form.)
Public method | PerformAutoScale | (Inherited from ContainerControl.)
Public method | PerformLayout | (Inherited from Control.)
Public method | PerformLayout(Control, String) | (Inherited from Control.)
Public method | PointToClient | (Inherited from Control.)
Public method | PointToScreen | (Inherited from Control.)
Public method | PreProcessControlMessage | (Inherited from Control.)
Public method | PreProcessMessage | (Inherited from Control.)
Protected method | ProcessCmdKey | (Inherited from Form.)
Protected method | ProcessDialogChar | (Inherited from Form.)
Protected method | ProcessDialogKey | (Inherited from Form.)
Protected method | ProcessKeyEventArgs | (Inherited from Control.)
Protected method | ProcessKeyMessage | (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | (Inherited from Control.)
Protected method | RaiseKeyEvent | (Inherited from Control.)
Protected method | RaiseMouseEvent | (Inherited from Control.)
Protected method | RaisePaintEvent | (Inherited from Control.)
Protected method | RecreateHandle | (Inherited from Control.)
Public method | RectangleToClient | (Inherited from Control.)
Public method | RectangleToScreen | (Inherited from Control.)
Public method | Refresh | (Inherited from Control.)
Public method | RemoveOwnedForm | (Inherited from Form.)
Public method | ResetBackColor | (Inherited from Control.)
Public method | ResetBindings | (Inherited from Control.)
Public method | ResetCursor | (Inherited from Control.)
Public method | ResetFont | (Inherited from Control.)
Public method | ResetForeColor | (Inherited from Control.)
Public method | ResetImeMode | (Inherited from Control.)
Protected method | ResetMouseEventArgs | (Inherited from Control.)
Public method | ResetRightToLeft | (Inherited from Control.)
Public method | ResetText | (Inherited from Control.)
Public method | ResumeLayout | (Inherited from Control.)
Public method | ResumeLayout(Boolean) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | (Inherited from Control.)
Protected method | RtlTranslateContent | (Inherited from Control.)
Protected method | RtlTranslateHorizontal | (Inherited from Control.)
Protected method | RtlTranslateLeftRight | (Inherited from Control.)
Public method | Scale(Single) | Obsolete. (Inherited from Control.)
Public method | Scale(SizeF) | (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. (Inherited from Control.)
Protected method | ScaleControl | (Inherited from Form.)
Protected method | ScaleCore | (Inherited from Form.)
Public method | ScrollControlIntoView | (Inherited from ScrollableControl.)
Protected method | ScrollToControl | (Inherited from ScrollableControl.)
Public method | Select | (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | (Inherited from Form.)
Public method | SelectNextControl | (Inherited from Control.)
Public method | SendToBack | (Inherited from Control.)
Public method | SetAutoScrollMargin | (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | (Inherited from Form.)
Public method | SetDesktopBounds | (Inherited from Form.)
Public method | SetDesktopLocation | (Inherited from Form.)
Protected method | SetDisplayRectLocation | (Inherited from ScrollableControl.)
Protected method | SetScrollState | (Inherited from ScrollableControl.)
Protected method | SetStyle | (Inherited from Control.)
Protected method | SetTopLevel | (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | (Inherited from Control.)
Public method | Show(IWin32Window) | (Inherited from Form.)
Public method | ShowDialog | (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | (Inherited from Form.)
Protected method | SizeFromClientSize | (Inherited from Control.)
Public method | SuspendLayout | (Inherited from Control.)
Public method | ToString | (Inherited from Form.)
Public method | Update | (Inherited from Control.)
Protected method | UpdateBounds | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | (Inherited from Control.)
Protected method | UpdateDefaultButton | (Inherited from Form.)
Protected method | UpdateStyles | (Inherited from Control.)
Protected method | UpdateZOrder | (Inherited from Control.)
Public method | Validate | (Inherited from ContainerControl.)
Public method | Validate(Boolean) | (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Explicit Interface Implementations
 | Name | Description
Explicit interface implementation | IContainerControlActivateControl | (Inherited from ContainerControl.)
Explicit interface implementation | IDropTargetOnDragDrop | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragEnter | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragLeave | (Inherited from Control.)
Explicit interface implementation | IDropTargetOnDragOver | (Inherited from Control.)
Top
See Also

Reference

TExternalForm Class


TExternalForm.Associate Method

TExternalFormAssociate Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

AssociateProperty - associate a control's property with a Visual Signal component property

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void Associate(
    AssociationTypes type,
    Control control,
    string source,
    string target
)
Public Sub Associate (
    type As AssociationTypes,
    control As Control,
    source As String,
    target As String
)
public:
void Associate(
    AssociationTypes type,
    Control^ control,
    String^ source,
    String^ target
)
member Associate :
        type : AssociationTypes *
        control : Control *
        source : string *
        target : string -> unit

Parameters

type
Type: VSignal.ExternalBaseAssociationTypes
Association type: either Action or Property
control
Type: System.Windows.FormsControl
Form control to be associated
source
Type: SystemString
Name of the form control's property or event to be associated from
target
Type: SystemString
Target to be associated to. This must be a command string understood by Visual Signal. For Action type, the target should be an action name supported by Visual Signal; for Property type, the target should be formated as "[component].[property]", where component is the component class and property is the component's property name to be associated.
See Also

Reference

TExternalForm Class


TExternalForm Properties

TExternalForm Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalForm type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | (Inherited from Form.)
Public property | AccessibilityObject | (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | (Inherited from Control.)
Public property | AccessibleDescription | (Inherited from Control.)
Public property | AccessibleName | (Inherited from Control.)
Public property | AccessibleRole | (Inherited from Control.)
Public property | ActiveControl | (Inherited from ContainerControl.)
Public property | ActiveMdiChild | (Inherited from Form.)
Public property | AllowDrop | (Inherited from Control.)
Public property | AllowTransparency | (Inherited from Form.)
Public property | Anchor | (Inherited from Control.)
Public property | AutoScale | Obsolete. (Inherited from Form.)
Public property | AutoScaleBaseSize | (Inherited from Form.)
Public property | AutoScaleDimensions | (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | (Inherited from ContainerControl.)
Public property | AutoScaleMode | (Inherited from ContainerControl.)
Public property | AutoScroll | (Inherited from Form.)
Public property | AutoScrollMargin | (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | (Inherited from Control.)
Public property | AutoScrollPosition | (Inherited from ScrollableControl.)
Public property | AutoSize | (Inherited from Form.)
Public property | AutoSizeMode | (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | (Inherited from Control.)
Public property | BackgroundImageLayout | (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | (Inherited from Control.)
Public property | Bounds | (Inherited from Control.)
Public property | CancelButton | (Inherited from Form.)
Protected property | CanEnableIme | (Inherited from ContainerControl.)
Public property | CanFocus | (Inherited from Control.)
Protected property | CanRaiseEvents | (Inherited from Control.)
Public property | CanSelect | (Inherited from Control.)
Public property | Capture | (Inherited from Control.)
Public property | CausesValidation | (Inherited from Control.)
Public property | ClientRectangle | (Inherited from Control.)
Public property | ClientSize | (Inherited from Form.)
Public property | CompanyName | (Inherited from Control.)
Public property | Container | (Inherited from Component.)
Public property | ContainsFocus | (Inherited from Control.)
Public property | ContextMenu | (Inherited from Control.)
Public property | ContextMenuStrip | (Inherited from Control.)
Public property | ControlBox | (Inherited from Form.)
Public property | Controls | (Inherited from Control.)
Public property | Created | (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | (Inherited from ContainerControl.)
Public property | Cursor | (Inherited from Control.)
Public property | DataBindings | (Inherited from Control.)
Protected property | DefaultCursor | (Inherited from Control.)
Protected property | DefaultImeMode | (Inherited from Form.)
Protected property | DefaultMargin | (Inherited from Control.)
Protected property | DefaultMaximumSize | (Inherited from Control.)
Protected property | DefaultMinimumSize | (Inherited from Control.)
Protected property | DefaultPadding | (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | (Inherited from Component.)
Public property | DesktopBounds | (Inherited from Form.)
Public property | DesktopLocation | (Inherited from Form.)
Public property | DialogResult | (Inherited from Form.)
Public property | DisplayRectangle | (Inherited from ScrollableControl.)
Public property | Disposing | (Inherited from Control.)
Public property | Dock | (Inherited from Control.)
Public property | DockPadding | (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | (Inherited from Control.)
Public property | Enabled | (Inherited from Control.)
Protected property | Events | (Inherited from Component.)
Public property | Focused | (Inherited from Control.)
Public property | Font | (Inherited from Control.)
Protected property | FontHeight | (Inherited from Control.)
Public property | ForeColor | (Inherited from Control.)
Public property | FormBorderStyle | (Inherited from Form.)
Public property | Handle | (Inherited from Control.)
Public property | HasChildren | (Inherited from Control.)
Public property | Height | (Inherited from Control.)
Public property | HelpButton | (Inherited from Form.)
Public property | HorizontalScroll | (Inherited from ScrollableControl.)
Protected property | HScroll | (Inherited from ScrollableControl.)
Public property | Icon | (Inherited from Form.)
Public property | ImeMode | (Inherited from Control.)
Protected property | ImeModeBase | (Inherited from Control.)
Public property | InvokeRequired | (Inherited from Control.)
Public property | IsAccessible | (Inherited from Control.)
Public property | IsDisposed | (Inherited from Control.)
Public property | IsHandleCreated | (Inherited from Control.)
Public property | IsMdiChild | (Inherited from Form.)
Public property | IsMdiContainer | (Inherited from Form.)
Public property | IsMirrored | (Inherited from Control.)
Public property | IsRestrictedWindow | (Inherited from Form.)
Public property | KeyPreview | (Inherited from Form.)
Public property | LayoutEngine | (Inherited from Control.)
Public property | Left | (Inherited from Control.)
Public property | Location | (Inherited from Form.)
Public property | MainMenuStrip | (Inherited from Form.)
Public property | Margin | (Inherited from Form.)
Public property | MaximizeBox | (Inherited from Form.)
Protected property | MaximizedBounds | (Inherited from Form.)
Public property | MaximumSize | (Inherited from Form.)
Public property | MdiChildren | (Inherited from Form.)
Public property | MdiParent | (Inherited from Form.)
Public property | Menu | (Inherited from Form.)
Public property | MergedMenu | (Inherited from Form.)
Public property | MinimizeBox | (Inherited from Form.)
Public property | MinimumSize | (Inherited from Form.)
Public property | Modal | (Inherited from Form.)
Public property | Name | (Inherited from Control.)
Public property | Opacity | (Inherited from Form.)
Public property | OwnedForms | (Inherited from Form.)
Public property | Owner | (Inherited from Form.)
Public property | Padding | (Inherited from Control.)
Public property | Parent | (Inherited from Control.)
Public property | ParentForm | (Inherited from ContainerControl.)
Public property | PreferredSize | (Inherited from Control.)
Public property | ProductName | (Inherited from Control.)
Public property | ProductVersion | (Inherited from Control.)
Public property | RecreatingHandle | (Inherited from Control.)
Public property | Region | (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | (Inherited from Control.)
Public property | RestoreBounds | (Inherited from Form.)
Public property | Right | (Inherited from Control.)
Public property | RightToLeft | (Inherited from Control.)
Public property | RightToLeftLayout | (Inherited from Form.)
Protected property | ScaleChildren | (Inherited from Control.)
Protected property | ShowFocusCues | (Inherited from Control.)
Public property | ShowIcon | (Inherited from Form.)
Public property | ShowInTaskbar | (Inherited from Form.)
Protected property | ShowKeyboardCues | (Inherited from Control.)
Protected property | ShowWithoutActivation | (Inherited from Form.)
Public property | Site | (Inherited from Control.)
Public property | Size | (Inherited from Form.)
Public property | SizeGripStyle | (Inherited from Form.)
Public property | StartPosition | (Inherited from Form.)
Public property | TabIndex | (Inherited from Form.)
Public property | TabStop | (Inherited from Form.)
Public property | Tag | (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | (Inherited from Control.)
Public property | TopLevel | (Inherited from Form.)
Public property | TopLevelControl | (Inherited from Control.)
Public property | TopMost | (Inherited from Form.)
Public property | TransparencyKey | (Inherited from Form.)
Public property | UpdatedProperties | UpdatedProperties - gets the XmlDocument containing updated values of associated properties. This property is used by Visual Signal only.
Public property | UseWaitCursor | (Inherited from Control.)
Public property | VerticalScroll | (Inherited from ScrollableControl.)
Public property | Visible | (Inherited from Control.)
Protected property | VScroll | (Inherited from ScrollableControl.)
Public property | VSPath | VSPath - for specifying the Visual Signal installation path. This property is used by Visual Signal only.
Public property | Width | (Inherited from Control.)
Public property | WindowState | (Inherited from Form.)
Public property | WindowTarget | (Inherited from Control.)
Top
See Also

Reference

TExternalForm Class


TExternalForm.UpdatedProperties Property

TExternalFormUpdatedProperties Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

UpdatedProperties - gets the XmlDocument containing updated values of associated properties. This property is used by Visual Signal only.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public XmlDocument UpdatedProperties { get; }
Public ReadOnly Property UpdatedProperties As XmlDocument
    Get
public:
property XmlDocument^ UpdatedProperties {
    XmlDocument^ get ();
}
member UpdatedProperties : XmlDocument with get

Property Value

Type: XmlDocument
See Also

Reference

TExternalForm Class


TExternalForm.VSPath Property

TExternalFormVSPath Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

VSPath - for specifying the Visual Signal installation path. This property is used by Visual Signal only.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string VSPath { get; set; }
Public Property VSPath As String
    Get
    Set
public:
property String^ VSPath {
    String^ get ();
    void set (String^ value);
}
member VSPath : string with get, set

Property Value

Type: String
See Also

Reference

TExternalForm Class


TExternalForm Events

TExternalForm Events Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalForm type exposes the following members.

Events
 | Name | Description
Public event | Activated | (Inherited from Form.)
Public event | AutoSizeChanged | (Inherited from Form.)
Public event | AutoValidateChanged | (Inherited from Form.)
Public event | BackColorChanged | (Inherited from Control.)
Public event | BackgroundImageChanged | (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | (Inherited from Control.)
Public event | BindingContextChanged | (Inherited from Control.)
Public event | CausesValidationChanged | (Inherited from Control.)
Public event | ChangeUICues | (Inherited from Control.)
Public event | Click | (Inherited from Control.)
Public event | ClientSizeChanged | (Inherited from Control.)
Public event | Closed | (Inherited from Form.)
Public event | Closing | (Inherited from Form.)
Public event | ContextMenuChanged | (Inherited from Control.)
Public event | ContextMenuStripChanged | (Inherited from Control.)
Public event | ControlAdded | (Inherited from Control.)
Public event | ControlRemoved | (Inherited from Control.)
Public event | CursorChanged | (Inherited from Control.)
Public event | Deactivate | (Inherited from Form.)
Public event | Disposed | (Inherited from Component.)
Public event | DockChanged | (Inherited from Control.)
Public event | DoubleClick | (Inherited from Control.)
Public event | DragDrop | (Inherited from Control.)
Public event | DragEnter | (Inherited from Control.)
Public event | DragLeave | (Inherited from Control.)
Public event | DragOver | (Inherited from Control.)
Public event | EnabledChanged | (Inherited from Control.)
Public event | Enter | (Inherited from Control.)
Public event | FontChanged | (Inherited from Control.)
Public event | ForeColorChanged | (Inherited from Control.)
Public event | FormClosed | (Inherited from Form.)
Public event | FormClosing | (Inherited from Form.)
Public event | GiveFeedback | (Inherited from Control.)
Public event | GotFocus | (Inherited from Control.)
Public event | HandleCreated | (Inherited from Control.)
Public event | HandleDestroyed | (Inherited from Control.)
Public event | HelpButtonClicked | (Inherited from Form.)
Public event | HelpRequested | (Inherited from Control.)
Public event | ImeModeChanged | (Inherited from Control.)
Public event | InputLanguageChanged | (Inherited from Form.)
Public event | InputLanguageChanging | (Inherited from Form.)
Public event | Invalidated | (Inherited from Control.)
Public event | KeyDown | (Inherited from Control.)
Public event | KeyPress | (Inherited from Control.)
Public event | KeyUp | (Inherited from Control.)
Public event | Layout | (Inherited from Control.)
Public event | Leave | (Inherited from Control.)
Public event | Load | (Inherited from Form.)
Public event | LocationChanged | (Inherited from Control.)
Public event | LostFocus | (Inherited from Control.)
Public event | MarginChanged | (Inherited from Form.)
Public event | MaximizedBoundsChanged | (Inherited from Form.)
Public event | MaximumSizeChanged | (Inherited from Form.)
Public event | MdiChildActivate | (Inherited from Form.)
Public event | MenuComplete | (Inherited from Form.)
Public event | MenuStart | (Inherited from Form.)
Public event | MinimumSizeChanged | (Inherited from Form.)
Public event | MouseCaptureChanged | (Inherited from Control.)
Public event | MouseClick | (Inherited from Control.)
Public event | MouseDoubleClick | (Inherited from Control.)
Public event | MouseDown | (Inherited from Control.)
Public event | MouseEnter | (Inherited from Control.)
Public event | MouseHover | (Inherited from Control.)
Public event | MouseLeave | (Inherited from Control.)
Public event | MouseMove | (Inherited from Control.)
Public event | MouseUp | (Inherited from Control.)
Public event | MouseWheel | (Inherited from Control.)
Public event | Move | (Inherited from Control.)
Public event | PaddingChanged | (Inherited from Control.)
Public event | Paint | (Inherited from Control.)
Public event | ParentChanged | (Inherited from Control.)
Public event | PreviewKeyDown | (Inherited from Control.)
Public event | QueryAccessibilityHelp | (Inherited from Control.)
Public event | QueryContinueDrag | (Inherited from Control.)
Public event | RegionChanged | (Inherited from Control.)
Public event | Resize | (Inherited from Control.)
Public event | ResizeBegin | (Inherited from Form.)
Public event | ResizeEnd | (Inherited from Form.)
Public event | RightToLeftChanged | (Inherited from Control.)
Public event | RightToLeftLayoutChanged | (Inherited from Form.)
Public event | Scroll | (Inherited from ScrollableControl.)
Public event | Shown | (Inherited from Form.)
Public event | SizeChanged | (Inherited from Control.)
Public event | StyleChanged | (Inherited from Control.)
Public event | SystemColorsChanged | (Inherited from Control.)
Public event | TabIndexChanged | (Inherited from Form.)
Public event | TabStopChanged | (Inherited from Form.)
Public event | TextChanged | (Inherited from Control.)
Public event | UpdateVS | UpdateVS - for specifying the Visual Signal function to execute when associated actions are triggered. This property is used by Visual Signal only.
Public event | Validated | (Inherited from Control.)
Public event | Validating | (Inherited from Control.)
Public event | VisibleChanged | (Inherited from Control.)
Top
See Also

Reference

TExternalForm Class


TExternalForm.UpdateVS Event

TExternalFormUpdateVS Event Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

UpdateVS - for specifying the Visual Signal function to execute when associated actions are triggered. This property is used by Visual Signal only.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public event Action<XmlDocument> UpdateVS
Public Event UpdateVS As Action(Of XmlDocument)
public:
 event Action<XmlDocument^>^ UpdateVS {
    void add (Action<XmlDocument^>^ value);
    void remove (Action<XmlDocument^>^ value);
}
member UpdateVS : IEvent<Action<XmlDocument>,
    EventArgs>

Value

Type: SystemAction XmlDocument
See Also

Reference

TExternalForm Class


TExternalViewer Class

TExternalViewer Class Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

ExternalViewer - Base viewer class inherited from TExternalBase, and also implementing the IExternalViewer interface . Any C# external user viewer DLL must inherit this class and override implementation for Init and DoCompute, and optionally UpdateViewerProperty.
Inheritance Hierarchy
SystemObject
VSignal.ExternalBaseTExternalBase
VSignal.ExternalBaseTExternalViewer

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public class TExternalViewer : TExternalBase,
    IExternalViewer, IExternalDll
Public Class TExternalViewer
    Inherits TExternalBase
    Implements IExternalViewer, IExternalDll
public ref class TExternalViewer : public TExternalBase,
    IExternalViewer, IExternalDll
type TExternalViewer =
    class
        inherit TExternalBase
        interface IExternalViewer
        interface IExternalDll
    end

The TExternalViewer type exposes the following members.

Constructors
 | Name | Description
Public method | TExternalViewer | Initializes a new instance of the TExternalViewer class
Top
Methods
 | Name | Description
Protected method | AcceptInput(TExternalBaseInputDataTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not. (Inherited from TExternalBase.)
Protected method | AcceptInput(TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not. (Inherited from TExternalBase.)
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. This function just calls the protected function DoCompute, which the user DLL must override with own implementation. External properties, input and output data are processed by Visual Signal before and after the execution of this function. User should expect _inputData to contain the input data and update _outputData to sent to Visual Signal. User should also expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal. (Inherited from TExternalBase.)
Protected method | DoCompute | Protected virtual function "DoCompute", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function compute which is in turn used by Visual Signal's ExternalDll module to start computation. (Inherited from TExternalBase.)
Public method | doubleClick | Interface for exported function "doubleClick", used by Visual Signal's ExternalDll module to handle the callback when user double-clicks the corresponding Visual Signal component. This function just calls the protected function OnDoubleClick, which the user DLL can override with own implementation. Like compute, external properties are processed by Visual Signal before and after the execution of this function; however, input and output data are not processed. User should expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal. (Inherited from TExternalBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getDllInfo | Exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, license control and properties. (Inherited from TExternalBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetInputCoords | Protected function "GetInputCoords", provided to the user DLL to obtain the input coordinates. (Inherited from TExternalBase.)
Protected method | GetInputDataExtension | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the input data extension. (Inherited from TExternalBase.)
Protected method | GetInputDataExtensionKeys | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the available input data extension keys. (Inherited from TExternalBase.)
Protected method | GetInputDataIm | Protected function "GetInputDataRe", provided to the user DLL to obtain the imaginary part of the input data. (Inherited from TExternalBase.)
Protected method | GetInputDataRe | Protected function "GetInputDataRe", provided to the user DLL to obtain the real part of the input data. (Inherited from TExternalBase.)
Public method | getOutputCoordinates | Exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDataRe | Exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDescriptor | Exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL. (Inherited from TExternalBase.)
Public method | getProperties | Exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL. (Inherited from TExternalBase.)
Protected method | GetPropertyValue | (Deprecated) Protected function "GetPropertyValue", provided to the user DLL for retrieving the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be accessed like regular C# public properties. (Inherited from TExternalBase.)
Public method | GetType | (Inherited from Object.)
Public method | getViewerPanel | Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user Dll
Protected method | Init | Protected virtual function "Init", intended to be overridden by the inherited user DLL class to provide the initialization function. This function is called by the exported function getDllInfo. (Inherited from TExternalBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDoubleClick | Protected virtual function "OnDoubleClick", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function doubleClick which is in turn used by Visual Signal's ExternalDll module to handle callback when user double-clicked on the module. (Inherited from TExternalBase.)
Protected method | RegisterProperty | (Deprecated) Protected function "RegisterProperty", proved to the user DLL for registering properties used by the DLL computation. This function should be invoked in Init, and the registered properties will be passed to Visual Signal's ExternalDll module via getDllInfo and become available in the module's property dialog for editing. The current values will be communicated back and forth between ExternalDll module and the user DLL via setProperties(String) and getProperties exported functions. This is deprecated. Property values can now be defined like regular C# properties, with appropriate attributes attached to the properties to define their categories, display names, descriptions, etc. Properties must be public and browsable. (Inherited from TExternalBase.)
Public method | setBackColor | Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color
Protected method | SetExtendedInfo | Override protected function SetExtendedInfo(XmlDocument) to set additional viewer-specific root attributes. This function is called by the exported function getDllInfo. (Overrides TExternalBaseSetExtendedInfo(XmlDocument).)
Public method | setInputCoordinates | Exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDataIm | Exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDataRe | Exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDescriptors | Exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL. (Inherited from TExternalBase.)
Protected method | SetOutputCoords | Protected function "SetOutputCoords", provided to the user DLL to set the output coordinates. (Inherited from TExternalBase.)
Protected method | SetOutputDataExtension | Protected function "SetOutputDataExtension", provided to the user DLL to set the output data extension info. (Inherited from TExternalBase.)
Protected method | SetOutputDataIm | Protected function "SetOutputDataIm", provided to the user DLL to set the imaginary part of the output data. (Inherited from TExternalBase.)
Protected method | SetOutputDataRe | Protected function "SetOutputDataRe", provided to the user DLL to set the real part of the output data. (Inherited from TExternalBase.)
Public method | setProperties | Exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL. (Inherited from TExternalBase.)
Public method | setTitle | Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title
Public method | ToString | (Inherited from Object.)
Protected method | UpdateProperty | (Deprecated) Protected function "UpdateProperty", provided to the user DLL for updating the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be updated like regular C# public properties. (Inherited from TExternalBase.)
Protected method | UpdateViewerProperty | Virtual hook function "UpdateViewerProperty()". This function can be overridden in user's code to provide custom behaviour for updating viewer properties.
Top
Fields
 | Name | Description
Protected field | _autoResizeViewer | This protected member contains persistent AutoResizeViewer state which should be initialized in Init.
Protected field | _backColor | This protected member contains persistent BackColor state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _inputData | This protected member will be initialized and updated by Visual Signal's ExternalDll module via setInputDescriptors(String), setInputCoordinates(Int32, Int32, Object), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double). The user DLL can directly access the DllData objects to obtain the data descriptor information. (Inherited from TExternalBase.)
Protected field | _inputTypes | This protected member contains a table of TExternalBaseDllInputType objects which stores the parameters used by the DLL. The table (in the form of a List) should be initialized in Init using AcceptInput(). (Inherited from TExternalBase.)
Protected field | _outputData | This protected member should be initialized and updated in the user DLL's DoCompute function to contain the output data (only one allowed). (Inherited from TExternalBase.)
Protected field | _properties | (Deprecated) This protected member contains a table of TExternalBaseDllProperty objects which stores the parameters used by the DLL. The table (in the form of a Dictionary) should be initialized in Init using RegisterProperty(). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable. (Inherited from TExternalBase.)
Protected field | _props | This protected member contains a table of ExtensionProperty objects which stores the parameters used by the use's DLL, it is not necessary to access this object directly. Use RegisterProperty(String, Type, Object, String, String, String, String, Int32), GetPropertyValue(String), and UpdateProperty(String, Object) functions instead to initialize, get, and set properties. (Inherited from TExternalBase.)
Protected field | _showTitle | This protected member contains persistent ShowTitle state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _title | This protected member contains persistent Title state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _viewerPanel | This protected member contains the System.Windows.Forms.Panel-derived object which should be initialized in Init. This member can be accessed via the ViewerPanel proeprty.
Top
Properties
 | Name | Description
Public property | AutoResizeViewer | If this property is set to "True", instruct the Visual Signal viewer to resize itself base on the control's size If set to "False", Visual Signal will try to resize the control based on the viewer's size. This property should be set in Init.
Public property | BackColor | Get the viewer background color The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected property | InfoText | Set this property in Init to register the infoText of the user module. This will appear in Visual Signal as a tooltip for the DLL. (Inherited from TExternalBase.)
Protected property | LicenseManagerID | Set this property in Init to register the license manager ID. If a license manager matching the ID were found, Visual Signal will attempt to use license control for the user module. If the property is not set or set to an empty string, license control will not be used for the user module. (Inherited from TExternalBase.)
Protected property | LicenseName | Set this property in Init to register the license name. Visual Signal will attempt to match the license name against any license files loaded by the license manager. If no valid license file matches the license name, then the user module will not be available for use in Visual Signal. For security reasons, the module will also not be available if a license manager matching LicenseManagerID were *not* found. (Inherited from TExternalBase.)
Protected property | MinInputCount | Set this property in Init to register the minimum number of inputs acceptable by the user DmoduleLL. (Inherited from TExternalBase.)
Protected property | Name | Set this property in Init to register the name of the user module. (Inherited from TExternalBase.)
Public property | ShowTitle | Get whether to show the title in the viewer. The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Public property | Title | Get the viewer title string The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected property | Version | Set this property in Init to register the version of the user module. (Inherited from TExternalBase.)
Public property | ViewerPanel | Set the external vewer System.Windows.Forms.Panel object. This property should be set in Init.
Top
See Also

Reference

VSignal.ExternalBase Namespace

Copyright (c) 2007-2015, AnCAD, Inc., All Rights Reserved.

Send comments on this topic to support@ancad.com


TExternalViewer Constructor

TExternalViewer Constructor Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Initializes a new instance of the TExternalViewer class

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public TExternalViewer()
Public Sub New
public:
TExternalViewer()
new : unit -> TExternalViewer
See Also

Reference

TExternalViewer Class


TExternalViewer Fields

TExternalViewer Fields Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalViewer type exposes the following members.

Fields
 | Name | Description
Protected field | _autoResizeViewer | This protected member contains persistent AutoResizeViewer state which should be initialized in Init.
Protected field | _backColor | This protected member contains persistent BackColor state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _inputData | This protected member will be initialized and updated by Visual Signal's ExternalDll module via setInputDescriptors(String), setInputCoordinates(Int32, Int32, Object), setInputDataRe(Int32, Int32, Double), and setInputDataIm(Int32, Int32, Double). The user DLL can directly access the DllData objects to obtain the data descriptor information. (Inherited from TExternalBase.)
Protected field | _inputTypes | This protected member contains a table of TExternalBaseDllInputType objects which stores the parameters used by the DLL. The table (in the form of a List) should be initialized in Init using AcceptInput(). (Inherited from TExternalBase.)
Protected field | _outputData | This protected member should be initialized and updated in the user DLL's DoCompute function to contain the output data (only one allowed). (Inherited from TExternalBase.)
Protected field | _properties | (Deprecated) This protected member contains a table of TExternalBaseDllProperty objects which stores the parameters used by the DLL. The table (in the form of a Dictionary) should be initialized in Init using RegisterProperty(). This is deprecated. It is no longer necessary to access property object directly. Define and access the properties like any other C# property using appropriate attributes. Properties must be public and browsable. (Inherited from TExternalBase.)
Protected field | _props | This protected member contains a table of ExtensionProperty objects which stores the parameters used by the use's DLL, it is not necessary to access this object directly. Use RegisterProperty(String, Type, Object, String, String, String, String, Int32), GetPropertyValue(String), and UpdateProperty(String, Object) functions instead to initialize, get, and set properties. (Inherited from TExternalBase.)
Protected field | _showTitle | This protected member contains persistent ShowTitle state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _title | This protected member contains persistent Title state which will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected field | _viewerPanel | This protected member contains the System.Windows.Forms.Panel-derived object which should be initialized in Init. This member can be accessed via the ViewerPanel proeprty.
Top
See Also

Reference

TExternalViewer Class


TExternalViewer._autoResizeViewer Field

TExternalViewer_autoResizeViewer Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains persistent AutoResizeViewer state which should be initialized in Init.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected bool _autoResizeViewer
Protected _autoResizeViewer As Boolean
protected:
bool _autoResizeViewer
val mutable _autoResizeViewer: bool

Field Value

Type: Boolean
See Also

Reference

TExternalViewer Class


TExternalViewer._backColor Field

TExternalViewer_backColor Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains persistent BackColor state which will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Color _backColor
Protected _backColor As Color
protected:
Color _backColor
val mutable _backColor: Color

Field Value

Type: Color
See Also

Reference

TExternalViewer Class


TExternalViewer._showTitle Field

TExternalViewer_showTitle Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains persistent ShowTitle state which will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected bool _showTitle
Protected _showTitle As Boolean
protected:
bool _showTitle
val mutable _showTitle: bool

Field Value

Type: Boolean
See Also

Reference

TExternalViewer Class


TExternalViewer._title Field

TExternalViewer_title Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains persistent Title state which will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected string _title
Protected _title As String
protected:
String^ _title
val mutable _title: string

Field Value

Type: String
See Also

Reference

TExternalViewer Class


TExternalViewer._viewerPanel Field

TExternalViewer_viewerPanel Field Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

This protected member contains the System.Windows.Forms.Panel-derived object which should be initialized in Init. This member can be accessed via the ViewerPanel proeprty.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected Panel _viewerPanel
Protected _viewerPanel As Panel
protected:
Panel^ _viewerPanel
val mutable _viewerPanel: Panel

Field Value

Type: Panel
See Also

Reference

TExternalViewer Class


TExternalViewer Methods

TExternalViewer Methods Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalViewer type exposes the following members.

Methods
 | Name | Description
Protected method | AcceptInput(TExternalBaseInputDataTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not. (Inherited from TExternalBase.)
Protected method | AcceptInput(TExternalBaseInputDataTypes, Int32, TExternalBaseInputCoordinateTypes, TExternalBaseInputChannelTypes, TExternalBaseInputValueTypes) | Protected function "AcceptInput", proved to the user DLL for registering input types acceptable by the DLL for computation. This function should be invoked in Init, and the registered acceptable input types will be passed to Visual Signal's ExternalDll module via getDllInfo. Visual Signal will use this information to determine whether an input connection is valid or not. (Inherited from TExternalBase.)
Public method | compute | Interface for exported function "compute", used by Visual Signal's ExternalDll module to execute the actual computation provided by the user DLL. This function just calls the protected function DoCompute, which the user DLL must override with own implementation. External properties, input and output data are processed by Visual Signal before and after the execution of this function. User should expect _inputData to contain the input data and update _outputData to sent to Visual Signal. User should also expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal. (Inherited from TExternalBase.)
Protected method | DoCompute | Protected virtual function "DoCompute", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function compute which is in turn used by Visual Signal's ExternalDll module to start computation. (Inherited from TExternalBase.)
Public method | doubleClick | Interface for exported function "doubleClick", used by Visual Signal's ExternalDll module to handle the callback when user double-clicks the corresponding Visual Signal component. This function just calls the protected function OnDoubleClick, which the user DLL can override with own implementation. Like compute, external properties are processed by Visual Signal before and after the execution of this function; however, input and output data are not processed. User should expect _properties to contain properties from Visual Signal and use UpdateProperty(String, Object) to update properties to Visual Signal. (Inherited from TExternalBase.)
Public method | Equals | (Inherited from Object.)
Protected method | Finalize | (Inherited from Object.)
Public method | getDllInfo | Exported function "getDllInfo()", used by Visual Signal's ExternalDll module to obtain DLL info such as name, version, API version, language, license control and properties. (Inherited from TExternalBase.)
Public method | GetHashCode | (Inherited from Object.)
Protected method | GetInputCoords | Protected function "GetInputCoords", provided to the user DLL to obtain the input coordinates. (Inherited from TExternalBase.)
Protected method | GetInputDataExtension | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the input data extension. (Inherited from TExternalBase.)
Protected method | GetInputDataExtensionKeys | Protected function "GetInputDataExtensionKeys", provided to the user DLL to obtain the available input data extension keys. (Inherited from TExternalBase.)
Protected method | GetInputDataIm | Protected function "GetInputDataRe", provided to the user DLL to obtain the imaginary part of the input data. (Inherited from TExternalBase.)
Protected method | GetInputDataRe | Protected function "GetInputDataRe", provided to the user DLL to obtain the real part of the input data. (Inherited from TExternalBase.)
Public method | getOutputCoordinates | Exported function "getOutputCoordinates", used by Visual Signal's ExternalDll module to obtain the output data coordinates from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDataIm | Interface for exported function "getOutputDataIm", used by Visual Signal's ExternalDll module to obtain the output data (imaginary part) from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDataRe | Exported function "getOutputDataRe", used by Visual Signal's ExternalDll module to obtain the output data (real part) from the user DLL. (Inherited from TExternalBase.)
Public method | getOutputDescriptor | Exported function "getOutputDescriptor", used by Visual Signal's ExternalDll module to obtain output descriptor from the user DLL. (Inherited from TExternalBase.)
Public method | getProperties | Exported function "getProperties", used by Visual Signal's ExternalDll module to obtain property values from the user DLL. (Inherited from TExternalBase.)
Protected method | GetPropertyValue | (Deprecated) Protected function "GetPropertyValue", provided to the user DLL for retrieving the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be accessed like regular C# public properties. (Inherited from TExternalBase.)
Public method | GetType | (Inherited from Object.)
Public method | getViewerPanel | Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user Dll
Protected method | Init | Protected virtual function "Init", intended to be overridden by the inherited user DLL class to provide the initialization function. This function is called by the exported function getDllInfo. (Inherited from TExternalBase.)
Protected method | MemberwiseClone | (Inherited from Object.)
Protected method | OnDoubleClick | Protected virtual function "OnDoubleClick", intended to be overridden by the inherited user DLL class to provide the actual computation. This function is called by the exported function doubleClick which is in turn used by Visual Signal's ExternalDll module to handle callback when user double-clicked on the module. (Inherited from TExternalBase.)
Protected method | RegisterProperty | (Deprecated) Protected function "RegisterProperty", proved to the user DLL for registering properties used by the DLL computation. This function should be invoked in Init, and the registered properties will be passed to Visual Signal's ExternalDll module via getDllInfo and become available in the module's property dialog for editing. The current values will be communicated back and forth between ExternalDll module and the user DLL via setProperties(String) and getProperties exported functions. This is deprecated. Property values can now be defined like regular C# properties, with appropriate attributes attached to the properties to define their categories, display names, descriptions, etc. Properties must be public and browsable. (Inherited from TExternalBase.)
Public method | setBackColor | Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color
Protected method | SetExtendedInfo | Override protected function SetExtendedInfo(XmlDocument) to set additional viewer-specific root attributes. This function is called by the exported function getDllInfo. (Overrides TExternalBaseSetExtendedInfo(XmlDocument).)
Public method | setInputCoordinates | Exported function "setInputCoordinates", used by Visual Signal's ExternalDll module to set input coordinates in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDataIm | Exported function "setInputDataIm", used by Visual Signal's ExternalDll module to set the input data (imaginary part) in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDataRe | Exported function "setInputDataRe", used by Visual Signal's ExternalDll module to set the input data (real part) in the user DLL. (Inherited from TExternalBase.)
Public method | setInputDescriptors | Exported function "setInputDescriptors", used by Visual Signal's ExternalDll module to set input descriptors in the user DLL. (Inherited from TExternalBase.)
Protected method | SetOutputCoords | Protected function "SetOutputCoords", provided to the user DLL to set the output coordinates. (Inherited from TExternalBase.)
Protected method | SetOutputDataExtension | Protected function "SetOutputDataExtension", provided to the user DLL to set the output data extension info. (Inherited from TExternalBase.)
Protected method | SetOutputDataIm | Protected function "SetOutputDataIm", provided to the user DLL to set the imaginary part of the output data. (Inherited from TExternalBase.)
Protected method | SetOutputDataRe | Protected function "SetOutputDataRe", provided to the user DLL to set the real part of the output data. (Inherited from TExternalBase.)
Public method | setProperties | Exported function "setProperties", used by Visual Signal's ExternalDll module to set property values in the user DLL. (Inherited from TExternalBase.)
Public method | setTitle | Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title
Public method | ToString | (Inherited from Object.)
Protected method | UpdateProperty | (Deprecated) Protected function "UpdateProperty", provided to the user DLL for updating the current property values. This function is usually invoked in the DoCompute function after the computation stage. This is deprecated. Property values can now be updated like regular C# public properties. (Inherited from TExternalBase.)
Protected method | UpdateViewerProperty | Virtual hook function "UpdateViewerProperty()". This function can be overridden in user's code to provide custom behaviour for updating viewer properties.
Top
See Also

Reference

TExternalViewer Class


TExternalViewer.getViewerPanel Method

TExternalViewergetViewerPanel Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "getViewerPanel()", used by Visual Signal's ExternalViewer module to obtain external viewer object created by the user Dll

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Panel getViewerPanel()
Public Function getViewerPanel As Panel
public:
virtual Panel^ getViewerPanel() sealed
abstract getViewerPanel : unit -> Panel
override getViewerPanel : unit -> Panel

Return Value

Type: Panel
Returns the external System.Windows.Forms.Panel object.

Implements

IExternalViewergetViewerPanel
See Also

Reference

TExternalViewer Class


TExternalViewer.setBackColor Method

TExternalViewersetBackColor Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setBackColor()", used by Visual Signal's ExternalViewer module to set external viewer background color

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setBackColor(
    Color color
)
Public Sub setBackColor (
    color As Color
)
public:
virtual void setBackColor(
    Color color
) sealed
abstract setBackColor :
        color : Color -> unit
override setBackColor :
        color : Color -> unit

Parameters

color
Type: System.DrawingColor
Specifies the background System.Draawing.Color.

Implements

IExternalViewersetBackColor(Color)
See Also

Reference

TExternalViewer Class


TExternalViewer.SetExtendedInfo Method

TExternalViewerSetExtendedInfo Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Override protected function SetExtendedInfo(XmlDocument) to set additional viewer-specific root attributes. This function is called by the exported function getDllInfo.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected override void SetExtendedInfo(
    XmlDocument xdoc
)
Protected Overrides Sub SetExtendedInfo (
    xdoc As XmlDocument
)
protected:
virtual void SetExtendedInfo(
    XmlDocument^ xdoc
) override
abstract SetExtendedInfo :
        xdoc : XmlDocument -> unit
override SetExtendedInfo :
        xdoc : XmlDocument -> unit

Parameters

xdoc
Type: System.XmlXmlDocument
Specifies the XML document containing the module info.
See Also

Reference

TExternalViewer Class


TExternalViewer.setTitle Method

TExternalViewersetTitle Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Exported function "setTitle()", used by Visual Signal's ExternalViewer module to set external viewer title

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public void setTitle(
    string title,
    bool showTitle
)
Public Sub setTitle (
    title As String,
    showTitle As Boolean
)
public:
virtual void setTitle(
    String^ title,
    bool showTitle
) sealed
abstract setTitle :
        title : string *
        showTitle : bool -> unit
override setTitle :
        title : string *
        showTitle : bool -> unit

Parameters

title
Type: SystemString
showTitle
Type: SystemBoolean

Implements

IExternalViewersetTitle(String, Boolean)
See Also

Reference

TExternalViewer Class


TExternalViewer.UpdateViewerProperty Method

TExternalViewerUpdateViewerProperty Method Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Virtual hook function "UpdateViewerProperty()". This function can be overridden in user's code to provide custom behaviour for updating viewer properties.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
protected virtual void UpdateViewerProperty()
Protected Overridable Sub UpdateViewerProperty
protected:
virtual void UpdateViewerProperty()
abstract UpdateViewerProperty : unit -> unit
override UpdateViewerProperty : unit -> unit
See Also

Reference

TExternalViewer Class


TExternalViewer Properties

TExternalViewer Properties Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

The TExternalViewer type exposes the following members.

Properties
 | Name | Description
Public property | AutoResizeViewer | If this property is set to "True", instruct the Visual Signal viewer to resize itself base on the control's size If set to "False", Visual Signal will try to resize the control based on the viewer's size. This property should be set in Init.
Public property | BackColor | Get the viewer background color The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected property | InfoText | Set this property in Init to register the infoText of the user module. This will appear in Visual Signal as a tooltip for the DLL. (Inherited from TExternalBase.)
Protected property | LicenseManagerID | Set this property in Init to register the license manager ID. If a license manager matching the ID were found, Visual Signal will attempt to use license control for the user module. If the property is not set or set to an empty string, license control will not be used for the user module. (Inherited from TExternalBase.)
Protected property | LicenseName | Set this property in Init to register the license name. Visual Signal will attempt to match the license name against any license files loaded by the license manager. If no valid license file matches the license name, then the user module will not be available for use in Visual Signal. For security reasons, the module will also not be available if a license manager matching LicenseManagerID were *not* found. (Inherited from TExternalBase.)
Protected property | MinInputCount | Set this property in Init to register the minimum number of inputs acceptable by the user DmoduleLL. (Inherited from TExternalBase.)
Protected property | Name | Set this property in Init to register the name of the user module. (Inherited from TExternalBase.)
Public property | ShowTitle | Get whether to show the title in the viewer. The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Public property | Title | Get the viewer title string The value will be updated from Visual Signal viewer properties before DoCompute is executed.
Protected property | Version | Set this property in Init to register the version of the user module. (Inherited from TExternalBase.)
Public property | ViewerPanel | Set the external vewer System.Windows.Forms.Panel object. This property should be set in Init.
Top
See Also

Reference

TExternalViewer Class


TExternalViewer.AutoResizeViewer Property

TExternalViewerAutoResizeViewer Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

If this property is set to "True", instruct the Visual Signal viewer to resize itself base on the control's size If set to "False", Visual Signal will try to resize the control based on the viewer's size. This property should be set in Init.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool AutoResizeViewer { set; }
Public WriteOnly Property AutoResizeViewer As Boolean
    Set
public:
property bool AutoResizeViewer {
    void set (bool value);
}
member AutoResizeViewer : bool with set

Property Value

Type: Boolean
See Also

Reference

TExternalViewer Class


TExternalViewer.BackColor Property

TExternalViewerBackColor Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get the viewer background color The value will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Color BackColor { get; }
Public ReadOnly Property BackColor As Color
    Get
public:
property Color BackColor {
    Color get ();
}
member BackColor : Color with get

Property Value

Type: Color
See Also

Reference

TExternalViewer Class


TExternalViewer.ShowTitle Property

TExternalViewerShowTitle Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get whether to show the title in the viewer. The value will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public bool ShowTitle { get; }
Public ReadOnly Property ShowTitle As Boolean
    Get
public:
property bool ShowTitle {
    bool get ();
}
member ShowTitle : bool with get

Property Value

Type: Boolean
See Also

Reference

TExternalViewer Class


TExternalViewer.Title Property

TExternalViewerTitle Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Get the viewer title string The value will be updated from Visual Signal viewer properties before DoCompute is executed.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
public:
property String^ Title {
    String^ get ();
}
member Title : string with get

Property Value

Type: String
See Also

Reference

TExternalViewer Class


TExternalViewer.ViewerPanel Property

TExternalViewerViewerPanel Property Visual Signal ExternalBase Class Library Documentation
API version 1.5.2

[This is preliminary documentation and is subject to change.]

Set the external vewer System.Windows.Forms.Panel object. This property should be set in Init.

Namespace: VSignal.ExternalBase
Assembly: vsmExternalBase (in vsmExternalBase.dll) Version: 1.6.0.0
Syntax
C#
VB
C++
F#
Copy
public Panel ViewerPanel { set; }
Public WriteOnly Property ViewerPanel As Panel
    Set
public:
property Panel^ ViewerPanel {
    void set (Panel^ value);
}
member ViewerPanel : Panel with set

Property Value

Type: Panel
See Also

Reference

TExternalViewer Class